PDA

View Full Version : 65 Ironhead lights


vetterdog
3rd June 2005, 16:05
Hey there, I have a quick question for you, I hope you can help. I have a 65 Ironhead, no battery. The lights are wired off of the voltage regulator, through a battery eliminator capacitor, on to the light switch. When I crack the throttle, the lights blow out, front and rear. Ten bucks down the crapper. I have no idea how to wire this differently. Other ways I have tried leave me with no lights at all. I thought the battery eliminator would prevent this, but it doesn't. Is there a ground I'm missing? Thanks for your help and time. -Dave Vetter

dabronco
3rd June 2005, 16:46
Which terminal are you using on the regulator? Measure with a volt meter to see just how many volts you are putting out to the light.

dwardy
3rd June 2005, 16:49
Yep it sounds like either you are connected to the input of the regulator or your regulator has gone south.

vetterdog
3rd June 2005, 18:46
It's run out of the B+ output terminal, just like in the wiring diagram, but the voltage surges like all get out when the throttle is revved. All the other terminals on the regulator are wired correctly also. Voltage regulator shot? Thanks for your time and know-how. Dave

dabronco
3rd June 2005, 18:51
I think your regulator is N.F.G.

geraldxlch
4th June 2005, 16:14
had the same problem, new regulator solved it.

vetterdog
4th June 2005, 16:16
Thanks fellas, I have ordered a new regulator. -vetterdog

vetterdog
14th June 2005, 03:00
I can ride at night now! Regulator fixed it, thanks again. vetterdog