The Sportster and Buell Motorcycle Forum - The XLFORUM®
 

Go Back   The Sportster and Buell Motorcycle Forum - The XLFORUM® > Blogs > Angell57
XLF Blogs XLF Arcade XLF Disclaimer/Privacy Statement/Terms Of Use

Notices

Active Threads
0 Do you use premium gas in your Sportster?
Last Post: spitfirechopper
Posted On: 2 Minutes Ago
Replies: 1,670
Views: 305,496
0 Official XL Forum Random Image Thread (NO NUDITY!)
Last Post: Stairman
Posted On: 6 Minutes Ago
Replies: 40,472
Views: 6,207,888
0 Do you run MAXIMUM PSI?!?
Last Post: Edster
Posted On: 9 Minutes Ago
Replies: 266
Views: 37,519
7 Hello from Spain
Last Post: hoggy
Posted On: 22 Minutes Ago
Replies: 13
Views: 219
0 Can’t get upper triple tree removed. Advice?
Last Post: Nate.evans
Posted On: 40 Minutes Ago
Replies: 2
Views: 73
0 Brake cable on 72 xlch forward controls
Last Post: shovithead
Posted On: 40 Minutes Ago
Replies: 12
Views: 159
0 Timing issue
Last Post: doodah man
Posted On: 48 Minutes Ago
Replies: 3
Views: 133
0 Food porn
Last Post: lugster
Posted On: 1 Hour Ago
Replies: 671
Views: 72,558
0 What did you do for your sporty Today?
Last Post: Crusty
Posted On: 1 Hour Ago
Replies: 5,128
Views: 542,625
0 Anyone go racing last weekend?
Last Post: Slojoe55
Posted On: 1 Hour Ago
Replies: 2,591
Views: 229,651
0 THE Trainspotting Thread
Last Post: Stairman
Posted On: 2 Hours Ago
Replies: 1,940
Views: 192,476
0 Hottie of the day, no nudity.
Last Post: Stairman
Posted On: 2 Hours Ago
Replies: 6,504
Views: 461,057
14 Firearms you wish you owned.
Last Post: Stairman
Posted On: 2 Hours Ago
Replies: 406
Views: 57,732
0 Shotgun Porn
Last Post: Stairman
Posted On: 2 Hours Ago
Replies: 730
Views: 90,713
0 my '82 XLS Roadster project
Last Post: N-Rico
Posted On: 3 Hours Ago
Replies: 0
Views: 32
0 Let's See Them R's!!
Last Post: grako122
Posted On: 3 Hours Ago
Replies: 1,490
Views: 529,535
0 Sportster fans, tell us why!
Last Post: Skuzeee
Posted On: 5 Hours Ago
Replies: 566
Views: 147,547
0 The forum got talent
Last Post: Skuzeee
Posted On: 6 Hours Ago
Replies: 26
Views: 1,197
0 900 heads contd..
Last Post: brucstoudt
Posted On: 7 Hours Ago
Replies: 27
Views: 1,376
0 Oil and smoke everywhere
Last Post: fbroos73
Posted On: 8 Hours Ago
Replies: 21
Views: 612
0 65B genr8r I hecked up
Last Post: Kaptain
Posted On: 8 Hours Ago
Replies: 0
Views: 42
0 attn DR DICK
Last Post: doodah man
Posted On: 8 Hours Ago
Replies: 10
Views: 613
0 Fixing a loose mirror
Last Post: Yochstein
Posted On: 9 Hours Ago
Replies: 0
Views: 58
0 Timing after dynatek 2000i install
Last Post: jordan1200
Posted On: 9 Hours Ago
Replies: 5
Views: 96
0 2020 H-D response to the Indian FTR1200?
Last Post: felis
Posted On: 9 Hours Ago
Replies: 23
Views: 1,026
0 Oil pump working, no oil to rockers
Last Post: shovithead
Posted On: 10 Hours Ago
Replies: 1
Views: 138
0 project 74 sporty
Last Post: the cowboy way
Posted On: 10 Hours Ago
Replies: 6
Views: 428
0 Aligning ‘14-newer OEM exhaust?
Last Post: jzink0883
Posted On: 10 Hours Ago
Replies: 2
Views: 159
0 Front brake combination not working well. Suggestions?
Last Post: sml1226
Posted On: 11 Hours Ago
Replies: 15
Views: 418
0 JACKHAMMER 570 Cams!
Last Post: md1200
Posted On: 11 Hours Ago
Replies: 152
Views: 40,591
More...
Members Birthdays
sflier, dubi1946, unclesumo (61), 81ironsporty (59), cheyenne71597 (58), akk (58), MDRide, JohnK (54), 86stang (53), Dusty1985 (33), evokid8 (27)
Rate this Entry

Lovin it

Submit "Lovin it" to Facebook Submit "Lovin it" to Google
Posted 2nd March 2014 at 15:04 by Angell57

I bought my bike last summer. I havent owned a bike since I was about 20...and that has been quite a few years ago now as I just turned 57! Anyway when I bought this bike it wasnt running. I had seen it run. The PO was a mechanic I worked with at one time and he needed money and really didnt want to mess with the bike. I threw a few parts at it and got it running only to discover that oil was pouring out from the top of the motor. Having no experience with these bikes I went to the internet and thats when I came across this site. It has been a life saver. So far any problem I've had someone on here has had an answer for. I finally found the leak...the PO, you know, the "mechanic", had taken the starter out and never put a gasket on it when he put it back together. BRILLIANT! I rode it for about 2 months and totally fell in love ! Took my last ride in Dec. and then tore it completeley apart for a total rebuild. I now have all the parts and am starting on puttin her back together. Spring is coming fast and I dont want to miss a day of riding!
Posted in Uncategorized
Views 3123 Comments 0
« Prev     Main     Next »
Total Comments 0

Comments

 


Sponsored Links
All times are GMT +1. The time now is 13:28.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
XL Forum® - Linson Media LLC