Thread: Rubbermount_EVO Sloppy up-shifting when hot?
View Single Post
  #1  
Old 4th August 2021
Oli1200's Avatar
Oli1200 Oli1200 is offline
Chief Know It All
 
Join Date: Aug 2007
Posts: 425
Reputation: 15257
Oli1200 is a glorious beacon of lightOli1200 is a glorious beacon of lightOli1200 is a glorious beacon of lightOli1200 is a glorious beacon of lightOli1200 is a glorious beacon of lightOli1200 is a glorious beacon of lightOli1200 is a glorious beacon of lightOli1200 is a glorious beacon of lightOli1200 is a glorious beacon of lightOli1200 is a glorious beacon of lightOli1200 is a glorious beacon of light
Default Sloppy up-shifting when hot?

2004 1200. Replaced my clutch in 2016 with the extra plate Barnett kit.

For the last couple seasons Ive noticed my upshifting is becoming more labored and I'm missing shifts more often in mid-high rpm range. Downshifting there's no problem. With forwards and mid controls. It feels the gears feel sloppy and theres no real feeling of definite engagement when upshifting. I thought it might be just rider error but it's definitely not that. I'm seemingly having to focus more on my upshifting to get cleaner shifts. Again it happens more when the bike gets hot and Ive been riding for 15-20 mins. Im not getting any strange noises when shifting.

I've re-adjusted the primary chain, inner clutch, hand lever and fluid level by the book too many times at this point. Theres something wrong.

Could it just be my barnett clutch burning out? Hoping it's not a tranny issue.

Thanks for all replies.
Reply With Quote