The Sportster and Buell Motorcycle Forum - The XLFORUM®
 

Go Back   The Sportster and Buell Motorcycle Forum - The XLFORUM® > SPORTSTER MOTORCYCLE FORUM > Sportster Motorcycle Electrical > Sportster Motorcycle Electrical and Ignition
XLF Blogs XLF Arcade XLF Disclaimer/Privacy Statement/Terms Of Use

Active Threads
0 Info needed on mini sumps.
Last Post: thefrenchowl
Posted On: 7 Minutes Ago
Replies: 41
Views: 1,692
0 Ground Up Beginner Build
Last Post: Hippysmack
Posted On: 1 Hour Ago
Replies: 1
Views: 20
0 Chinese S&S carbs
Last Post: Highly-Dangerous
Posted On: 1 Hour Ago
Replies: 51
Views: 1,822
0 ....1
Last Post: Highly-Dangerous
Posted On: 1 Hour Ago
Replies: 5,561
Views: 323,825
0 "S" model specific Q&A
Last Post: Paul.W
Posted On: 1 Hour Ago
Replies: 1,981
Views: 403,865
0 Learning Wrenching Resources?
Last Post: Paul.W
Posted On: 1 Hour Ago
Replies: 21
Views: 1,069
0 Tappet blocks and tappets
Last Post: Ferrous Head
Posted On: 1 Hour Ago
Replies: 19
Views: 441
0 XR mutt race bike progress
Last Post: Ferrous Head
Posted On: 1 Hour Ago
Replies: 22
Views: 1,057
0 My Rear Master Cylinder Re-build
Last Post: Hippysmack
Posted On: 2 Hours Ago
Replies: 120
Views: 68,929
0 Sportster Fork Upgrade
Last Post: PetesPonies
Posted On: 3 Hours Ago
Replies: 53
Views: 15,544
0 Real Horse Power Difference in Head Treatments
Last Post: rocketmangb
Posted On: 3 Hours Ago
Replies: 9
Views: 99
0 Proven external Fuel pump and regulator
Last Post: Iron Mike
Posted On: 4 Hours Ago
Replies: 16
Views: 175
0 WANTED, Mid Controls for 2002, 883 Sportster
Last Post: tylermiller
Posted On: 4 Hours Ago
Replies: 4
Views: 134
0 Why No Tachometer?
Last Post: Oldmxdog61u
Posted On: 5 Hours Ago
Replies: 45
Views: 2,008
0 Brotherhood of the traveling lid
Last Post: Maxeffort
Posted On: 5 Hours Ago
Replies: 7
Views: 173
0 Average age of the Ironhead forum users
Last Post: BigLerowski
Posted On: 6 Hours Ago
Replies: 465
Views: 98,870
0 HOW BIG? Mikuni on a 1250 kit?
Last Post: rocketmangb
Posted On: 6 Hours Ago
Replies: 15
Views: 252
0 2020 east coast meet and greet.
Last Post: BKB
Posted On: 6 Hours Ago
Replies: 96
Views: 8,503
0 Keep & Kill
Last Post: Crusty
Posted On: 6 Hours Ago
Replies: 17,501
Views: 1,012,237
0 Dual Speedo/Tach Gauge Mount Failure
Last Post: Edster
Posted On: 8 Hours Ago
Replies: 5
Views: 134
0 What did you do for your sporty Today?
Last Post: sportsterpaul
Posted On: 8 Hours Ago
Replies: 6,971
Views: 988,461
0 Coil readings
Last Post: IXL2Relax
Posted On: 8 Hours Ago
Replies: 8
Views: 198
0 New guy from IL
Last Post: Bow only
Posted On: 8 Hours Ago
Replies: 9
Views: 109
0 Top end failure
Last Post: Tipofthelake
Posted On: 8 Hours Ago
Replies: 25
Views: 918
0 Valve Lengths?
Last Post: brucstoudt
Posted On: 9 Hours Ago
Replies: 7
Views: 230
0 3/4” Axle Drum Brake ??
Last Post: Tim The Grim
Posted On: 9 Hours Ago
Replies: 7
Views: 225
0 primary cover
Last Post: IXL2Relax
Posted On: 9 Hours Ago
Replies: 2
Views: 171
0 Why such heavy oil in Sportster?
Last Post: shanneba
Posted On: 10 Hours Ago
Replies: 39
Views: 1,223
0 Andrews 5th Gear Mainshaft Swap
Last Post: Diemos
Posted On: 10 Hours Ago
Replies: 0
Views: 38
0 Hottie of the day, no nudity.
Last Post: Stairman
Posted On: 10 Hours Ago
Replies: 20,048
Views: 2,042,991
More...
Members Birthdays
daggar rider, The Brit (67), MGN54 (66), beau-kat, bkmthdff (55), af_sting (51), ofo (49), LOSTHIGHWAY420 (46), coxja (40), rickeybyrd (35)
Tags
battery, electrical, generator, ignition

Reply
 
Share Thread Tools Display Modes
  #1  
Old 8th April 2012
wmubrent wmubrent is offline
Biker
 
Join Date: Apr 2012
Posts: 7
Sportster/Buell Model: xl
Sportster/Buell Year: 1975
Reputation: 10
wmubrent is an unknown quantity at this point
Default Generator Light on after key Removed

I am a total noob, this is my first thread.
I have a '75 sportster. Old battery had dead cell. Installed new battery, ran bike out for short ride, got back into the garage and turned off the key.
The generator Light is still on.
If I turn the key to the accessory? (middle) position the Generator light goes off, but the oil pressure light comes on, as well as head and tail lamps.
With the key in the off position or removed, if I touch the negative battery cable to the post I hear and feel a click coming from the generator and the light clicks on.
I have read about charging? The generator but don't know what it means or if this pertains to my issue.
I am sure this could be caused by one of several things, just looking for some help with where to start!
Thanks guys!
Reply With Quote
  #2  
Old 9th April 2012
bustert's Avatar
bustert bustert is offline
XL FORUM TEAM MEMBER
 
Join Date: Jul 2008
Posts: 9,970
Sportster/Buell Model: 1200s
Sportster/Buell Year: 2001
Sportster/Buell Model #2: xlch
Sportster/Buell Year #2: 1974
Reputation: 3254109
bustert has a reputation beyond reputebustert has a reputation beyond reputebustert has a reputation beyond reputebustert has a reputation beyond reputebustert has a reputation beyond reputebustert has a reputation beyond reputebustert has a reputation beyond reputebustert has a reputation beyond reputebustert has a reputation beyond reputebustert has a reputation beyond reputebustert has a reputation beyond repute
Default

sounds like a bad ign sw. due to the light issue. the gen light grounds through the generator ground brush from the regulator, when gen output is above batt. voltage, the light will go out. could be shorted somewhere in the circuit.
Reply With Quote
  #3  
Old 14th April 2012
wmubrent wmubrent is offline
Biker
 
Join Date: Apr 2012
Posts: 7
Sportster/Buell Model: xl
Sportster/Buell Year: 1975
Reputation: 10
wmubrent is an unknown quantity at this point
Default

Bought new ignition switch, problem still exists. Even if I disconnect all the wires to the ignition switch and connect both battery cables, my generator still lights up.

What other components are connected to positive and negative battery, that are not disabled thru the ignition switch? How can I test with a volt meter, I mean what am I looking for?
Reply With Quote
  #4  
Old 14th April 2012
wmubrent wmubrent is offline
Biker
 
Join Date: Apr 2012
Posts: 7
Sportster/Buell Model: xl
Sportster/Buell Year: 1975
Reputation: 10
wmubrent is an unknown quantity at this point
Default

Okay, if I disconnect the battery + connection at the Regulator, the generator light goes off. Could this mean bad solenoid or bad Regulator?
Reply With Quote
  #5  
Old 15th April 2012
sportytrash's Avatar
sportytrash sportytrash is offline
Senior Chief Harley Engineer
 
Join Date: Jun 2010
Location: south of 70
Posts: 1,041
Sportster/Buell Model: xlh
Sportster/Buell Year: 93
Other Motorcycle Model: '72 Bonnie
Reputation: 58452
sportytrash is a splendid one to beholdsportytrash is a splendid one to beholdsportytrash is a splendid one to beholdsportytrash is a splendid one to beholdsportytrash is a splendid one to beholdsportytrash is a splendid one to beholdsportytrash is a splendid one to beholdsportytrash is a splendid one to beholdsportytrash is a splendid one to beholdsportytrash is a splendid one to beholdsportytrash is a splendid one to behold
Default

Been a awhile think a stuck mechanical regulator will do this. Has it been polorized ? Gently rap it with rubber mallet. Maybe physicaly open contacts. connect battery and polorize regulator.
Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT +1. The time now is 08:55.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
XL Forum® - Linson Media LLC