The Sportster and Buell Motorcycle Forum - The XLFORUM®
 

Go Back   The Sportster and Buell Motorcycle Forum - The XLFORUM® > SPORTSTER MOTORCYCLE FORUM > Sportster Motorcycle Era Specific and Model Specific > EFI Sportster Motorcycle Talk (2007 and up)
XLF Blogs XLF Arcade XLF Disclaimer/Privacy Statement/Terms Of Use

Notices

EFI Sportster Motorcycle Talk (2007 and up) For 2007 and above Sportsters

Active Threads
0 Lets see your off season builds
Last Post: mac93
Posted On: 6 Minutes Ago
Replies: 1,093
Views: 114,646
0 runs-on after kill button pressed
Last Post: Folkie
Posted On: 11 Minutes Ago
Replies: 14
Views: 369
0 Do the Gel Seat Pads work??
Last Post: Antares1965
Posted On: 14 Minutes Ago
Replies: 7
Views: 393
0 Food porn
Last Post: Stairman
Posted On: 25 Minutes Ago
Replies: 767
Views: 90,556
0 Anyone go racing last weekend?
Last Post: cycowrencher
Posted On: 35 Minutes Ago
Replies: 2,714
Views: 245,797
0 Exhaust Wrap Questions
Last Post: Glamazon
Posted On: 39 Minutes Ago
Replies: 8
Views: 126
0 Official XL Forum Random Image Thread (NO NUDITY!)
Last Post: Stairman
Posted On: 41 Minutes Ago
Replies: 41,206
Views: 6,317,619
0 Hottie of the day, no nudity.
Last Post: Stairman
Posted On: 1 Hour Ago
Replies: 7,585
Views: 556,811
0 O2 Sensor, p/n 27719-07, is it 12mm or 18mm ? - 2011 XL1200CP
Last Post: lucifer_mr2
Posted On: 1 Hour Ago
Replies: 2
Views: 121
0 Crusty's Travels
Last Post: SonWon
Posted On: 2 Hours Ago
Replies: 1,511
Views: 152,492
0 C.O.B.B run west
Last Post: decman
Posted On: 2 Hours Ago
Replies: 210
Views: 15,688
0 Big bore stroker - the beginning of a 10-year long build
Last Post: RKN
Posted On: 2 Hours Ago
Replies: 727
Views: 64,350
0 Show your favorite pic of your bike. just one
Last Post: Yakcm2
Posted On: 3 Hours Ago
Replies: 4,686
Views: 1,735,703
0 Greetings from Mobile, Alabama
Last Post: jharback
Posted On: 4 Hours Ago
Replies: 12
Views: 178
0 New Member
Last Post: juzyHD
Posted On: 4 Hours Ago
Replies: 11
Views: 126
0 Sportster Harley Saddlebags
Last Post: Jcolleyoh
Posted On: 4 Hours Ago
Replies: 1
Views: 101
0 Big Bore Kit - What else is needed
Last Post: Cropduster
Posted On: 5 Hours Ago
Replies: 20
Views: 653
0 Boardtracker Project
Last Post: JonesL
Posted On: 5 Hours Ago
Replies: 540
Views: 96,479
0 remap. Y/N?
Last Post: Nibelungen
Posted On: 5 Hours Ago
Replies: 21
Views: 6,253
0 I finally learned how to work the system!
Last Post: brianbbs67
Posted On: 5 Hours Ago
Replies: 6
Views: 162
0 Spark Plugs
Last Post: brianbbs67
Posted On: 5 Hours Ago
Replies: 11
Views: 482
0 new (to me) '82 25th Anniversary Edition XLH 1000
Last Post: brianbbs67
Posted On: 6 Hours Ago
Replies: 41
Views: 1,345
0 Handlebars: stock Iron/48 vs Chumps
Last Post: Freud
Posted On: 6 Hours Ago
Replies: 3
Views: 569
0 Sportster fenders and fuel tank
Last Post: sportsterpaul
Posted On: 6 Hours Ago
Replies: 6
Views: 257
0 Divorced Ironhead project.
Last Post: brianbbs67
Posted On: 6 Hours Ago
Replies: 22
Views: 2,927
0 Sizing cylinders too pistons
Last Post: Yakcm2
Posted On: 7 Hours Ago
Replies: 9
Views: 297
0 You asked for it! "The Tess' Coffee Thread"
Last Post: sportsterpaul
Posted On: 7 Hours Ago
Replies: 10,242
Views: 670,625
0 Tail Light Dying While Riding
Last Post: tigger
Posted On: 8 Hours Ago
Replies: 2
Views: 54
0 Cafe' Image thread WTFN
Last Post: tigger
Posted On: 8 Hours Ago
Replies: 5,079
Views: 2,195,033
0 How many miles do you have on your rubbermount?
Last Post: ParrotHead
Posted On: 8 Hours Ago
Replies: 384
Views: 70,632
More...
Members Birthdays
epconde (61), floydfan222 (58), Brian (53), Rondall (53), Nightster Man, Scarecrow2311 (49), thatbikerguy (49), SprtyGirl (47), freecdp45 (47), rxr, addy76 (42), sportster883r (38), Steeljester (37), 98xl1200s (32)
Sponsored Links
Reply
 
Share Thread Tools Display Modes
  #1  
Old 4 Weeks Ago
DK.Haff's Avatar
DK.Haff DK.Haff is offline
XL FORUM TEAM MEMBER
 
Join Date: May 2010
Posts: 109
Sportster/Buell Model: XL 1200C
Sportster/Buell Year: 2008
Reputation: 98
DK.Haff is an unknown quantity at this point
Default Speedo quits working, bike wants to die

Ran into this problem a couple weeks ago. speedo would cut out while riding, then after a minute check engine light and security light come on. stop the bike and idles horribly, and actually quit a couple times. cleaned and tightened battery cables and frame ground, but still happening. Any ideas? thanks guys
Reply With Quote
  #2  
Old 4 Weeks Ago
tigger's Avatar
tigger tigger is offline
Chief Harley Engineer
 
Join Date: Aug 2006
Posts: 517
Sportster/Buell Model: 100th Anniv. XLH Hugger
Sportster/Buell Year: 03
Other Motorcycle Model: Honda CB750F Super Sport
Other Motorcycle Year: 1976
Reputation: 248671
tigger has a brilliant futuretigger has a brilliant futuretigger has a brilliant futuretigger has a brilliant futuretigger has a brilliant futuretigger has a brilliant futuretigger has a brilliant futuretigger has a brilliant futuretigger has a brilliant futuretigger has a brilliant futuretigger has a brilliant future
Default

check the battery cable going to the starter. mine was doing almost the same thing. the battery cable where it attaches to the starter was broken in half right after the lug on the post to the starter. looking at it it looked fine. the break was inside the plastic/rubber cladding for the cable. only reason i found it is because i tugged on the cable a little and it came right off the lug.

would lose speedo and lights intermittently while idling, oil light would flash on and off and it would idle rough. if i gave it throttle the vibrations would shake the cable lose enough to make it die sometimes.



hopefully it's something simple as that.

i know you have a newer bike so it may be something else. but definitely check that first.
Reply With Quote
  #3  
Old 4 Weeks Ago
shanneba shanneba is offline
XL FORUM TEAM MEMBER
 
Join Date: Jul 2013
Location: Franklin, Indiana
Posts: 1,314
Sportster/Buell Model: XL1200C
Sportster/Buell Year: 2013
Reputation: 1087016
shanneba has a reputation beyond reputeshanneba has a reputation beyond reputeshanneba has a reputation beyond reputeshanneba has a reputation beyond reputeshanneba has a reputation beyond reputeshanneba has a reputation beyond reputeshanneba has a reputation beyond reputeshanneba has a reputation beyond reputeshanneba has a reputation beyond reputeshanneba has a reputation beyond reputeshanneba has a reputation beyond repute
Default

You might also check the VSS (speed sensor) connections.

The TMAP, TPS, and VSS all share the same 5 volt circuit. (plus JSS on International Sportsters)
Check all the connections.

The VSS input is also used in the IAC control, so your idle could be effected if the VSS signal is off.

What codes did you have?
Those would lead toward any other sensor that may be having a problem.
You may get a TMAP ot TPS code before a VSS code sets since they are a lower Code number. You might get codes for all of them if only one is bad.

The electrical service manual has the steps to check the sensors individually.
__________________
2013 XL1200C

Find your Owner's Manual, Wiring Diagram and Parts List here :

https://serviceinfo.harley-davidson....cle/lookupForm
Enter your VIN OR
Use the search - enter year and model

If something doesn't work on your Sportster look here:
SportsterPedia.com
Reply With Quote
  #4  
Old 4 Weeks Ago
IXL2Relax's Avatar
IXL2Relax IXL2Relax is offline
XL FORUM TEAM MEMBER
 
Join Date: Feb 2013
Location: Let Freedom Ring in PA
Posts: 5,388
Sportster/Buell Model: Sportster 883►1200
Sportster/Buell Year: 1994
IXL2Relax has disabled reputation
Default

Here's the Sportsterpedia section on Diagnostic Codes:
http://sportsterpedia.com/doku.php/t...:ref:trouble09

And here's the section in the SP on the Sensors:
http://sportsterpedia.com/doku.php/t...k:evo:engctl03

I suspect the CKP - But check the codes - If it is getting a CKP error, pulling, examine it, clean it, reinstall & clear the codes... Ride & check the codes again...

IXL _ ___ _____ _______ >>>> My Build & Ride Reports Are Here <<<<
2 Relax
FREE Organized Tech Info - Check Out The XLForum Sportsterpedia
__________________
### The ride is more enjoyable to nowhere in particular! ###
Reply With Quote
  #5  
Old 4 Weeks Ago
Folkie's Avatar
Folkie Folkie is online now
Brass Nut
 
Join Date: Feb 2005
Location: Western Weald
Posts: 44,378
Sportster/Buell Model: XL1200CB
Sportster/Buell Year: 2015
Other Motorcycle Model: CRF250L
Other Motorcycle Year: 2017
Reputation: 9198231
Folkie has a reputation beyond reputeFolkie has a reputation beyond reputeFolkie has a reputation beyond reputeFolkie has a reputation beyond reputeFolkie has a reputation beyond reputeFolkie has a reputation beyond reputeFolkie has a reputation beyond reputeFolkie has a reputation beyond reputeFolkie has a reputation beyond reputeFolkie has a reputation beyond reputeFolkie has a reputation beyond repute
Default

Did you check the ground on the back of the primary case?

Here are details of the diagnostic codes and how to retrieve them:
Diagnostic Trouble Codes, 2007-13 Bikes
__________________
Folkie
Super Moderator
South East England Riders



There is nothing at the end of any road better than may be found beside it. Edward Thomas (1878 - 1917)
Reply With Quote
  #6  
Old 4 Weeks Ago
ReddTigger's Avatar
ReddTigger ReddTigger is offline
XL FORUM LIFE MEMBER
 
Join Date: Aug 2005
Location: MARY Lund, YUK !
Posts: 15,323
Sportster/Buell Model: XLH-1208
Sportster/Buell Year: 1997
Reputation: 2027967
ReddTigger has a reputation beyond reputeReddTigger has a reputation beyond reputeReddTigger has a reputation beyond reputeReddTigger has a reputation beyond reputeReddTigger has a reputation beyond reputeReddTigger has a reputation beyond reputeReddTigger has a reputation beyond reputeReddTigger has a reputation beyond reputeReddTigger has a reputation beyond reputeReddTigger has a reputation beyond reputeReddTigger has a reputation beyond repute
Default

Check for corrosion on the back side of the fuse box.. you may have a nice green forest back there. sounds to me like a grounding issue and these other fella's have pointed you in some good directions.
__________________


States I've Ridden in

71.3 hp 70.8 tq

1208cc 11.09:1 (Wiseco 10° Dome 10.5:1 .010 over) ,Screamin Eagle Dual Plug Heads (10° 61cc), Original SE A/C, Vance & Hines Straight Shots w/ Custom Baffles. SE 6800 ign, Dual BREMBO brakes/ Pirelli Night Dragon MU85-16 Rear - 100/90-19 Front. Progressive Springs & 412 HD 13½" Chrome Shocks, 5½" pullback riser w/ "reddtigger mount", Stebel Nautilus Compact Air horn, Mustang Vintage Super Wide Touring Seat, Alto Carbonite Clutch
Reply With Quote
  #7  
Old 3 Weeks Ago
I-man I-man is offline
Biker
 
Join Date: Jan 2018
Posts: 1
Sportster/Buell Model: 883 sportster
Sportster/Buell Year: 2007
Reputation: 10
I-man is an unknown quantity at this point
Default

I had the same problem. It turned out to be the VSS (speed sensor) was corroded. I put a new sensor in (could have cleaned the sensor, probably) and the problem went away.
Reply With Quote
  #8  
Old 3 Weeks Ago
tigger's Avatar
tigger tigger is offline
Chief Harley Engineer
 
Join Date: Aug 2006
Posts: 517
Sportster/Buell Model: 100th Anniv. XLH Hugger
Sportster/Buell Year: 03
Other Motorcycle Model: Honda CB750F Super Sport
Other Motorcycle Year: 1976
Reputation: 248671
tigger has a brilliant futuretigger has a brilliant futuretigger has a brilliant futuretigger has a brilliant futuretigger has a brilliant futuretigger has a brilliant futuretigger has a brilliant futuretigger has a brilliant futuretigger has a brilliant futuretigger has a brilliant futuretigger has a brilliant future
Default

hopefully it was something simple and it was straightened out. if so i wish he'd post what it was.



could help other people in the future by posting the solution.
Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Sponsored Links
All times are GMT +1. The time now is 12:03.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
XL Forum® - Linson Media LLC