The Sportster and Buell Motorcycle Forum - The XLFORUM®
 

Go Back   The Sportster and Buell Motorcycle Forum - The XLFORUM® > SPORTSTER MOTORCYCLE FORUM > Sportster Motorcycle Era Specific and Model Specific > Frame Mount EVO Sportster Talk (1986-2003 models)
XLF Blogs XLF Arcade XLF Disclaimer/Privacy Statement/Terms Of Use

Notices

Active Threads
0 Automotive Motor Oil In Sportster
Last Post: NLXL
Posted On: 11 Minutes Ago
Replies: 46
Views: 1,510
0 XR 750 steering head bearings
Last Post: mofosheee
Posted On: 14 Minutes Ago
Replies: 0
Views: 1
0 Q cams in 73 xlh ??
Last Post: 73HEAD
Posted On: 26 Minutes Ago
Replies: 51
Views: 2,298
0 "S" model specific Q&A
Last Post: Edster
Posted On: 42 Minutes Ago
Replies: 2,107
Views: 464,174
0 Keep & Kill
Last Post: hammer6315
Posted On: 46 Minutes Ago
Replies: 24,664
Views: 1,453,498
5 How do I increase sag ?
Last Post: Tomcatt
Posted On: 1 Hour Ago
Replies: 71
Views: 3,453
0 Official XL Forum Random Image Thread (NO NUDITY!)
Last Post: Iron Mike
Posted On: 1 Hour Ago
Replies: 52,012
Views: 8,752,659
0 What song do you have stuck in your head?
Last Post: hammer6315
Posted On: 2 Hours Ago
Replies: 2,416
Views: 257,416
0 HSR idle mixture screw
Last Post: bustert
Posted On: 2 Hours Ago
Replies: 5
Views: 153
0 It's Glamazon's Birthday!
Last Post: Crusty
Posted On: 2 Hours Ago
Replies: 2
Views: 24
0 Finally some nice weather in the northeast!
Last Post: Crusty
Posted On: 3 Hours Ago
Replies: 56
Views: 6,411
0 Hottie of the day, no nudity.
Last Post: Stairman
Posted On: 6 Hours Ago
Replies: 32,145
Views: 3,737,367
0 What gas mileage do you get for touring?
Last Post: SonWon
Posted On: 7 Hours Ago
Replies: 156
Views: 62,696
0 Track Bike Build
Last Post: shanneba
Posted On: 7 Hours Ago
Replies: 3
Views: 158
0 Stroker pistons
Last Post: Steve9
Posted On: 13 Hours Ago
Replies: 99
Views: 5,671
0 Pushrod hitting tube
Last Post: DR DICK
Posted On: 15 Hours Ago
Replies: 21
Views: 1,168
0 need help with 68 XLH
Last Post: DR DICK
Posted On: 16 Hours Ago
Replies: 17
Views: 1,066
0 1983 Roadster
Last Post: RicThompson
Posted On: 18 Hours Ago
Replies: 21
Views: 754
0 Range With EFI 3.3 Gal Tank
Last Post: Mike1nw
Posted On: 19 Hours Ago
Replies: 97
Views: 73,077
0 who has NOT had problems with the XL
Last Post: handa700
Posted On: 21 Hours Ago
Replies: 770
Views: 220,273
0 Gear and brake linkage
Last Post: Andy56
Posted On: 21 Hours Ago
Replies: 8
Views: 164
0 Oil pressure switch
Last Post: sportsterpaul
Posted On: 23 Hours Ago
Replies: 5
Views: 248
0 This week on Craig's list
Last Post: Steve9
Posted On: 23 Hours Ago
Replies: 5,370
Views: 881,294
0 Iree's late night cafe
Last Post: Steve9
Posted On: 23 Hours Ago
Replies: 2,132
Views: 358,928
0 Valve Stem Seal ID
Last Post: BruceM
Posted On: 23 Hours Ago
Replies: 6
Views: 194
0 Anyone go racing last weekend?
Last Post: Tinz
Posted On: 1 Day Ago
Replies: 3,402
Views: 384,929
0 What oil temp do you run
Last Post: John Harper
Posted On: 1 Day Ago
Replies: 134
Views: 31,746
0 Food porn
Last Post: Stairman
Posted On: 1 Day Ago
Replies: 2,497
Views: 578,351
0 Clutch Spring plate poll
Last Post: Bluto
Posted On: 1 Day Ago
Replies: 313
Views: 78,482
0 why you can't be seen
Last Post: Les59
Posted On: 1 Day Ago
Replies: 31
Views: 10,402
More...
Members Birthdays
jdhickm (86), Chip (73), Chief4x4 (71), willyobiker (69), CBryant (68), XLCH69 (65), sage (62), Butch (62), VettesRule (59), jerseyjeff (59), TheExecutioner (56), SalTheWop (56), manic_mechanic, pauldmedic16 (47), BluegrassXL (43), Superman
 
 
Share Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #22  
Old 29th June 2021
Mr.Rowdy's Avatar
Mr.Rowdy Mr.Rowdy is offline
Biker
 
Join Date: Jun 2021
Posts: 68
Sportster/Buell Model: XL883
Sportster/Buell Year: 1993
Reputation: 10
Mr.Rowdy is an unknown quantity at this point
Default

The carburetor running out of fuel at exactly the same RPM regardless of gear and the engine not missing a beat as soon as I shift eliminates that possibility I think.

Throttle plate opens fine.

The pickup in the nose cone looks fine and it failing at exactly the same RPM every time doesn't really seem plausible.

A loose ground or such would not always be at exactly the same RPM either.

Plugs are fine, the thing pulls like a train until that specific RPM then goes soft. Not like the rev limiter now that I've changed settings for a higher limiter rpm. The thing just goes flat and the rpms just hover around 5500. I'm thinking that these old valve springs now being pushed further than they ever have give up the ghost and go into float mode. The coil is another possibility but I'd have to replace that to find out. So I may be replacing a coil, valve springs, swapping carbs. Lord knows.
Reply With Quote
 

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT +1. The time now is 17:36.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
XL Forum® - Linson Media LLC