The Sportster and Buell Motorcycle Forum - The XLFORUM®
 

Go Back   The Sportster and Buell Motorcycle Forum - The XLFORUM® > SPORTSTER MOTORCYCLE FORUM > Sportster Motorcycle Era Specific and Model Specific > Frame Mount EVO Sportster Talk (1986-2003 models)
XLF Blogs XLF Arcade XLF Disclaimer/Privacy Statement/Terms Of Use

Notices

Active Threads
0 Gear and brake linkage
Last Post: 93trident
Posted On: 12 Minutes Ago
Replies: 4
Views: 96
0 Official XL Forum Random Image Thread (NO NUDITY!)
Last Post: cal43
Posted On: 25 Minutes Ago
Replies: 52,004
Views: 8,750,859
0 Hot Rods, Rat Rods, and Customs.
Last Post: cal43
Posted On: 27 Minutes Ago
Replies: 4,735
Views: 912,953
0 Hot Chicks on Hot Bikes
Last Post: cal43
Posted On: 28 Minutes Ago
Replies: 12,527
Views: 2,911,347
0 This is gonna hurt.
Last Post: cal43
Posted On: 30 Minutes Ago
Replies: 8,908
Views: 2,073,623
0 Hottie of the day, no nudity.
Last Post: Stairman
Posted On: 53 Minutes Ago
Replies: 32,126
Views: 3,732,843
0 Automotive Motor Oil In Sportster
Last Post: shanneba
Posted On: 58 Minutes Ago
Replies: 28
Views: 708
0 Oil pressure switch
Last Post: Andy56
Posted On: 3 Hours Ago
Replies: 2
Views: 94
0 why you can't be seen
Last Post: Andy56
Posted On: 3 Hours Ago
Replies: 30
Views: 10,241
0 What oil temp do you run
Last Post: Andy56
Posted On: 3 Hours Ago
Replies: 130
Views: 31,498
0 This week on Craig's list
Last Post: Fivecats
Posted On: 3 Hours Ago
Replies: 5,367
Views: 877,554
0 Keep & Kill
Last Post: Crusty
Posted On: 6 Hours Ago
Replies: 24,639
Views: 1,452,505
0 Stroker pistons
Last Post: Ferrous Head
Posted On: 9 Hours Ago
Replies: 87
Views: 4,644
0 1974 sportster vin issues! what the heck did I buy?
Last Post: Hippysmack
Posted On: 11 Hours Ago
Replies: 81
Views: 5,381
0 need help with 68 XLH
Last Post: mrmom9r
Posted On: 11 Hours Ago
Replies: 12
Views: 602
0 Q cams in 73 xlh ??
Last Post: RicThompson
Posted On: 13 Hours Ago
Replies: 44
Views: 1,923
0 HSR idle mixture screw
Last Post: sml1226
Posted On: 13 Hours Ago
Replies: 4
Views: 109
0 Iree's late night cafe
Last Post: Stairman
Posted On: 14 Hours Ago
Replies: 2,131
Views: 357,398
0 Range With EFI 3.3 Gal Tank
Last Post: Mike1nw
Posted On: 15 Hours Ago
Replies: 97
Views: 73,037
0 Video - Routing Hoses For Oil Filter Relocation Kit
Last Post: DK Custom
Posted On: 17 Hours Ago
Replies: 0
Views: 42
0 Snippets
Last Post: Crusty
Posted On: 21 Hours Ago
Replies: 496
Views: 68,571
0 Roads I'd like to ride.
Last Post: Stairman
Posted On: 21 Hours Ago
Replies: 3,654
Views: 416,074
0 oil to front rocker, no oil to rear?
Last Post: Hardtail28
Posted On: 22 Hours Ago
Replies: 0
Views: 73
0 Front deflection
Last Post: bustert
Posted On: 1 Day Ago
Replies: 2
Views: 154
0 video & pics
Last Post: cal43
Posted On: 1 Day Ago
Replies: 426
Views: 44,136
0 Off Road Lights
Last Post: rejeanprimeau
Posted On: 1 Day Ago
Replies: 3
Views: 135
0 The One Who Likes Pineapple
Last Post: Fifty150
Posted On: 1 Day Ago
Replies: 0
Views: 89
0 78 Ironhead switchgear parts
Last Post: Hopper
Posted On: 1 Day Ago
Replies: 4
Views: 173
0 Sportster S on the dyno
Last Post: crfblur
Posted On: 1 Day Ago
Replies: 3
Views: 322
0 KT - 2021 - You're In It Now
Last Post: sportsterpaul
Posted On: 1 Day Ago
Replies: 67
Views: 12,592
More...
Members Birthdays
Reply
 
Share Thread Tools Display Modes
  #1  
Old 28th June 2021
Mr.Rowdy's Avatar
Mr.Rowdy Mr.Rowdy is offline
Biker
 
Join Date: Jun 2021
Posts: 68
Sportster/Buell Model: XL883
Sportster/Buell Year: 1993
Reputation: 10
Mr.Rowdy is an unknown quantity at this point
Default Troubles with tach, ignition or valve float?

Today was the first chance I have had to actually run the bike fairly hard. Got onto the highway and let it rip and in 2nd gear I let the rpms run and despite my Dyna2000 rev limiter being set at 6500 I hit the wall at around 5500 according to my factory tach.

Now it sure felt and sounded like a rev limiter. But 1000 rpm shy of where it should be is bothersome. I have the 7 pin Dyna2000 module under the left cover by the battery, factory pickup under the cone and the separate green wire from the Dyna module not connected to anything. The instructions that came with the ignition are pretty lacking in terms of the tech wire. So do I need to hook that thing up to something or what?

Now I don't know if it is the tach, ignition, or if I was floating valves at 5500 but that I highly doubt.

Any ideas?
Reply With Quote
  #2  
Old 28th June 2021
IXL2Relax's Avatar
IXL2Relax IXL2Relax is offline
XL FORUM TEAM MEMBER
 
Join Date: Feb 2013
Location: Let Freedom Ring in PA
Posts: 8,947
Sportster/Buell Model: Sportster 883►1200
Sportster/Buell Year: 1994
IXL2Relax has disabled reputation
Default

The instructions for the Dyna2000 indicate to NOT USE the trigger wire from the coil for the tachometer - but rather, use the green wire from the 2000 ignition module. This is the illustrated connection whether using the single-fire mode or the dual-fire mode.

I would try that to see if you get a different reading...

To what do you have each of the switches set?

Are you using single-fire or dual-fire mode?

IXL _______ >>>> My Motorcycle Chronicles Are Here <<<<
For Sportster Tech Info:
Ride The Sportsterpedia - A Toll-Free XLForum Information Highway!
__________________
### The ride is more enjoyable to nowhere in particular! ###
Reply With Quote
  #3  
Old 28th June 2021
Mr.Rowdy's Avatar
Mr.Rowdy Mr.Rowdy is offline
Biker
 
Join Date: Jun 2021
Posts: 68
Sportster/Buell Model: XL883
Sportster/Buell Year: 1993
Reputation: 10
Mr.Rowdy is an unknown quantity at this point
Default

I'm reading the instructions and all they say is that there is a green wire tach output and the green wire is for the tach and it's use is optional on dual fire installations. That is all it says. So where am I supposed to hook that guy up? I am running dual fire and have Switch #4 ON and Switch #5 OFF per directions
Reply With Quote
  #4  
Old 28th June 2021
IXL2Relax's Avatar
IXL2Relax IXL2Relax is offline
XL FORUM TEAM MEMBER
 
Join Date: Feb 2013
Location: Let Freedom Ring in PA
Posts: 8,947
Sportster/Buell Model: Sportster 883►1200
Sportster/Buell Year: 1994
IXL2Relax has disabled reputation
Default

Dual-Fire Mode
Sw6 is OFF <--- Right?


I know it says connecting the GREEN wire is optional, but the wiring diagrams show it being used in both modes.

If you use it, you need to get it connected to the PINK wire at the tach.

For testing, maybe you can disconnect the correct PINK wire at the coil and connect that to the GREEN wire from the 2000 module. That way, you can put it back on the coil if it makes no difference in the tach reading.

IXL _______ >>>> My Motorcycle Chronicles Are Here <<<<
For Sportster Tech Info:
Ride The Sportsterpedia - A Toll-Free XLForum Information Highway!
Reply With Quote
  #5  
Old 28th June 2021
Mr.Rowdy's Avatar
Mr.Rowdy Mr.Rowdy is offline
Biker
 
Join Date: Jun 2021
Posts: 68
Sportster/Buell Model: XL883
Sportster/Buell Year: 1993
Reputation: 10
Mr.Rowdy is an unknown quantity at this point
Default

I'm splicing the green tach wire into the pink wire and seeing what's what...
Reply With Quote
  #6  
Old 28th June 2021
Mr.Rowdy's Avatar
Mr.Rowdy Mr.Rowdy is offline
Biker
 
Join Date: Jun 2021
Posts: 68
Sportster/Buell Model: XL883
Sportster/Buell Year: 1993
Reputation: 10
Mr.Rowdy is an unknown quantity at this point
Default

Okay. So splicing the tach wire into the pink wire did nothing. I have only 5 switches. They are 1-Off 2-On 3-On 4-On 5-Off.
I don't know what diagram you have but the one I got doesn't even have the green tach wire on it
Reply With Quote
  #7  
Old 28th June 2021
IXL2Relax's Avatar
IXL2Relax IXL2Relax is offline
XL FORUM TEAM MEMBER
 
Join Date: Feb 2013
Location: Let Freedom Ring in PA
Posts: 8,947
Sportster/Buell Model: Sportster 883►1200
Sportster/Buell Year: 1994
IXL2Relax has disabled reputation
Default

It looks like you have the earlier model:
https://www.mpsracing.com/instructio...ek/D2K-HD1.pdf

If so, then that makes:
Sw1 & 2 - the curve settings
Sw3 & 4 - the RPM Limit - where 6500 would ON - OFF
Sw5 ----- the Dual/Single Fire mode - Dual Fire being OFF

Is there no text sticker on the switches to indicate their function?


IXL _______ >>>> My Motorcycle Chronicles Are Here <<<<
For Sportster Tech Info:
Ride The Sportsterpedia - A Toll-Free XLForum Information Highway!
Reply With Quote
  #8  
Old 28th June 2021
IXL2Relax's Avatar
IXL2Relax IXL2Relax is offline
XL FORUM TEAM MEMBER
 
Join Date: Feb 2013
Location: Let Freedom Ring in PA
Posts: 8,947
Sportster/Buell Model: Sportster 883►1200
Sportster/Buell Year: 1994
IXL2Relax has disabled reputation
Default

Beyond the ignition module - There are other conditions that might limit your RPMs.

The carb bowl running out of fuel - Do you have a free flow of fuel from the petcock?

The Throttle Plate not fully opening - Remove air cleaner, look in throat, crank grip to WOT?

Failing Cam Position Sensor - Have you looked in the nosecone to see what condition the CPS is in? They can melt & cause failures due to heat, like a nosecone ignition module.

Failing Coil - Under some conditions, coils will fail due to heat causing the internal windings to gap open from expansion

A bad/loose ground (or positive) battery strap can be intermittent due to vibrations. Check the connections at each end of both cables. Also check for corroded or broken strands down in the cables themselves.

When in 2nd gear, at 5000 RPMs on your Tach, what speed (mph) is indicated on your Speedo.


IXL _______ >>>> My Motorcycle Chronicles Are Here <<<<
For Sportster Tech Info:
Ride The Sportsterpedia - A Toll-Free XLForum Information Highway!
Reply With Quote
  #9  
Old 28th June 2021
Randy_rots Randy_rots is offline
Chief Harley Engineer
 
Join Date: Mar 2007
Location: Derby
Posts: 517
Sportster/Buell Model: XL 1200 softail frame&NOS
Sportster/Buell Year: 2000
Sportster/Buell Model #2: Buell XB1250 Uly XT
Sportster/Buell Year #2: 2009
Reputation: 186700
Randy_rots has a brilliant futureRandy_rots has a brilliant futureRandy_rots has a brilliant futureRandy_rots has a brilliant futureRandy_rots has a brilliant futureRandy_rots has a brilliant futureRandy_rots has a brilliant futureRandy_rots has a brilliant futureRandy_rots has a brilliant futureRandy_rots has a brilliant futureRandy_rots has a brilliant future
Default

I had similar experience with 2003 bike. The factory tach is basically shit!
My brother was riding it on a drag strip and had similar issues.
Dyna 2000i was set up to 7000 RPM but the factory tach was showing about 1.5K less when the cut off kicked in.
The solution was to use Dakota digital speedo/tach unit.
I'm assuming that you have green wire from Dyna 2Ki connected directly to the tach.
Reply With Quote
  #10  
Old 28th June 2021
Mr.Rowdy's Avatar
Mr.Rowdy Mr.Rowdy is offline
Biker
 
Join Date: Jun 2021
Posts: 68
Sportster/Buell Model: XL883
Sportster/Buell Year: 1993
Reputation: 10
Mr.Rowdy is an unknown quantity at this point
Default

Okay, so the green tach wire from the Dyna is now going directly to the pink tach wire. From the coil terminal two pink wires come from that, one goes to the tach and another goes to the Dyna. I disconnected the one going to the tach from the coil and connected the end going to the tach to the green wire. So the other pink wire from the coil still goes to the Dyna. Now I have no tach signal. This shit is annoying me.

For all I know it was working just fine and the tach is off. Now the tach isn't reading at all.

I'm assuming that the tach signal should be coming from the pink wire on the coil to the Dyna through the seven pin plug. That should then come out of the green wire and go to the tach. That obviously isn't happening. All I did was disconnect the tach wire from the coil and reconnect it to the green Dyna wire.
Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT +1. The time now is 13:03.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
XL Forum® - Linson Media LLC