The Sportster and Buell Motorcycle Forum - The XLFORUM®
 

Go Back   The Sportster and Buell Motorcycle Forum - The XLFORUM® > SPORTSTER MOTORCYCLE FORUM > Sportster Motorcycle Era Specific and Model Specific > EFI Sportster Motorcycle Talk (2007 and up)
XLF Blogs XLF Arcade XLF Disclaimer/Privacy Statement/Terms Of Use

Notices

EFI Sportster Motorcycle Talk (2007 and up) For 2007 and above Sportsters

Active Threads
0 Who is at fault here? (WARNING - GRAPHIC!)
Last Post: Folkie
Posted On: 1 Minute Ago
Replies: 143
Views: 32,429
0 Those little ways to personalize your bike...
Last Post: IXL2Relax
Posted On: 1 Minute Ago
Replies: 4
Views: 288
0 Hello everyone!
Last Post: Toejam503
Posted On: 3 Minutes Ago
Replies: 8
Views: 50
0 If the shoe fits...
Last Post: Toejam503
Posted On: 7 Minutes Ago
Replies: 0
Views: 1
0 How many helmets?
Last Post: Bone
Posted On: 13 Minutes Ago
Replies: 197
Views: 27,576
0 Do you blip the throttle when downshifting?
Last Post: Toejam503
Posted On: 19 Minutes Ago
Replies: 442
Views: 64,470
0 Chardhin moved to Pennsylvania!
Last Post: sportsterpaul
Posted On: 38 Minutes Ago
Replies: 5
Views: 70
10 Is it important to brush your teeth?
Last Post: Airbozo
Posted On: 41 Minutes Ago
Replies: 4
Views: 56
0 I've been getting some revenge.
Last Post: sportsterpaul
Posted On: 42 Minutes Ago
Replies: 5
Views: 100
0 burrs & grooves in clutch basket
Last Post: sportsterpaul
Posted On: 48 Minutes Ago
Replies: 46
Views: 1,201
0 How many Keith Black Conversions?
Last Post: farmer 66
Posted On: 1 Hour Ago
Replies: 1
Views: 159
0 Brake fails - what then
Last Post: ChinCactus
Posted On: 1 Hour Ago
Replies: 34
Views: 1,485
8 Drinking and Riding!!!
Last Post: Henry007
Posted On: 1 Hour Ago
Replies: 153
Views: 27,778
0 A Guide For Cold Weather Motorcycle Riding
Last Post: Henry007
Posted On: 1 Hour Ago
Replies: 53
Views: 29,326
0 Official XL Forum Random Image Thread (NO NUDITY!)
Last Post: rubine
Posted On: 1 Hour Ago
Replies: 42,004
Views: 6,500,250
0 Hot Rods, Rat Rods, and Customs.
Last Post: rubine
Posted On: 1 Hour Ago
Replies: 2,791
Views: 258,550
0 This is gonna hurt.
Last Post: BWP 5p
Posted On: 2 Hours Ago
Replies: 7,570
Views: 1,417,917
0 Were your parents anti bike?
Last Post: Medicalweed
Posted On: 2 Hours Ago
Replies: 42
Views: 1,139
0 Who's still riding???
Last Post: doodah man
Posted On: 2 Hours Ago
Replies: 42
Views: 1,710
0 When Were You Born?
Last Post: Henry007
Posted On: 2 Hours Ago
Replies: 320
Views: 75,341
0 ***DK Custom - Pair of Quality Heim Joints For Harley Shift Linkage***
Last Post: DK Custom
Posted On: 2 Hours Ago
Replies: 2
Views: 189
0 Roads I'd like to ride.
Last Post: Stairman
Posted On: 2 Hours Ago
Replies: 674
Views: 38,857
0 ***DK CUSTOM - Skid Plate for 2004-up Sporty****
Last Post: DK Custom
Posted On: 2 Hours Ago
Replies: 2
Views: 190
0 Hot Chicks on Hot Bikes
Last Post: Stairman
Posted On: 2 Hours Ago
Replies: 9,332
Views: 1,446,152
0 ***DK Custom Products Thunder Torques Inserts***
Last Post: DK Custom
Posted On: 3 Hours Ago
Replies: 48
Views: 10,453
0 Led upgrade 1200S
Last Post: bustert
Posted On: 3 Hours Ago
Replies: 5
Views: 187
0 Got New Bike - 2002 Sportster Project
Last Post: mzavala2424
Posted On: 3 Hours Ago
Replies: 16
Views: 290
0 ***DK Custom Footpegs - Shift Pegs - Highway Pegs***
Last Post: DK Custom
Posted On: 3 Hours Ago
Replies: 35
Views: 11,562
0 primary and gear case cover paint.
Last Post: bustert
Posted On: 3 Hours Ago
Replies: 1
Views: 75
0 ***DK Custom-SEE & BE SEEN-LED Front & Rear Lighting***
Last Post: DK Custom
Posted On: 3 Hours Ago
Replies: 1
Views: 163
More...
Members Birthdays
Tags
electrical problems

Sponsored Links
Reply
 
Share Thread Tools Display Modes
  #1  
Old 13th June 2018
xElvis's Avatar
xElvis xElvis is offline
Biker
 
Join Date: May 2017
Posts: 14
Sportster/Buell Model: XL883
Sportster/Buell Year: 2008
xElvis has disabled reputation
Default Electrical Gremlin and weird Speedo Behavior

The electrical gremlin crawled in through a tail light, I suspect. Odd, I know.
Basic facts, then basic story, then ramblings as I drooled over the problem so far.
2008 XL883. Bone stock, basically. 91k miles. Ran fine this winter and spring, daily.


Story: On Thursday, I took the controls and throttle off of the bars, to check fit of new bars. Placed all back on old bars, rode to work Friday. Nothing weird I recall.
On Saturday, I take tail light plastic off to check wires with multimeter for which to cut into. No cutting / splicing done, just the plastic connectors.
Turn bike on. Multimeter reads one hot line to tail light, 1 cold, 1 ground. Tie off brake lever. Still one hot, one cold, one ground. WTF. Check upstream, the connector where the harness attaches into tail light. Same thing. Blue line hot, all others cold. WTF.
Now, signals, front and rear, don't work. Front ones light for running, no blinking for signal. Speedometer's digital readout ... is worse. Won't show, when bike is off. Normally can get total miles, and clock. Nothing. Turn key on. Nothing. Hit kill switch to arm the bike, now I get digital readout. Hit starter, goes blank again. Speedo also not working when digital is out. Signals NEVER worked again, beyond running lights of front one. Headlight is fine, hi and lo. I checked where the tail light harness plugs in under the seat, also still hot / all cold.
On Monday, 2 of my 4 trips, the speedo and digital readout worked, even after bike was running. 2 of 4, it went blank / dead as described above. Now, some times, when I park the bike, after hitting kill switch, the battery and check engine lights come on, if I can see anything there at all.
I checked for diag codes, and found only U1016 in the St section. Googling this gave me little help.

Reminders, I did not pull any wire from any connector (though always possible one loosened, I don't see any signs of that). The only 3 connectors I opened were for the tail light harness.

So, how bad is this? Dying ECU? a simple short I can't find? I am not a fan of electrical hunts, but my easy weekend project to move the plate has gone south in a hurry.
I THINK I've eliminated worn wire in rear fender, by checking upstream under the seat. While there, I looked at the ground on the frame which still looked perfectly good.
I have swapped fuses from spare to lights, no help, no change. I have swapped system relay for ignition, no help, no change.



Any suggestions? The schematic makes my eyes go crossed, but I can at least read it, and amazingly, the wires are even the colors advertised.
__________________
xElvis - DOT Certified Cage-Free - '08 883 91k+ miles
Reply With Quote
  #2  
Old 13th June 2018
Toejam503's Avatar
Toejam503 Toejam503 is online now
Subscribing Biker
 
Join Date: May 2010
Location: Dakota Territory
Posts: 755
Sportster/Buell Model: XL 1200 C
Sportster/Buell Year: 2006
Reputation: 892471
Toejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond repute
Default

Does it have a security system? If it does I'd start there. Otherwise, it sounds like it all started when you tested the taillight.
Reply With Quote
  #3  
Old 13th June 2018
xElvis's Avatar
xElvis xElvis is offline
Biker
 
Join Date: May 2017
Posts: 14
Sportster/Buell Model: XL883
Sportster/Buell Year: 2008
xElvis has disabled reputation
Default

no security system besides a padlock and angry owner.
Reply With Quote
  #4  
Old 13th June 2018
Toejam503's Avatar
Toejam503 Toejam503 is online now
Subscribing Biker
 
Join Date: May 2010
Location: Dakota Territory
Posts: 755
Sportster/Buell Model: XL 1200 C
Sportster/Buell Year: 2006
Reputation: 892471
Toejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond repute
Default

I work in a Chevy Garage and for the last ten years we have had to be careful using a regular test-light because they can back-feed current and destroy a module. In an instant. Most of the testing is continuity tests for me. Disconnect the battery and try some continuity tests on the wires you opened up and go from there. If you had spiked anything it was probably the TSM (turn signal module). You'd be surprised to know that a lot of the modules have to work together to work properly.
Reply With Quote
  #5  
Old 13th June 2018
IXL2Relax's Avatar
IXL2Relax IXL2Relax is offline
XL FORUM TEAM MEMBER
 
Join Date: Feb 2013
Location: Let Freedom Ring in PA
Posts: 5,637
Sportster/Buell Model: Sportster 883►1200
Sportster/Buell Year: 1994
IXL2Relax has disabled reputation
Default

Quote:
Originally Posted by xElvis View Post
Story: On Thursday, I took the controls and throttle off of the bars, to check fit of new bars.
<SNIP>
Now, signals, front and rear, don't work. Front ones light for running, no blinking for signal. Speedometer's digital readout <SNIP> Won't show, when bike is off. Normally can get total miles, and clock. Nothing. Turn key on. Nothing. Hit kill switch to arm the bike, now I get digital readout. Hit starter, goes blank again. Speedo also not working when digital is out. Signals NEVER worked again, beyond running lights of front one. Headlight is fine, hi and lo.
You may have pulled the Speedo harness connector loose during your bar checks...

But... (the problem may be unrelated since it has 91K on the clock)

Your model year has a history of corrosion & gunk in the fuse/relay tray - Start there - Remove fuses & relays - Clean every, front & back - apply dielectric grease to all contacts & reinsert fuses & relays...

Next, check both battery cables (tug hard on both ends of both cables & check for corrosion & breaks inside the cable sheath)...

Then check all grounds - remove connections - clean contacts - apply copper-based anti-seize compound and retighten well - Be sure to check the Battery ground, the Powertrain ground and the engine-to-frame ground strap under the bike...

NOW - Use your meter to take some voltage readings off the battery - Key OFF, Key ON, Cranking the Engine...

Here's the Sportsterpedia section on checking the battery cables, voltages and grounds:
http://sportsterpedia.com/doku.php/t...place_to_start
Please report your SPECIFIC METER READINGS from those tests...


IXL _ ___ _____ _______ >>>> My Build & Ride Reports Are Here <<<<
2 Relax
FREE Organized Tech Info - Check Out The XLForum Sportsterpedia
__________________
### The ride is more enjoyable to nowhere in particular! ###
Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Sponsored Links
All times are GMT +1. The time now is 01:09.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
XL Forum® - Linson Media LLC