The Sportster and Buell Motorcycle Forum - The XLFORUM®
 

Go Back   The Sportster and Buell Motorcycle Forum - The XLFORUM® > SPORTSTER MOTORCYCLE FORUM > Sportster Motorcycle Era Specific and Model Specific > EFI Sportster Motorcycle Talk (2007 and up)
XLF Blogs XLF Arcade XLF Disclaimer/Privacy Statement/Terms Of Use

Notices

EFI Sportster Motorcycle Talk (2007 and up) For 2007 and above Sportsters

Active Threads
0 77 xlh pinging noise left side
Last Post: Beazer
Posted On: 1 Minute Ago
Replies: 26
Views: 1,138
0 New T Shirts
Last Post: rocketmangb
Posted On: 18 Minutes Ago
Replies: 12
Views: 206
0 The Official New Forty Eight Thread
Last Post: Turbo Sporty 48
Posted On: 24 Minutes Ago
Replies: 1,842
Views: 892,339
0 Proposed clutch spring improvement0
Last Post: bustert
Posted On: 26 Minutes Ago
Replies: 13
Views: 337
0 What did you do for your sporty Today?
Last Post: jcn59
Posted On: 31 Minutes Ago
Replies: 5,392
Views: 608,708
0 How many miles do you have on your rubbermount?
Last Post: Toejam503
Posted On: 52 Minutes Ago
Replies: 393
Views: 72,976
0 Gravydog crashed again.
Last Post: Toejam503
Posted On: 57 Minutes Ago
Replies: 53
Views: 1,384
0 19 inch mag wheel questions
Last Post: Hippysmack
Posted On: 1 Hour Ago
Replies: 1
Views: 31
0 Another poser sentenced
Last Post: Hippysmack
Posted On: 1 Hour Ago
Replies: 2
Views: 909
0 13 3/8" Emulsion Shocks on Xl1200c
Last Post: Spokane2303
Posted On: 1 Hour Ago
Replies: 14
Views: 369
0 BowlingGreen Fall races
Last Post: tigger
Posted On: 1 Hour Ago
Replies: 1
Views: 26
0 New England 2018
Last Post: cotton1
Posted On: 1 Hour Ago
Replies: 204
Views: 10,286
0 National Guard
Last Post: Toejam503
Posted On: 1 Hour Ago
Replies: 44
Views: 4,353
0 65 CH barn find/survivor
Last Post: DirtyHarry68
Posted On: 1 Hour Ago
Replies: 115
Views: 21,348
0 Supertrapp 2:1 fit issue with Pics
Last Post: robbie202
Posted On: 1 Hour Ago
Replies: 20
Views: 701
0 Clutch gone out of adjustment seems like a lot
Last Post: jordan1200
Posted On: 1 Hour Ago
Replies: 19
Views: 193
0 Anyone go racing last weekend?
Last Post: cycowrencher
Posted On: 1 Hour Ago
Replies: 2,810
Views: 255,970
0 Are you a Vet?
Last Post: Toejam503
Posted On: 2 Hours Ago
Replies: 406
Views: 73,323
0 Carb + Rubbermount = Collector's Item?
Last Post: Wyo George
Posted On: 2 Hours Ago
Replies: 175
Views: 27,632
14 Firearms you wish you owned.
Last Post: Wyo George
Posted On: 2 Hours Ago
Replies: 490
Views: 75,465
5 1200 or 883
Last Post: Nibelungen
Posted On: 2 Hours Ago
Replies: 988
Views: 294,486
0 Weekend at Jester's
Last Post: rocketmangb
Posted On: 2 Hours Ago
Replies: 36
Views: 3,943
0 Seeking the plushest ride possible?
Last Post: Lone Rider
Posted On: 2 Hours Ago
Replies: 8
Views: 247
5 Your worst car?
Last Post: ChinCactus
Posted On: 2 Hours Ago
Replies: 218
Views: 23,944
0 Luggage rack for Tallboy seat equipped sporty
Last Post: Screw Loose Dan
Posted On: 3 Hours Ago
Replies: 2
Views: 135
0 My take on the world ~ Photo by Trace
Last Post: sportytrace
Posted On: 4 Hours Ago
Replies: 839
Views: 92,959
0 hello and help
Last Post: IronX
Posted On: 4 Hours Ago
Replies: 8
Views: 183
0 Cams, what are the specs?
Last Post: sportytrace
Posted On: 4 Hours Ago
Replies: 5
Views: 194
0 New from Pasco, Fl
Last Post: Prof Rene
Posted On: 4 Hours Ago
Replies: 10
Views: 103
0 Roads I'd like to ride.
Last Post: Graywolf
Posted On: 4 Hours Ago
Replies: 473
Views: 22,690
More...
Members Birthdays
PlanB, Cuco6924 (72), 1200sporty (61), iron68 (47), LifesHarlequin (34), mattosm (33)
Sponsored Links
Reply
 
Share Thread Tools Display Modes
  #201  
Old 27th January 2015
wkong's Avatar
wkong wkong is offline
XL FORUM TEAM MEMBER
 
Join Date: Jan 2015
Posts: 143
Sportster/Buell Model: 1200 Custom
Sportster/Buell Year: 2007
Reputation: 19319
wkong is a name known to allwkong is a name known to allwkong is a name known to allwkong is a name known to allwkong is a name known to allwkong is a name known to allwkong is a name known to allwkong is a name known to allwkong is a name known to allwkong is a name known to allwkong is a name known to all
Default

Bumping it back up! Horrible corrosion all over the fuse block. Blasted it with some cleaner, loaded up new fuses and relays with grease, and boom. No more issues starting. It seemed that most people's system relay was going first, but my fuel pump relay went first. It would crank and crank and crank and never get enough fuel sometimes, and then out of nowhere viola, starts right up. Wondering if the previous owner was having problems and couldn't figure out why, which might explain why an otherwise pristine bike with under 10k miles was going for so cheap.

Just to help those using the search function... bike will crank but won't start.
Reply With Quote
  #202  
Old 27th January 2015
sportsterdoc's Avatar
sportsterdoc sportsterdoc is offline
Senior Master Custom Bike Builder
 
Join Date: Apr 2012
Location: Mojave Desert
Posts: 12,757
Sportster/Buell Model: 1200S
Sportster/Buell Year: 2002
Sportster/Buell Model #2: XLH883
Sportster/Buell Year #2: 2003
Reputation: 4357699
sportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond repute
Default

Every 2007-2009 model should have fuse blocks and relays examined regularly.
Reply With Quote
  #203  
Old 28th January 2015
Bone's Avatar
Bone Bone is offline
Senior Master Custom Bike Builder
 
Join Date: Jun 2009
Location: Medford, NJ
Posts: 10,710
Sportster/Buell Model: 1200Lr
Sportster/Buell Year: 2007
Sportster/Buell Model #2: FLHP
Sportster/Buell Year #2: 2016
Other Motorcycle Model: 13 Guzzi V7 / 11 Duc 696
Other Motorcycle Year: 2013
Reputation: 3026604
Bone has a reputation beyond reputeBone has a reputation beyond reputeBone has a reputation beyond reputeBone has a reputation beyond reputeBone has a reputation beyond reputeBone has a reputation beyond reputeBone has a reputation beyond reputeBone has a reputation beyond reputeBone has a reputation beyond reputeBone has a reputation beyond reputeBone has a reputation beyond repute
Default

Quote:
Originally Posted by wkong View Post
It seemed that most people's system relay was going first, but my fuel pump relay went first. It would crank and crank and crank and never get enough fuel sometimes, and then out of nowhere viola, starts right up.
The system relay controls the fuel pump.

There are two identical relays:

1. Main/system that controls the fuel and ignition systems.
2. Starter relay that controls cranking.

So what happened is the system relay finally closed.
Reply With Quote
  #204  
Old 1st June 2015
rockmanbm's Avatar
rockmanbm rockmanbm is offline
Chief Harley Engineer
 
Join Date: Mar 2010
Posts: 546
Sportster/Buell Model: XL883 Low
Sportster/Buell Year: 2009
Other Motorcycle Model: CX500
Other Motorcycle Year: 1979
Reputation: 4697
rockmanbm is just really nicerockmanbm is just really nicerockmanbm is just really nicerockmanbm is just really nicerockmanbm is just really nicerockmanbm is just really nicerockmanbm is just really nicerockmanbm is just really nicerockmanbm is just really nicerockmanbm is just really nicerockmanbm is just really nice
Default

I believe mine is doing this now as well. I will be stripping and cleaning the fuses and relays tonight. Glad this forum is here to give appropriate info
__________________
Road Name: TANK (2009 XL883L ridden hard daily)
Reply With Quote
  #205  
Old 2nd June 2015
Bone's Avatar
Bone Bone is offline
Senior Master Custom Bike Builder
 
Join Date: Jun 2009
Location: Medford, NJ
Posts: 10,710
Sportster/Buell Model: 1200Lr
Sportster/Buell Year: 2007
Sportster/Buell Model #2: FLHP
Sportster/Buell Year #2: 2016
Other Motorcycle Model: 13 Guzzi V7 / 11 Duc 696
Other Motorcycle Year: 2013
Reputation: 3026604
Bone has a reputation beyond reputeBone has a reputation beyond reputeBone has a reputation beyond reputeBone has a reputation beyond reputeBone has a reputation beyond reputeBone has a reputation beyond reputeBone has a reputation beyond reputeBone has a reputation beyond reputeBone has a reputation beyond reputeBone has a reputation beyond reputeBone has a reputation beyond repute
Default

Quote:
Originally Posted by Bone View Post
No but it took 4 years for the untreated relays to fail on Jenn's bike, as did it on Nytstr's bike. So it is quite logical/likely that it would take at least that time before it might occur again, probably longer with the grease.

Obviously YMMV and others might vary because of differences in usage.
Thought I'd report back, here we are another 4-5 years later and I was just in there finally replacing the stock battery.

While there I spot checked the relays and there's little or no new corrosion. The replacement relays still look fine.
Reply With Quote
  #206  
Old 2nd June 2015
rockmanbm's Avatar
rockmanbm rockmanbm is offline
Chief Harley Engineer
 
Join Date: Mar 2010
Posts: 546
Sportster/Buell Model: XL883 Low
Sportster/Buell Year: 2009
Other Motorcycle Model: CX500
Other Motorcycle Year: 1979
Reputation: 4697
rockmanbm is just really nicerockmanbm is just really nicerockmanbm is just really nicerockmanbm is just really nicerockmanbm is just really nicerockmanbm is just really nicerockmanbm is just really nicerockmanbm is just really nicerockmanbm is just really nicerockmanbm is just really nicerockmanbm is just really nice
Default

That is good to hear. I will be tearing into mine and cleaning the entire fuse box, replacing fuses and relays on my 2009. Looking back on it, mine has been having problems over the last 2 weeks with intermittent starting issues, and the IAC started cycling while off. Anyone been able to source some good relays that are sealed?
Reply With Quote
  #207  
Old 12th June 2015
rockmanbm's Avatar
rockmanbm rockmanbm is offline
Chief Harley Engineer
 
Join Date: Mar 2010
Posts: 546
Sportster/Buell Model: XL883 Low
Sportster/Buell Year: 2009
Other Motorcycle Model: CX500
Other Motorcycle Year: 1979
Reputation: 4697
rockmanbm is just really nicerockmanbm is just really nicerockmanbm is just really nicerockmanbm is just really nicerockmanbm is just really nicerockmanbm is just really nicerockmanbm is just really nicerockmanbm is just really nicerockmanbm is just really nicerockmanbm is just really nicerockmanbm is just really nice
Default

I was able to clean corrosion off and the bike worked flawlessly. I wonder of a '10 fusebox is sealed better and will fit on a 09
Reply With Quote
Sponsored Links
  #208  
Old 12th June 2015
sportsterdoc's Avatar
sportsterdoc sportsterdoc is offline
Senior Master Custom Bike Builder
 
Join Date: Apr 2012
Location: Mojave Desert
Posts: 12,757
Sportster/Buell Model: 1200S
Sportster/Buell Year: 2002
Sportster/Buell Model #2: XLH883
Sportster/Buell Year #2: 2003
Reputation: 4357699
sportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond repute
Default

Quote:
Originally Posted by rockmanbm View Post
I was able to clean corrosion off and the bike worked flawlessly. I wonder of a '10 fusebox is sealed better and will fit on a 09
Different animals

Fuses 2007-2009
Spare
Instruments o
Ignition g
Battery bn/gy
Lights be
Accessories o/w
P&A ignition fuse
Spare
ECM be/gy
Fuel pump o/gy
System relay
Start Relay
Spare

Fuses 2010-2013
Ignition g
Battery bn/gy
Lights be
Accessories o/w
ECM be/gy
System relay
Start Relay
Reply With Quote
  #209  
Old 12th June 2015
Bone's Avatar
Bone Bone is offline
Senior Master Custom Bike Builder
 
Join Date: Jun 2009
Location: Medford, NJ
Posts: 10,710
Sportster/Buell Model: 1200Lr
Sportster/Buell Year: 2007
Sportster/Buell Model #2: FLHP
Sportster/Buell Year #2: 2016
Other Motorcycle Model: 13 Guzzi V7 / 11 Duc 696
Other Motorcycle Year: 2013
Reputation: 3026604
Bone has a reputation beyond reputeBone has a reputation beyond reputeBone has a reputation beyond reputeBone has a reputation beyond reputeBone has a reputation beyond reputeBone has a reputation beyond reputeBone has a reputation beyond reputeBone has a reputation beyond reputeBone has a reputation beyond reputeBone has a reputation beyond reputeBone has a reputation beyond repute
Default

Quote:
Originally Posted by rockmanbm View Post
I was able to clean corrosion off and the bike worked flawlessly. I wonder of a '10 fusebox is sealed better and will fit on a 09
Yes, 10 is sealed better, cause it's a complete redesign.

No, not compatible.
Reply With Quote
  #210  
Old 1st January 2016
Ultrarunner Ultrarunner is offline
XL FORUM TEAM MEMBER
 
Join Date: Aug 2015
Location: Upstate SC
Posts: 70
Sportster/Buell Model: XL883C
Sportster/Buell Year: 2009
Other Motorcycle Model: FLHX
Other Motorcycle Year: 2007
Reputation: 65390
Ultrarunner has much to be proud ofUltrarunner has much to be proud ofUltrarunner has much to be proud ofUltrarunner has much to be proud ofUltrarunner has much to be proud ofUltrarunner has much to be proud ofUltrarunner has much to be proud ofUltrarunner has much to be proud ofUltrarunner has much to be proud ofUltrarunner has much to be proud ofUltrarunner has much to be proud of
Default

I have an 09 883c, and have finally resolved this issue. Without going into the entire back story, I purchased this bike in August, and have put 6000 miles on it since. It was garage kept and immaculate (until I got my hands on it....), with 5000 miles on it, and I doubt had ever seen water.

I started having battery drain issues about a month ago, and replaced the battery, as I figured it was original. Put an HD battery in it, which was fine for a couple of weeks, when I started chasing potential issues. Turns out the new battery had a bad cell. So, HD gave me another, which was dead the following morning.

I had already seen and read this thread, and had cleaned my fuse panel as well as testing my relays. The fuse panel had very, very little corrosion on it. The relays tested fine (with multimeter, not just a click test). Charging system checked out fine, I had already gone through wiring off battery with a fine toothed comb, and was getting frustrated.

I put in new relays, just in case.... that was 4 days ago, and it solved the problem. Even though the old ones tested fine, there was one that must have been working improperly intermittently. Argh. Very aggravating. So, I will be cleaning the fuze panel with every oil change as well as keeping a couple of spare relays in my tool kit. Pretty cheap insurance.

Of course, while working on this my FZ 1 fuze block arrived, so I'll be installing that soon. Glad I figured out the charging issue first! Thanks to the forum- this is a great resource.
__________________
2009 XL883C
Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Sponsored Links
All times are GMT +1. The time now is 01:41.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
XL Forum® - Linson Media LLC