The Sportster and Buell Motorcycle Forum - The XLFORUM®
 

Go Back   The Sportster and Buell Motorcycle Forum - The XLFORUM® > SPORTSTER MOTORCYCLE FORUM > Sportster Motorcycle Era Specific and Model Specific > EFI Sportster Motorcycle Talk (2007 and up)
XLF Blogs XLF Arcade XLF Disclaimer/Privacy Statement/Terms Of Use

Notices

EFI Sportster Motorcycle Talk (2007 and up) For 2007 and above Sportsters

Active Threads
0 A Reliable Engine
Last Post: 73HEAD
Posted On: 1 Hour Ago
Replies: 24
Views: 655
0 Keep & Kill
Last Post: Crusty
Posted On: 1 Hour Ago
Replies: 26,704
Views: 1,548,751
0 Microsquirt EFI Conversion
Last Post: t120r
Posted On: 3 Hours Ago
Replies: 61
Views: 6,790
0 What song do you have stuck in your head?
Last Post: iNSaNeSHaNe
Posted On: 4 Hours Ago
Replies: 2,486
Views: 276,477
1 Hello from Cork, Ireland
Last Post: Stairman
Posted On: 4 Hours Ago
Replies: 6
Views: 59
0 04 Sportster refurb and build.
Last Post: JimVonBaden
Posted On: 5 Hours Ago
Replies: 106
Views: 8,182
0 My XLCH/XLR Hybrid build
Last Post: brucstoudt
Posted On: 5 Hours Ago
Replies: 18
Views: 625
0 What did you do to your EFI Sporty today?
Last Post: Steelrain
Posted On: 6 Hours Ago
Replies: 4,034
Views: 860,228
0 Official XL Forum Random Image Thread (NO NUDITY!)
Last Post: Graywolf
Posted On: 7 Hours Ago
Replies: 52,914
Views: 8,968,554
0 Coulda' - Shoulda' - Woulda' - Solenoid/Bendix?
Last Post: ZTatZAU
Posted On: 8 Hours Ago
Replies: 0
Views: 51
0 On board voltmeter
Last Post: ZTatZAU
Posted On: 8 Hours Ago
Replies: 12
Views: 733
0 Let's See Your Iron!!!
Last Post: Ghostdog
Posted On: 8 Hours Ago
Replies: 2,140
Views: 1,623,645
0 Aftermarket Ironhead Seats - ID?
Last Post: ZTatZAU
Posted On: 9 Hours Ago
Replies: 7
Views: 397
0 Iree's late night cafe
Last Post: rokytnji
Posted On: 9 Hours Ago
Replies: 2,215
Views: 395,064
3 Rear galiper bracket spec.
Last Post: DG Racing
Posted On: 9 Hours Ago
Replies: 1
Views: 108
0 1972 Build thread please subscribe
Last Post: wedge
Posted On: 9 Hours Ago
Replies: 167
Views: 25,151
0 Hot Rods, Rat Rods, and Customs.
Last Post: Stairman
Posted On: 9 Hours Ago
Replies: 4,899
Views: 1,005,114
0 Hottie of the day, no nudity.
Last Post: Stairman
Posted On: 9 Hours Ago
Replies: 33,840
Views: 4,071,351
0 Roads I'd like to ride.
Last Post: Stairman
Posted On: 9 Hours Ago
Replies: 3,738
Views: 441,595
0 extortion
Last Post: wedge
Posted On: 10 Hours Ago
Replies: 125
Views: 8,595
0 Primary chain tensioner, stock or M1 or other?
Last Post: gotamotor
Posted On: 10 Hours Ago
Replies: 8
Views: 446
0 Pushrod adjustment question
Last Post: gotamotor
Posted On: 10 Hours Ago
Replies: 12
Views: 866
0 Can't install kickstand spring
Last Post: RicThompson
Posted On: 10 Hours Ago
Replies: 13
Views: 442
0 Before and After pictures/Videos of your bike (All Welcome)
Last Post: Ghostdog
Posted On: 11 Hours Ago
Replies: 108
Views: 31,918
0 Snippets
Last Post: Crusty
Posted On: 11 Hours Ago
Replies: 591
Views: 83,242
0 1200T Build
Last Post: Ghostdog
Posted On: 11 Hours Ago
Replies: 6
Views: 533
0 This is gonna hurt.
Last Post: rokytnji
Posted On: 13 Hours Ago
Replies: 9,225
Views: 2,178,774
0 Massachusetts 2022
Last Post: joes95bobber
Posted On: 13 Hours Ago
Replies: 26
Views: 916
0 "The Blues" thread!
Last Post: rokytnji
Posted On: 14 Hours Ago
Replies: 1,108
Views: 157,243
0 Secondary Pulley Sprocket Quality
Last Post: SonWon
Posted On: 14 Hours Ago
Replies: 19
Views: 655
More...
Members Birthdays
hillclimber (72), burtondl2 (54), Cet (52), hagar71 (51), ShaneWolfe (50), grizdiesel (45), Confused89 (37), RAIDER0372 (36), spamer80 (36), svwannabe
Tags
electrical help, no click, turn signal, won’t start

Reply
 
Share Thread Tools Display Modes
  #1  
Old 6th December 2021
Viffer Viffer is offline
Biker
 
Join Date: Dec 2021
Posts: 5
Sportster/Buell Model: XL883
Sportster/Buell Year: 2007
Reputation: 10
Viffer is an unknown quantity at this point
Default 2007 Sportster 883 won’t start; no turn signals

I was out riding my Sportster 883 as normal. While in the ride, the red key light comes on and stays on, on the Speedo. Other than that, no changes.

When I pulled into the garage, I turn the bike off. I try to turn it back on, and nothing. I turn the ignition, flip the switch to run, I hear the fuel pump activate, and that’s all. When I push start, even in neutral with clutch in or in gear, nothing. No click, or sound, or anything.

So I check for codes. Here’s what I find:
- P: Code U1301
- S: No response
- SP: U1301, U1255
- T: I don’t have one, so no response.
I checked the ECM plug in, the TSM plug in, and the battery health, connections and ground. I have not checked for shorts in individual wires throughout the harness yet.

The TSM appears to be working, at LEAST partially, as pulling it out and moving it sideways activated the tilt sensor.

Note that this is a TSM and not as TSSM, as I do not have a fob, thus no security issues.

So it appears with the no response to the TSM, their is a short in the wiring somewhere? Does that sound right? I believe it’s telling me the ECM is short, and the Speedo is short AND is getting no data.

I also wonder what could lead to this happening all at once? I had a perfectly functioning bike that would start as always, and now it ain’t start at all.

Some things to note: it’s a stock 07 XL883 with a few aesthetic mods but nothing electrical save for an LED headlight replacing the original halogen that has worked great for thousands of miles. It has 13,500 miles on it.

When this all happened, the turn sig also stopped working. All of the fuses are in good condition, and I know the specific turn signal fuse is working, because that same fuse powers the brake light function, which is working properly.

Sorry if this was a lot, it’s my first post and I wanted to be as thorough as possible. I just want to ride my Harley again, and not having any leads has been disheartening.
Reply With Quote
  #2  
Old 7th December 2021
shanneba shanneba is offline
XL FORUM TEAM MEMBER
 
Join Date: Jul 2013
Location: Franklin, Indiana
Posts: 2,720
Sportster/Buell Model: XL1200C
Sportster/Buell Year: 2013
Reputation: 5381366
shanneba has a reputation beyond reputeshanneba has a reputation beyond reputeshanneba has a reputation beyond reputeshanneba has a reputation beyond reputeshanneba has a reputation beyond reputeshanneba has a reputation beyond reputeshanneba has a reputation beyond reputeshanneba has a reputation beyond reputeshanneba has a reputation beyond reputeshanneba has a reputation beyond reputeshanneba has a reputation beyond repute
Default

The TSM controls the turn signals and supplies voltage for the turn signals to operate.
A short on the turn signal circuits can cause the battery fuse to open.
If no short to ground is found in the battery fuse circuit check the turn
signal circuits between the TSM and the turn signals for a short to ground.
__________________
2013 XL1200C

Find your Owner's Manual, Wiring Diagram and Parts Catalog here :

https://serviceinfo.harley-davidson....cle/lookupForm
Enter your VIN OR
Use the search - enter year and model

If something doesn't work on your Sportster look here:
SportsterPedia.com
Reply With Quote
  #3  
Old 7th December 2021
Viffer Viffer is offline
Biker
 
Join Date: Dec 2021
Posts: 5
Sportster/Buell Model: XL883
Sportster/Buell Year: 2007
Reputation: 10
Viffer is an unknown quantity at this point
Default

Quote:
Originally Posted by shanneba View Post
The TSM controls the turn signals and supplies voltage for the turn signals to operate.
A short on the turn signal circuits can cause the battery fuse to open.
If no short to ground is found in the battery fuse circuit check the turn
signal circuits between the TSM and the turn signals for a short to ground.
Thanks for the reply. Are you saying check with a voltmeter? I assume you mean check the module itself for a short, and then check the harness that plugs into the TSM for a short there? Just wanted to clarify, I’m only versed in Japanese bikes so this is all fresh.

I was thinking it may be the module itself based on the healthy fuses and relays but I’m really not sure of anything at this point. I know it can’t be the whole harness/all the wires in the harness because the brake light, horn and headlight bright switch all still work fine. I’m also hoping it’s not the starter, and is just a code issue PREVENTING it from starting.
Reply With Quote
  #4  
Old 7th December 2021
IXL2Relax's Avatar
IXL2Relax IXL2Relax is offline
XL FORUM TEAM MEMBER
 
Join Date: Feb 2013
Location: Let Freedom Ring in PA
Posts: 9,051
Sportster/Buell Model: Sportster 883►1200
Sportster/Buell Year: 1994
IXL2Relax has disabled reputation
Default

http://sportsterpedia.com/doku.php/t...:elec02#relays

Sportsterpedia Note: The 2007-2009 model years have a significant history of corrosion and gunk collecting in the fuse/relay tray causing low-grade shorts and erratic electrical operation - This is especially problematic if the bike is left outside or operated in the rain. It's a good idea to check & thoroughly clean this entire tray at least every year (or 4 to 6 months if parked outside).

Relays are relatively inexpensive - Change them out every few years as a preventative maintenance measure.

Read over the Sportsterpedia section on Turn Signal Modules:
http://sportsterpedia.com/doku.php/t...3#turn_signals

IXL _______ >>>> My Motorcycle Chronicles Are Here <<<<
For Sportster Tech Info:
Ride The Sportsterpedia - A Toll-Free XLForum Information Highway!
__________________
### The ride is more enjoyable to nowhere in particular! ###
Reply With Quote
  #5  
Old 7th December 2021
Viffer Viffer is offline
Biker
 
Join Date: Dec 2021
Posts: 5
Sportster/Buell Model: XL883
Sportster/Buell Year: 2007
Reputation: 10
Viffer is an unknown quantity at this point
Default

Quote:
Originally Posted by IXL2Relax View Post
http://sportsterpedia.com/doku.php/t...:elec02#relays

Sportsterpedia Note: The 2007-2009 model years have a significant history of corrosion and gunk collecting in the fuse/relay tray causing low-grade shorts and erratic electrical operation - This is especially problematic if the bike is left outside or operated in the rain. It's a good idea to check & thoroughly clean this entire tray at least every year (or 4 to 6 months if parked outside).

Relays are relatively inexpensive - Change them out every few years as a preventative maintenance measure.

Read over the Sportsterpedia section on Turn Signal Modules:
http://sportsterpedia.com/doku.php/t...3#turn_signals

Thanks for the info. What should I use to clean the tray?

IXL _______ >>>> My Motorcycle Chronicles Are Here <<<<
For Sportster Tech Info:
Ride The Sportsterpedia - A Toll-Free XLForum Information Highway!
Reply With Quote
  #6  
Old 7th December 2021
IXL2Relax's Avatar
IXL2Relax IXL2Relax is offline
XL FORUM TEAM MEMBER
 
Join Date: Feb 2013
Location: Let Freedom Ring in PA
Posts: 9,051
Sportster/Buell Model: Sportster 883►1200
Sportster/Buell Year: 1994
IXL2Relax has disabled reputation
Default

https://www.google.com/search?q=elec...+cleaner+spray

Check the directions for issues regarding painted surfaces.


Once the tray is thoroughly cleaned, apply a coat of dielectric grease to all the tray contacts & to the new relay contacts.

Do the same for the TSM & connector.


IXL _______ >>>> My Motorcycle Chronicles Are Here <<<<
For Sportster Tech Info:
Ride The Sportsterpedia - A Toll-Free XLForum Information Highway!
Reply With Quote
  #7  
Old 7th December 2021
Viffer Viffer is offline
Biker
 
Join Date: Dec 2021
Posts: 5
Sportster/Buell Model: XL883
Sportster/Buell Year: 2007
Reputation: 10
Viffer is an unknown quantity at this point
Default

Awesome I’ll give it a whirl
Reply With Quote
  #8  
Old 7th December 2021
IXL2Relax's Avatar
IXL2Relax IXL2Relax is offline
XL FORUM TEAM MEMBER
 
Join Date: Feb 2013
Location: Let Freedom Ring in PA
Posts: 9,051
Sportster/Buell Model: Sportster 883►1200
Sportster/Buell Year: 1994
IXL2Relax has disabled reputation
Default

While you're at it, I'd clean & dielectric grease the Speedo Connection & the ECM since those codes were displayed...

But, corrosion on the fuse tray can cause all kinds of havoc and strange symptons.

After the cleaning job, clear the codes and see if any return...
http://sportsterpedia.com/doku.php/t...k:ref:genmsr08


IXL _______ >>>> My Motorcycle Chronicles Are Here <<<<
For Sportster Tech Info:
Ride The Sportsterpedia - A Toll-Free XLForum Information Highway!
Reply With Quote
  #9  
Old 7th December 2021
Viffer Viffer is offline
Biker
 
Join Date: Dec 2021
Posts: 5
Sportster/Buell Model: XL883
Sportster/Buell Year: 2007
Reputation: 10
Viffer is an unknown quantity at this point
Default

Quote:
Originally Posted by IXL2Relax View Post
While you're at it, I'd clean & dielectric grease the Speedo Connection & the ECM since those codes were displayed...

But, corrosion on the fuse tray can cause all kinds of havoc and strange symptons.

After the cleaning job, clear the codes and see if any return...
http://sportsterpedia.com/doku.php/t...k:ref:genmsr08


IXL _______ >>>> My Motorcycle Chronicles Are Here <<<<
For Sportster Tech Info:
Ride The Sportsterpedia - A Toll-Free XLForum Information Highway!
So even if the fuses aren’t blown and what not, they could be at fault?
Reply With Quote
  #10  
Old 7th December 2021
IXL2Relax's Avatar
IXL2Relax IXL2Relax is offline
XL FORUM TEAM MEMBER
 
Join Date: Feb 2013
Location: Let Freedom Ring in PA
Posts: 9,051
Sportster/Buell Model: Sportster 883►1200
Sportster/Buell Year: 1994
IXL2Relax has disabled reputation
Default

Quote:
Originally Posted by Viffer View Post
So even if the fuses aren’t blown and what not, they could be at fault?
Corrosion is like dirt between the contacts, only very thin... It can cause intermittent loss of signals. Unless the contact is clean and tight, vibration can cause intermittent loss of signals. Sometimes corrosion can keep a contact from working & vibrations intermittently causes it to work. There are all kinds of strange results from the intermittent operation caused by a thin layer of corrosion on contacts. Especially if the power to the ECM/TSM/Speedo is intermittently broken - computer electronics hate that.

Sometimes, just disconnecting & reconnecting connectors will allow the contacts to wipe thru corrosion to make contact and stuff works again.

Clean contacts are important - that's why the mfrs use sealed connectors - but that is not always perfect, especially on a vibrating machine that is operated in the rain.

Be sure to use dielectric grease (which is non-conductive) - NOT regular grease which might have conductivity due to the ingredients...


IXL _______ >>>> My Motorcycle Chronicles Are Here <<<<
For Sportster Tech Info:
Ride The Sportsterpedia - A Toll-Free XLForum Information Highway!
Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT +1. The time now is 05:15.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
XL Forum® - Linson Media LLC