The Sportster and Buell Motorcycle Forum - The XLFORUM®
 

Go Back   The Sportster and Buell Motorcycle Forum - The XLFORUM® > SPORTSTER MOTORCYCLE FORUM > Sportster Motorcycle Era Specific and Model Specific > EFI Sportster Motorcycle Talk (2007 and up)
XLF Blogs XLF Arcade XLF Disclaimer/Privacy Statement/Terms Of Use

Notices

EFI Sportster Motorcycle Talk (2007 and up) For 2007 and above Sportsters

Active Threads
0 Roads I'd like to ride.
Last Post: Stairman
Posted On: 4 Minutes Ago
Replies: 3,854
Views: 481,505
0 Food porn
Last Post: Crusty
Posted On: 40 Minutes Ago
Replies: 2,847
Views: 736,328
0 Chinese sportster
Last Post: bustert
Posted On: 1 Hour Ago
Replies: 4
Views: 160
0 Oops, I signed up for another long ass ride: The 2022 Hoka Hey
Last Post: decman
Posted On: 1 Hour Ago
Replies: 46
Views: 4,620
0 Clutch Spring plate poll
Last Post: Bluto
Posted On: 1 Hour Ago
Replies: 325
Views: 83,610
0 Need a solution for the oil T hose
Last Post: bustert
Posted On: 1 Hour Ago
Replies: 2
Views: 184
0 Sportster Oil Pressure and Dynamics
Last Post: bustert
Posted On: 1 Hour Ago
Replies: 340
Views: 20,689
0 We Lost Another Sportster Rider Today
Last Post: IronMick
Posted On: 1 Hour Ago
Replies: 4
Views: 194
0 Need help tuning VM38
Last Post: ryder rick
Posted On: 1 Hour Ago
Replies: 14
Views: 289
0 what size motor?
Last Post: ryder rick
Posted On: 2 Hours Ago
Replies: 37
Views: 2,026
0 Keep & Kill
Last Post: Crusty
Posted On: 3 Hours Ago
Replies: 29,867
Views: 1,754,234
0 Snippets
Last Post: Crusty
Posted On: 3 Hours Ago
Replies: 694
Views: 103,084
0 Official XL Forum Random Image Thread (NO NUDITY!)
Last Post: cal43
Posted On: 3 Hours Ago
Replies: 54,814
Views: 9,345,185
0 Hot Rods, Rat Rods, and Customs.
Last Post: cal43
Posted On: 3 Hours Ago
Replies: 5,318
Views: 1,191,869
0 This is gonna hurt.
Last Post: cal43
Posted On: 4 Hours Ago
Replies: 9,714
Views: 2,353,833
0 Hottie of the day, no nudity.
Last Post: cal43
Posted On: 4 Hours Ago
Replies: 37,907
Views: 4,766,604
0 Hot Chicks on Hot Bikes
Last Post: cal43
Posted On: 4 Hours Ago
Replies: 13,250
Views: 3,370,674
7 Greetings from Norway!
Last Post: Bikeaholic
Posted On: 7 Hours Ago
Replies: 12
Views: 331
0 new from the Netherlands
Last Post: Bikeaholic
Posted On: 7 Hours Ago
Replies: 13
Views: 823
0 Howdy from St Louis
Last Post: Bikeaholic
Posted On: 7 Hours Ago
Replies: 13
Views: 721
0 Morning constitution:
Last Post: harley506d
Posted On: 7 Hours Ago
Replies: 1
Views: 77
0 Instrument of Expression, the next chapter of the Sportster legacy
Last Post: Andy56
Posted On: 9 Hours Ago
Replies: 51
Views: 5,034
0 how many run baffles, run open, or just run stock
Last Post: 84rzv500r
Posted On: 9 Hours Ago
Replies: 414
Views: 103,910
0 Hello from mississauga ont
Last Post: Highly-Dangerous
Posted On: 10 Hours Ago
Replies: 13
Views: 876
0 Figure i'd finally introduce myself
Last Post: Highly-Dangerous
Posted On: 10 Hours Ago
Replies: 11
Views: 578
0 Hey from illinois
Last Post: Highly-Dangerous
Posted On: 10 Hours Ago
Replies: 9
Views: 564
0 Another Member
Last Post: Highly-Dangerous
Posted On: 10 Hours Ago
Replies: 9
Views: 389
0 Hi from France
Last Post: Highly-Dangerous
Posted On: 10 Hours Ago
Replies: 9
Views: 415
0 Murph from MN
Last Post: Highly-Dangerous
Posted On: 10 Hours Ago
Replies: 10
Views: 497
0 Hi from Sussex
Last Post: Highly-Dangerous
Posted On: 10 Hours Ago
Replies: 8
Views: 429
More...
Members Birthdays
Reply
 
Share Thread Tools Display Modes
  #1  
Old 21st May 2022
kuch73's Avatar
kuch73 kuch73 is offline
Biker
 
Join Date: Mar 2022
Posts: 23
Sportster/Buell Model: 1200C
Sportster/Buell Year: 2007
Reputation: 119897
kuch73 has much to be proud ofkuch73 has much to be proud ofkuch73 has much to be proud ofkuch73 has much to be proud ofkuch73 has much to be proud ofkuch73 has much to be proud ofkuch73 has much to be proud ofkuch73 has much to be proud ofkuch73 has much to be proud ofkuch73 has much to be proud ofkuch73 has much to be proud of
Default 2007 1200 low idle when hot...

My 07 1200 just started to get a real low idle when hot and sometimes dies at lights and stop signs. It starts right back up no issues. This seems to be intermittent. I just installed VIEDs and also added more tension to the throttle body return spring for a little more resistance on the throttle. I found the stock spring to be real sensitive to bumps and turns and such. I checked for codes and only have P0131 and P0151 which are both O2 sensors reading lean, which should be normal with any IED install, but no other codes. I just ordered a new VSS as I am also having issues with the speedo dropping off intermittently, as well as ordered a new CKP just to replace it. But, any other ideas as to why it may be having an intermittent low idle. Thoughts, thanks
Reply With Quote
  #2  
Old 22nd May 2022
Toejam503's Avatar
Toejam503 Toejam503 is offline
Air-Cooled Forever
 
Join Date: May 2010
Location: Dakota Territory
Posts: 3,330
Sportster/Buell Model: XL 1200 C
Sportster/Buell Year: 2006
Sportster/Buell Model #2: (Prev.Own)XLH Milw.Spec.
Sportster/Buell Year #2: 1981
Reputation: 6795622
Toejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond repute
Default

Dual or single throttle cable?
Reply With Quote
  #3  
Old 22nd May 2022
kuch73's Avatar
kuch73 kuch73 is offline
Biker
 
Join Date: Mar 2022
Posts: 23
Sportster/Buell Model: 1200C
Sportster/Buell Year: 2007
Reputation: 119897
kuch73 has much to be proud ofkuch73 has much to be proud ofkuch73 has much to be proud ofkuch73 has much to be proud ofkuch73 has much to be proud ofkuch73 has much to be proud ofkuch73 has much to be proud ofkuch73 has much to be proud ofkuch73 has much to be proud ofkuch73 has much to be proud ofkuch73 has much to be proud of
Default

it's a dual cable, maybe I can just turn the idle screw out a tad
Reply With Quote
  #4  
Old 22nd May 2022
Toejam503's Avatar
Toejam503 Toejam503 is offline
Air-Cooled Forever
 
Join Date: May 2010
Location: Dakota Territory
Posts: 3,330
Sportster/Buell Model: XL 1200 C
Sportster/Buell Year: 2006
Sportster/Buell Model #2: (Prev.Own)XLH Milw.Spec.
Sportster/Buell Year #2: 1981
Reputation: 6795622
Toejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond repute
Default

The bike is supposed to idle around 1100rpm, warm. I know, it seems a little fast but it's a Sportster and not a BT. So with FI, I assume the idle is about 1400 rpm for a half minute or so, when cold.
Reply With Quote
  #5  
Old 22nd May 2022
Tomcatt Tomcatt is offline
Dazed & Confused
 
Join Date: Feb 2019
Location: Never Never Land
Posts: 3,069
Sportster/Buell Model: XL1200C
Sportster/Buell Year: 2017
Other Motorcycle Model: BMW R9T
Other Motorcycle Year: 2015
Reputation: 3795674
Tomcatt has a reputation beyond reputeTomcatt has a reputation beyond reputeTomcatt has a reputation beyond reputeTomcatt has a reputation beyond reputeTomcatt has a reputation beyond reputeTomcatt has a reputation beyond reputeTomcatt has a reputation beyond reputeTomcatt has a reputation beyond reputeTomcatt has a reputation beyond reputeTomcatt has a reputation beyond reputeTomcatt has a reputation beyond repute
Default

Quote:
Originally Posted by kuch73 View Post
My 07 1200 just started to get a real low idle when hot and sometimes dies at lights and stop signs... I just installed VIEDs...
Did this start right after you installed the VIED's?
__________________
2017 XL1200C in SE Wisconsin, USA
Reply With Quote
  #6  
Old 22nd May 2022
IXL2Relax's Avatar
IXL2Relax IXL2Relax is offline
XL FORUM TEAM MEMBER
 
Join Date: Feb 2013
Location: Let Freedom Ring in PA
Posts: 9,362
Sportster/Buell Model: Sportster 883►1200
Sportster/Buell Year: 1994
IXL2Relax has disabled reputation
Default

Have you checked the Idle Air Control?

http://sportsterpedia.com/doku.php/t...le_air_control


IXL _______ >>>> My Motorcycle Chronicles Are Here <<<<
For Sportster Tech Info:
Ride The Sportsterpedia - A Toll-Free XLForum Information Highway!
__________________
### The ride is more enjoyable to nowhere in particular! ###
Reply With Quote
  #7  
Old 22nd May 2022
kuch73's Avatar
kuch73 kuch73 is offline
Biker
 
Join Date: Mar 2022
Posts: 23
Sportster/Buell Model: 1200C
Sportster/Buell Year: 2007
Reputation: 119897
kuch73 has much to be proud ofkuch73 has much to be proud ofkuch73 has much to be proud ofkuch73 has much to be proud ofkuch73 has much to be proud ofkuch73 has much to be proud ofkuch73 has much to be proud ofkuch73 has much to be proud ofkuch73 has much to be proud ofkuch73 has much to be proud ofkuch73 has much to be proud of
Default

I installed the VIeds and added more tension to the throttle spring at the same time, but also reading the sportsterpedia page it mentions that the IAC gets its signal when the VSS is 0. As I am also getting erratic speedo readings maybe my VSS is the culprit.
Reply With Quote
  #8  
Old 23rd May 2022
kuch73's Avatar
kuch73 kuch73 is offline
Biker
 
Join Date: Mar 2022
Posts: 23
Sportster/Buell Model: 1200C
Sportster/Buell Year: 2007
Reputation: 119897
kuch73 has much to be proud ofkuch73 has much to be proud ofkuch73 has much to be proud ofkuch73 has much to be proud ofkuch73 has much to be proud ofkuch73 has much to be proud ofkuch73 has much to be proud ofkuch73 has much to be proud ofkuch73 has much to be proud ofkuch73 has much to be proud ofkuch73 has much to be proud of
Default

I removed the Vieds yesterday and went for a ride this morning and did not have any issues. I have also read on a few threads here that many run these at their minimum setting, which gives about a 14.3 AFR. I had them set to the recommended 50% setting which gives a 14.0 AFR. I am thinking that this is too rich for my ride and is causing it to load up some at idle when hot. I am going to put them back on and turn them down to their minimum setting and see how they do. One thing though is that the part throttle popping and decel popping is back, so they are working in that regard. I will report back tomorrow on the results.
Reply With Quote
  #9  
Old 23rd May 2022
Bluto Bluto is offline
Chief Know It All
 
Join Date: Jan 2018
Location: California
Posts: 411
Sportster/Buell Model: XL1200R Roadster
Sportster/Buell Year: 2008
Other Motorcycle Model: Norton 850 Commando
Other Motorcycle Year: 1973
Reputation: 1125195
Bluto has a reputation beyond reputeBluto has a reputation beyond reputeBluto has a reputation beyond reputeBluto has a reputation beyond reputeBluto has a reputation beyond reputeBluto has a reputation beyond reputeBluto has a reputation beyond reputeBluto has a reputation beyond reputeBluto has a reputation beyond reputeBluto has a reputation beyond reputeBluto has a reputation beyond repute
Default

BTW the correct way to adjust the throttle cables on an EFI Sportster is not obvious, or wasn't to me anyway.
Hammer Performance shows how to do it right...

https://youtu.be/M6Ee5aCifxA

Reply With Quote
  #10  
Old 23rd May 2022
Andy56 Andy56 is offline
Chief Know It All
 
Join Date: Jan 2019
Location: UK
Posts: 423
Sportster/Buell Model: XL1200T
Sportster/Buell Year: 2017
Reputation: 198699
Andy56 has a brilliant futureAndy56 has a brilliant futureAndy56 has a brilliant futureAndy56 has a brilliant futureAndy56 has a brilliant futureAndy56 has a brilliant futureAndy56 has a brilliant futureAndy56 has a brilliant futureAndy56 has a brilliant futureAndy56 has a brilliant futureAndy56 has a brilliant future
Default

I like videos that reinforce an idea or show tips and tricks that fully explain what HD mean or a better way to get the job done...

The idle cable apparently needs to be adjusted with the steering pointed fully to the right.

Reading the manual after you have the throttle butterfly fully open the grip should be released and the adjuster should be turned another 1/2 to 1 turn.
Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT +1. The time now is 17:49.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
XL Forum® - Linson Media LLC