The Sportster and Buell Motorcycle Forum - The XLFORUM®
 

Go Back   The Sportster and Buell Motorcycle Forum - The XLFORUM® > SPORTSTER MOTORCYCLE FORUM > Sportster Motorcycle Era Specific and Model Specific > EFI Sportster Motorcycle Talk (2007 and up)
XLF Blogs XLF Arcade XLF Disclaimer/Privacy Statement/Terms Of Use

Notices

EFI Sportster Motorcycle Talk (2007 and up) For 2007 and above Sportsters

Active Threads
0 Official XL Forum Random Image Thread (NO NUDITY!)
Last Post: Stairman
Posted On: 2 Minutes Ago
Replies: 53,085
Views: 8,995,232
0 Turn signals stopped blinking
Last Post: rejeanprimeau
Posted On: 4 Minutes Ago
Replies: 9
Views: 262
0 Keep & Kill
Last Post: Graywolf
Posted On: 19 Minutes Ago
Replies: 27,005
Views: 1,564,710
0 Massachusetts 2022
Last Post: mick42
Posted On: 49 Minutes Ago
Replies: 47
Views: 1,832
0 High beam not working
Last Post: Jaime1840
Posted On: 50 Minutes Ago
Replies: 13
Views: 434
0 What's up with this turn signal?
Last Post: NLXL
Posted On: 1 Hour Ago
Replies: 6
Views: 63
0 What did you do for your sporty Today?
Last Post: cycowrencher
Posted On: 2 Hours Ago
Replies: 7,879
Views: 1,371,527
0 video & pics
Last Post: cal43
Posted On: 3 Hours Ago
Replies: 809
Views: 85,220
0 Hot Chicks on Hot Bikes
Last Post: cal43
Posted On: 3 Hours Ago
Replies: 12,749
Views: 3,083,079
0 Hottie of the day, no nudity.
Last Post: cal43
Posted On: 3 Hours Ago
Replies: 34,120
Views: 4,118,803
0 Informed reviews!
Last Post: Ferrous Head
Posted On: 6 Hours Ago
Replies: 25
Views: 1,101
0 My new deer rifle
Last Post: kitabel
Posted On: 7 Hours Ago
Replies: 6
Views: 121
5 Removing primary engine sprocket nut with heat gun, special caution needed?
Last Post: IronMick
Posted On: 8 Hours Ago
Replies: 30
Views: 1,232
0 VOES issues? Adjustments needed?
Last Post: Edster
Posted On: 8 Hours Ago
Replies: 16
Views: 503
0 1995 Manual
Last Post: RandallM
Posted On: 8 Hours Ago
Replies: 9
Views: 273
0 1967 on FaceBook. Florida.
Last Post: rokytnji
Posted On: 10 Hours Ago
Replies: 0
Views: 46
0 Getting old is a bitch!
Last Post: rejeanprimeau
Posted On: 11 Hours Ago
Replies: 35
Views: 7,791
0 Coulda' - Shoulda' - Woulda' - Solenoid/Bendix?
Last Post: Ferrous Head
Posted On: 12 Hours Ago
Replies: 77
Views: 2,691
0 re rocker arm cover spewing out oil
Last Post: Ferrous Head
Posted On: 13 Hours Ago
Replies: 11
Views: 780
0 weight loss thread
Last Post: Steve9
Posted On: 14 Hours Ago
Replies: 81
Views: 29,494
0 1988 Coil wiring
Last Post: rokytnji
Posted On: 15 Hours Ago
Replies: 4
Views: 167
0 "The Blues" thread!
Last Post: Graywolf
Posted On: 15 Hours Ago
Replies: 1,114
Views: 160,931
0 Digital volt meter
Last Post: sportsterpaul
Posted On: 16 Hours Ago
Replies: 10
Views: 473
0 Do Loud Pipes in fact save lives?
Last Post: Steve9
Posted On: 16 Hours Ago
Replies: 2,605
Views: 321,006
5 Best way to ship large parts?
Last Post: Nightmare
Posted On: 18 Hours Ago
Replies: 5
Views: 151
3 Wtb, Wts, Wtt, Wtg (Ironhead)
Last Post: Nightmare
Posted On: 18 Hours Ago
Replies: 27
Views: 291,269
0 04 Sportster refurb and build.
Last Post: Iron Mike
Posted On: 22 Hours Ago
Replies: 120
Views: 9,320
0 This is gonna hurt.
Last Post: cal43
Posted On: 23 Hours Ago
Replies: 9,277
Views: 2,190,911
0 Hot Rods, Rat Rods, and Customs.
Last Post: cal43
Posted On: 23 Hours Ago
Replies: 4,955
Views: 1,020,809
0 a brand new Corvette convertible
Last Post: NLXL
Posted On: 1 Day Ago
Replies: 1
Views: 178
More...
Members Birthdays
Taipan (63), Harveyveepower (62), regoscar (53), kmm0000 (47), SmokeyDrifter (39)
Tags
electrical help, no click, turn signal, won’t start

Reply
 
Share Thread Tools Display Modes
  #1  
Old 6th December 2021
Viffer Viffer is offline
Biker
 
Join Date: Dec 2021
Posts: 5
Sportster/Buell Model: XL883
Sportster/Buell Year: 2007
Reputation: 10
Viffer is an unknown quantity at this point
Default 2007 Sportster 883 won’t start; no turn signals

I was out riding my Sportster 883 as normal. While in the ride, the red key light comes on and stays on, on the Speedo. Other than that, no changes.

When I pulled into the garage, I turn the bike off. I try to turn it back on, and nothing. I turn the ignition, flip the switch to run, I hear the fuel pump activate, and that’s all. When I push start, even in neutral with clutch in or in gear, nothing. No click, or sound, or anything.

So I check for codes. Here’s what I find:
- P: Code U1301
- S: No response
- SP: U1301, U1255
- T: I don’t have one, so no response.
I checked the ECM plug in, the TSM plug in, and the battery health, connections and ground. I have not checked for shorts in individual wires throughout the harness yet.

The TSM appears to be working, at LEAST partially, as pulling it out and moving it sideways activated the tilt sensor.

Note that this is a TSM and not as TSSM, as I do not have a fob, thus no security issues.

So it appears with the no response to the TSM, their is a short in the wiring somewhere? Does that sound right? I believe it’s telling me the ECM is short, and the Speedo is short AND is getting no data.

I also wonder what could lead to this happening all at once? I had a perfectly functioning bike that would start as always, and now it ain’t start at all.

Some things to note: it’s a stock 07 XL883 with a few aesthetic mods but nothing electrical save for an LED headlight replacing the original halogen that has worked great for thousands of miles. It has 13,500 miles on it.

When this all happened, the turn sig also stopped working. All of the fuses are in good condition, and I know the specific turn signal fuse is working, because that same fuse powers the brake light function, which is working properly.

Sorry if this was a lot, it’s my first post and I wanted to be as thorough as possible. I just want to ride my Harley again, and not having any leads has been disheartening.
Reply With Quote
  #2  
Old 7th December 2021
shanneba shanneba is offline
XL FORUM TEAM MEMBER
 
Join Date: Jul 2013
Location: Franklin, Indiana
Posts: 2,724
Sportster/Buell Model: XL1200C
Sportster/Buell Year: 2013
Reputation: 5381366
shanneba has a reputation beyond reputeshanneba has a reputation beyond reputeshanneba has a reputation beyond reputeshanneba has a reputation beyond reputeshanneba has a reputation beyond reputeshanneba has a reputation beyond reputeshanneba has a reputation beyond reputeshanneba has a reputation beyond reputeshanneba has a reputation beyond reputeshanneba has a reputation beyond reputeshanneba has a reputation beyond repute
Default

The TSM controls the turn signals and supplies voltage for the turn signals to operate.
A short on the turn signal circuits can cause the battery fuse to open.
If no short to ground is found in the battery fuse circuit check the turn
signal circuits between the TSM and the turn signals for a short to ground.
__________________
2013 XL1200C

Find your Owner's Manual, Wiring Diagram and Parts Catalog here :

https://serviceinfo.harley-davidson....cle/lookupForm
Enter your VIN OR
Use the search - enter year and model

If something doesn't work on your Sportster look here:
SportsterPedia.com
Reply With Quote
  #3  
Old 7th December 2021
Viffer Viffer is offline
Biker
 
Join Date: Dec 2021
Posts: 5
Sportster/Buell Model: XL883
Sportster/Buell Year: 2007
Reputation: 10
Viffer is an unknown quantity at this point
Default

Quote:
Originally Posted by shanneba View Post
The TSM controls the turn signals and supplies voltage for the turn signals to operate.
A short on the turn signal circuits can cause the battery fuse to open.
If no short to ground is found in the battery fuse circuit check the turn
signal circuits between the TSM and the turn signals for a short to ground.
Thanks for the reply. Are you saying check with a voltmeter? I assume you mean check the module itself for a short, and then check the harness that plugs into the TSM for a short there? Just wanted to clarify, I’m only versed in Japanese bikes so this is all fresh.

I was thinking it may be the module itself based on the healthy fuses and relays but I’m really not sure of anything at this point. I know it can’t be the whole harness/all the wires in the harness because the brake light, horn and headlight bright switch all still work fine. I’m also hoping it’s not the starter, and is just a code issue PREVENTING it from starting.
Reply With Quote
  #4  
Old 7th December 2021
IXL2Relax's Avatar
IXL2Relax IXL2Relax is offline
XL FORUM TEAM MEMBER
 
Join Date: Feb 2013
Location: Let Freedom Ring in PA
Posts: 9,065
Sportster/Buell Model: Sportster 883►1200
Sportster/Buell Year: 1994
IXL2Relax has disabled reputation
Default

http://sportsterpedia.com/doku.php/t...:elec02#relays

Sportsterpedia Note: The 2007-2009 model years have a significant history of corrosion and gunk collecting in the fuse/relay tray causing low-grade shorts and erratic electrical operation - This is especially problematic if the bike is left outside or operated in the rain. It's a good idea to check & thoroughly clean this entire tray at least every year (or 4 to 6 months if parked outside).

Relays are relatively inexpensive - Change them out every few years as a preventative maintenance measure.

Read over the Sportsterpedia section on Turn Signal Modules:
http://sportsterpedia.com/doku.php/t...3#turn_signals

IXL _______ >>>> My Motorcycle Chronicles Are Here <<<<
For Sportster Tech Info:
Ride The Sportsterpedia - A Toll-Free XLForum Information Highway!
__________________
### The ride is more enjoyable to nowhere in particular! ###
Reply With Quote
  #5  
Old 7th December 2021
Viffer Viffer is offline
Biker
 
Join Date: Dec 2021
Posts: 5
Sportster/Buell Model: XL883
Sportster/Buell Year: 2007
Reputation: 10
Viffer is an unknown quantity at this point
Default

Quote:
Originally Posted by IXL2Relax View Post
http://sportsterpedia.com/doku.php/t...:elec02#relays

Sportsterpedia Note: The 2007-2009 model years have a significant history of corrosion and gunk collecting in the fuse/relay tray causing low-grade shorts and erratic electrical operation - This is especially problematic if the bike is left outside or operated in the rain. It's a good idea to check & thoroughly clean this entire tray at least every year (or 4 to 6 months if parked outside).

Relays are relatively inexpensive - Change them out every few years as a preventative maintenance measure.

Read over the Sportsterpedia section on Turn Signal Modules:
http://sportsterpedia.com/doku.php/t...3#turn_signals

Thanks for the info. What should I use to clean the tray?

IXL _______ >>>> My Motorcycle Chronicles Are Here <<<<
For Sportster Tech Info:
Ride The Sportsterpedia - A Toll-Free XLForum Information Highway!
Reply With Quote
  #6  
Old 7th December 2021
IXL2Relax's Avatar
IXL2Relax IXL2Relax is offline
XL FORUM TEAM MEMBER
 
Join Date: Feb 2013
Location: Let Freedom Ring in PA
Posts: 9,065
Sportster/Buell Model: Sportster 883►1200
Sportster/Buell Year: 1994
IXL2Relax has disabled reputation
Default

https://www.google.com/search?q=elec...+cleaner+spray

Check the directions for issues regarding painted surfaces.


Once the tray is thoroughly cleaned, apply a coat of dielectric grease to all the tray contacts & to the new relay contacts.

Do the same for the TSM & connector.


IXL _______ >>>> My Motorcycle Chronicles Are Here <<<<
For Sportster Tech Info:
Ride The Sportsterpedia - A Toll-Free XLForum Information Highway!
Reply With Quote
  #7  
Old 7th December 2021
Viffer Viffer is offline
Biker
 
Join Date: Dec 2021
Posts: 5
Sportster/Buell Model: XL883
Sportster/Buell Year: 2007
Reputation: 10
Viffer is an unknown quantity at this point
Default

Awesome I’ll give it a whirl
Reply With Quote
  #8  
Old 7th December 2021
IXL2Relax's Avatar
IXL2Relax IXL2Relax is offline
XL FORUM TEAM MEMBER
 
Join Date: Feb 2013
Location: Let Freedom Ring in PA
Posts: 9,065
Sportster/Buell Model: Sportster 883►1200
Sportster/Buell Year: 1994
IXL2Relax has disabled reputation
Default

While you're at it, I'd clean & dielectric grease the Speedo Connection & the ECM since those codes were displayed...

But, corrosion on the fuse tray can cause all kinds of havoc and strange symptons.

After the cleaning job, clear the codes and see if any return...
http://sportsterpedia.com/doku.php/t...k:ref:genmsr08


IXL _______ >>>> My Motorcycle Chronicles Are Here <<<<
For Sportster Tech Info:
Ride The Sportsterpedia - A Toll-Free XLForum Information Highway!
Reply With Quote
  #9  
Old 7th December 2021
Viffer Viffer is offline
Biker
 
Join Date: Dec 2021
Posts: 5
Sportster/Buell Model: XL883
Sportster/Buell Year: 2007
Reputation: 10
Viffer is an unknown quantity at this point
Default

Quote:
Originally Posted by IXL2Relax View Post
While you're at it, I'd clean & dielectric grease the Speedo Connection & the ECM since those codes were displayed...

But, corrosion on the fuse tray can cause all kinds of havoc and strange symptons.

After the cleaning job, clear the codes and see if any return...
http://sportsterpedia.com/doku.php/t...k:ref:genmsr08


IXL _______ >>>> My Motorcycle Chronicles Are Here <<<<
For Sportster Tech Info:
Ride The Sportsterpedia - A Toll-Free XLForum Information Highway!
So even if the fuses aren’t blown and what not, they could be at fault?
Reply With Quote
  #10  
Old 7th December 2021
IXL2Relax's Avatar
IXL2Relax IXL2Relax is offline
XL FORUM TEAM MEMBER
 
Join Date: Feb 2013
Location: Let Freedom Ring in PA
Posts: 9,065
Sportster/Buell Model: Sportster 883►1200
Sportster/Buell Year: 1994
IXL2Relax has disabled reputation
Default

Quote:
Originally Posted by Viffer View Post
So even if the fuses aren’t blown and what not, they could be at fault?
Corrosion is like dirt between the contacts, only very thin... It can cause intermittent loss of signals. Unless the contact is clean and tight, vibration can cause intermittent loss of signals. Sometimes corrosion can keep a contact from working & vibrations intermittently causes it to work. There are all kinds of strange results from the intermittent operation caused by a thin layer of corrosion on contacts. Especially if the power to the ECM/TSM/Speedo is intermittently broken - computer electronics hate that.

Sometimes, just disconnecting & reconnecting connectors will allow the contacts to wipe thru corrosion to make contact and stuff works again.

Clean contacts are important - that's why the mfrs use sealed connectors - but that is not always perfect, especially on a vibrating machine that is operated in the rain.

Be sure to use dielectric grease (which is non-conductive) - NOT regular grease which might have conductivity due to the ingredients...


IXL _______ >>>> My Motorcycle Chronicles Are Here <<<<
For Sportster Tech Info:
Ride The Sportsterpedia - A Toll-Free XLForum Information Highway!
Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT +1. The time now is 12:26.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
XL Forum® - Linson Media LLC