The Sportster and Buell Motorcycle Forum - The XLFORUM®
 

Go Back   The Sportster and Buell Motorcycle Forum - The XLFORUM® > SPORTSTER MOTORCYCLE FORUM > Sportster Motorcycle Intake and Exhaust > Sportster Motorcycle Air intake, Carburetor, EFI, Fuel, and Exhaust
XLF Blogs XLF Arcade XLF Disclaimer/Privacy Statement/Terms Of Use

Sportster Motorcycle Air intake, Carburetor, EFI, Fuel, and Exhaust Problems, advice and/or how tos for Sporster and Buell motorcycle carburators, Electronic Fuel Injection (EFI), Air Intake, Fuel and Exhaust.

Active Threads
0 Intake seals, glad I checked them
Last Post: John Harper
Posted On: 8 Minutes Ago
Replies: 1
Views: 15
0 simple HF jack-lift for sporty mod.
Last Post: Iron Mike
Posted On: 28 Minutes Ago
Replies: 14
Views: 248
0 What did you do for your sporty Today?
Last Post: Steve9
Posted On: 41 Minutes Ago
Replies: 6,738
Views: 929,742
0 Spark Plugs
Last Post: ryder rick
Posted On: 43 Minutes Ago
Replies: 85
Views: 52,297
0 xied or x14ied?
Last Post: Joe_jeep
Posted On: 45 Minutes Ago
Replies: 0
Views: 9
0 Snippets
Last Post: sportsterpaul
Posted On: 46 Minutes Ago
Replies: 34
Views: 4,202
0 Drastic Failure how to diagnose
Last Post: glbsportster
Posted On: 53 Minutes Ago
Replies: 56
Views: 4,749
0 Xlch spark plugs
Last Post: IronMick
Posted On: 56 Minutes Ago
Replies: 6
Views: 138
0 Official XL Forum Random Image Thread (NO NUDITY!)
Last Post: Graywolf
Posted On: 1 Hour Ago
Replies: 46,830
Views: 7,458,090
0 Keep & Kill
Last Post: Graywolf
Posted On: 1 Hour Ago
Replies: 16,270
Views: 925,706
0 Diagnostic code ?
Last Post: sportsterpaul
Posted On: 1 Hour Ago
Replies: 31
Views: 917
0 I hope this is not the "New Normal"
Last Post: rokytnji
Posted On: 1 Hour Ago
Replies: 3
Views: 65
0 Help with jacking up my sportster
Last Post: boomerguy
Posted On: 1 Hour Ago
Replies: 26
Views: 2,774
0 Solenoid issue?
Last Post: Gulf Coaster
Posted On: 1 Hour Ago
Replies: 18
Views: 896
0 Resto-Repair 84 ironhead
Last Post: ryder rick
Posted On: 2 Hours Ago
Replies: 20
Views: 1,003
0 Corona Virus
Last Post: NLXL
Posted On: 2 Hours Ago
Replies: 344
Views: 17,547
0 Help, Headlight out and fuse thing clicks?
Last Post: Hellbent_4
Posted On: 2 Hours Ago
Replies: 9
Views: 515
0 PSA on headlight shell wires
Last Post: Hellbent_4
Posted On: 2 Hours Ago
Replies: 0
Views: 50
0 harbor freight lift
Last Post: Hellbent_4
Posted On: 2 Hours Ago
Replies: 22
Views: 867
0 Digital odometer
Last Post: onadraw
Posted On: 2 Hours Ago
Replies: 4
Views: 151
0 1986-90 Evo Sportsters: What every owner should know but were afraid to ask
Last Post: Hippysmack
Posted On: 3 Hours Ago
Replies: 390
Views: 54,045
0 86-90 regulator-rectifier on 2003 engine?
Last Post: IXL2Relax
Posted On: 3 Hours Ago
Replies: 16
Views: 297
10 The better than average BLUE bike thread!
Last Post: Hellbent_4
Posted On: 3 Hours Ago
Replies: 398
Views: 123,833
0 Show your favorite pic of your bike. just one
Last Post: Hellbent_4
Posted On: 3 Hours Ago
Replies: 4,774
Views: 1,848,444
0 Hottie of the day, no nudity.
Last Post: trainman
Posted On: 4 Hours Ago
Replies: 17,867
Views: 1,802,182
0 Ceramic Wax
Last Post: Tomcatt
Posted On: 4 Hours Ago
Replies: 3
Views: 68
0 ....1
Last Post: Graywolf
Posted On: 4 Hours Ago
Replies: 5,163
Views: 309,128
0 Don't drive angry
Last Post: needspeed
Posted On: 4 Hours Ago
Replies: 10
Views: 490
0 Talk to me about Painting
Last Post: Ireeman
Posted On: 4 Hours Ago
Replies: 16
Views: 439
0 Government and financial services rip-off
Last Post: Ireeman
Posted On: 5 Hours Ago
Replies: 9
Views: 344
More...
Members Birthdays
mcevoy, Dnight (54), alvin01101 (54), rahean (52), 2005883c (46), cliff883 (45), HotRodSporty (44), Wes Marshall (41), liquidice148 (34)
Reply
 
Share Thread Tools Display Modes
  #1  
Old 10th July 2019
smm1200 smm1200 is offline
Biker
 
Join Date: Jul 2019
Posts: 38
Sportster/Buell Model: 1200xl
Sportster/Buell Year: 2008
Reputation: 12811
smm1200 is a glorious beacon of lightsmm1200 is a glorious beacon of lightsmm1200 is a glorious beacon of lightsmm1200 is a glorious beacon of lightsmm1200 is a glorious beacon of lightsmm1200 is a glorious beacon of lightsmm1200 is a glorious beacon of lightsmm1200 is a glorious beacon of lightsmm1200 is a glorious beacon of lightsmm1200 is a glorious beacon of lightsmm1200 is a glorious beacon of light
Default EFI hose clamps

I am having problems with a NOS sportster, 08 with 2700 miles that had its pump replaced last year. Gauge on the way to check pressure. The pump has let me know with loud squeal/whine that it is not happy. Trying to get parts in order in advance. Any one know what size the small hose clamps on the corrugated hose on the pump. I have 12.8, but cannot tell whether they might be 12.3 or 13.3....hmmm. The HD part does not help since no one describes size. thanks in advance.
Reply With Quote
  #2  
Old 10th July 2019
seajay's Avatar
seajay seajay is offline
XL FORUM TEAM MEMBER
 
Join Date: Nov 2004
Location: jupiter fl
Posts: 2,697
Sportster/Buell Model: 1200C
Sportster/Buell Year: 04
Reputation: 827146
seajay has a reputation beyond reputeseajay has a reputation beyond reputeseajay has a reputation beyond reputeseajay has a reputation beyond reputeseajay has a reputation beyond reputeseajay has a reputation beyond reputeseajay has a reputation beyond reputeseajay has a reputation beyond reputeseajay has a reputation beyond reputeseajay has a reputation beyond reputeseajay has a reputation beyond repute
Default

Are you sure its the oil pump making the noise? What is the history of the bike? Oil pump replaced with only 2700 miles? Was oil circulating? Are the oil lines kinked or not going where they should? Might have other engine issues if oil wasn't circulating.
__________________
04/07 1275 BFH heads .590 Cat 4 cams S&S 1.725 rockers S&S premium lifters BDL+15% clutch TC88A HSR-45 S&S 3" ac LSR 2-1
Reply With Quote
  #3  
Old 10th July 2019
smm1200 smm1200 is offline
Biker
 
Join Date: Jul 2019
Posts: 38
Sportster/Buell Model: 1200xl
Sportster/Buell Year: 2008
Reputation: 12811
smm1200 is a glorious beacon of lightsmm1200 is a glorious beacon of lightsmm1200 is a glorious beacon of lightsmm1200 is a glorious beacon of lightsmm1200 is a glorious beacon of lightsmm1200 is a glorious beacon of lightsmm1200 is a glorious beacon of lightsmm1200 is a glorious beacon of lightsmm1200 is a glorious beacon of lightsmm1200 is a glorious beacon of lightsmm1200 is a glorious beacon of light
Default

seajay....thanks for reply....but this is EFI, fuel, pump hoses. Was not talking oil pump. Sorry for any confusion.
Reply With Quote
  #4  
Old 10th July 2019
seajay's Avatar
seajay seajay is offline
XL FORUM TEAM MEMBER
 
Join Date: Nov 2004
Location: jupiter fl
Posts: 2,697
Sportster/Buell Model: 1200C
Sportster/Buell Year: 04
Reputation: 827146
seajay has a reputation beyond reputeseajay has a reputation beyond reputeseajay has a reputation beyond reputeseajay has a reputation beyond reputeseajay has a reputation beyond reputeseajay has a reputation beyond reputeseajay has a reputation beyond reputeseajay has a reputation beyond reputeseajay has a reputation beyond reputeseajay has a reputation beyond reputeseajay has a reputation beyond repute
Default

Yeah, I got you. I'm a carb guy.
Reply With Quote
  #5  
Old 10th July 2019
b0fh's Avatar
b0fh b0fh is offline
Drag Race Champion
 
Join Date: Oct 2008
Location: Brazil
Posts: 357
Sportster/Buell Model: XL883R
Sportster/Buell Year: 2008
Sportster/Buell Model #2: XL1200CX Roadster
Sportster/Buell Year #2: 2017
Reputation: 301893
b0fh has a reputation beyond reputeb0fh has a reputation beyond reputeb0fh has a reputation beyond reputeb0fh has a reputation beyond reputeb0fh has a reputation beyond reputeb0fh has a reputation beyond reputeb0fh has a reputation beyond reputeb0fh has a reputation beyond reputeb0fh has a reputation beyond reputeb0fh has a reputation beyond reputeb0fh has a reputation beyond repute
Default

mine does a horrible noise on turn-on whenever i let it sit for too long like a week or more. sounds like a cat dying... also a 2008 and does this since new, pump still pumping strong
Reply With Quote
  #6  
Old 10th July 2019
Toejam503's Avatar
Toejam503 Toejam503 is offline
Air-Cooled Forever
 
Join Date: May 2010
Location: Dakota Territory
Posts: 2,861
Sportster/Buell Model: XL 1200 C
Sportster/Buell Year: 2006
Sportster/Buell Model #2: (Prev.Own)XLH Milw.Spec.
Sportster/Buell Year #2: 1981
Reputation: 5657406
Toejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond repute
Default

Quote:
Originally Posted by b0fh View Post
mine does a horrible noise on turn-on whenever i let it sit for too long like a week or more. sounds like a cat dying... also a 2008 and does this since new, pump still pumping strong
Sounds like the pump is dry, does it somehow lose it's prime, especially when setting for a while?
Reply With Quote
  #7  
Old 10th July 2019
b0fh's Avatar
b0fh b0fh is offline
Drag Race Champion
 
Join Date: Oct 2008
Location: Brazil
Posts: 357
Sportster/Buell Model: XL883R
Sportster/Buell Year: 2008
Sportster/Buell Model #2: XL1200CX Roadster
Sportster/Buell Year #2: 2017
Reputation: 301893
b0fh has a reputation beyond reputeb0fh has a reputation beyond reputeb0fh has a reputation beyond reputeb0fh has a reputation beyond reputeb0fh has a reputation beyond reputeb0fh has a reputation beyond reputeb0fh has a reputation beyond reputeb0fh has a reputation beyond reputeb0fh has a reputation beyond reputeb0fh has a reputation beyond reputeb0fh has a reputation beyond repute
Default

Quote:
Originally Posted by Toejam503 View Post
Sounds like the pump is dry, does it somehow lose it's prime, especially when setting for a while?


no idea. this particular bike (its an 883) never failed to start on 1st try its whole life, even when sitting for more than a month due to work travel and whatnot.

just makes the dying cat sound for a minute or so.
Reply With Quote
  #8  
Old 11th July 2019
Bikeaholic Bikeaholic is offline
XL FORUM LIFE MEMBER
 
Join Date: May 2015
Location: NSW, Australia.
Posts: 116
Sportster/Buell Model: xl1250
Sportster/Buell Year: 2008
Reputation: 118048
Bikeaholic has much to be proud ofBikeaholic has much to be proud ofBikeaholic has much to be proud ofBikeaholic has much to be proud ofBikeaholic has much to be proud ofBikeaholic has much to be proud ofBikeaholic has much to be proud ofBikeaholic has much to be proud ofBikeaholic has much to be proud ofBikeaholic has much to be proud ofBikeaholic has much to be proud of
Default

Hi,
So you had the fuel pump replaced last year? You now have 2700 miles and you are having squeal type noises when first priming the fuel pump. Are there any other problems with fuel this pump beside the noise? ( i know you are waiting on a pressure gauge to test it) . What was wrong with the first fuel pump?
I have a 2008 and mine has always made squeal, almost grating sound noises when turned on. It is worse when it has been sitting for a while at "first start" after sitting for long periods ( days, weeks etc) Always works and i have not noticed the bike suffer from incorrect fuel pressure. I think i remember reading that it not unusual to have noises from primming of the pump prior to starting. Please keep us informed. Ride safe.
Reply With Quote
  #9  
Old 11th July 2019
Toejam503's Avatar
Toejam503 Toejam503 is offline
Air-Cooled Forever
 
Join Date: May 2010
Location: Dakota Territory
Posts: 2,861
Sportster/Buell Model: XL 1200 C
Sportster/Buell Year: 2006
Sportster/Buell Model #2: (Prev.Own)XLH Milw.Spec.
Sportster/Buell Year #2: 1981
Reputation: 5657406
Toejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond repute
Default

You can probably dismiss this as pure Bullshit, but if I had an EFI bike and the pump made a constant start-up squeal I'd be tempted to run a small amount of 2-cycle oil, mixed with the gas, to help lubricate the internal parts of the pump. Maybe it would help, maybe not. It shouldn't damage the pump.
Reply With Quote
  #10  
Old 11th July 2019
smm1200 smm1200 is offline
Biker
 
Join Date: Jul 2019
Posts: 38
Sportster/Buell Model: 1200xl
Sportster/Buell Year: 2008
Reputation: 12811
smm1200 is a glorious beacon of lightsmm1200 is a glorious beacon of lightsmm1200 is a glorious beacon of lightsmm1200 is a glorious beacon of lightsmm1200 is a glorious beacon of lightsmm1200 is a glorious beacon of lightsmm1200 is a glorious beacon of lightsmm1200 is a glorious beacon of lightsmm1200 is a glorious beacon of lightsmm1200 is a glorious beacon of lightsmm1200 is a glorious beacon of light
Default

thanks for all discussion. ....the press gauge today.....runs near 60psi....so pump working. Not sure about flow rate.....not easy to just turn on pump and let it flow w/o another adapter.....the fittings have internal checks. But, revved up and no press loss.....soooo. Will now pull tank and pump assy for next steps. At this point I will replace some parts. Called dealer on parts....said they would call back...nonesuch. I still would like to know about size on the single ear clamps...may have to just go to harley to see if they have parts. Intend now to look at screen and filter, and probably replace pump as well due to noise....but I hear your points above on noise and been OK, I may change my mind on the pump for now since pressure ok. Will follow up with more findings. Now worried about injectors....maybe other problems like electrical since it just shuts down under full throttle over last several runs. But, will just follow the dots for now. thanks again.
Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT +1. The time now is 03:04.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
XL Forum® - Linson Media LLC