The Sportster and Buell Motorcycle Forum - The XLFORUM®
 

Go Back   The Sportster and Buell Motorcycle Forum - The XLFORUM® > SPORTSTER MOTORCYCLE ZONE > Sportster Motorcycle Drivetrain > Sportster Motorcycle Tires, Wheels, and Brakes
XLF Blogs XLF Arcade XLF Disclaimer/Privacy Statement/Terms Of Use

Notices

Sportster Motorcycle Tires, Wheels, and Brakes Discuss issues with Sportster motorcycle tires, wheels and brakes.

Active Threads
0 End of the road for me
Last Post: jammantoo
Posted On: 1 Minute Ago
Replies: 17
Views: 538
0 Hot Chicks on Hot Bikes
Last Post: lugster
Posted On: 5 Minutes Ago
Replies: 8,980
Views: 1,275,006
0 2 wire turn signal installing on 1 wire bike
Last Post: chris16371
Posted On: 8 Minutes Ago
Replies: 0
Views: 1
0 Lost compression?
Last Post: Dave L
Posted On: 14 Minutes Ago
Replies: 37
Views: 1,039
0 Sudden stiff rear brake pedal.
Last Post: rocketmangb
Posted On: 33 Minutes Ago
Replies: 4
Views: 95
4 Cross Country Prep
Last Post: DirtyHarry68
Posted On: 42 Minutes Ago
Replies: 7
Views: 162
0 New Hammer Impact Air Intake Powder Coated
Last Post: rocketmangb
Posted On: 43 Minutes Ago
Replies: 1
Views: 51
0 33.4 fork axle help
Last Post: Bturkey
Posted On: 46 Minutes Ago
Replies: 10
Views: 170
0 2018 East Coast Meet & Greet
Last Post: SteveK
Posted On: 1 Hour Ago
Replies: 619
Views: 34,579
0 TC88A and Raptor shift light
Last Post: rocketmangb
Posted On: 1 Hour Ago
Replies: 6
Views: 144
0 Hillbilly Hot Dogs
Last Post: gravydog
Posted On: 1 Hour Ago
Replies: 21
Views: 479
0 Intake manifold gasket fitment
Last Post: rocketmangb
Posted On: 1 Hour Ago
Replies: 9
Views: 98
0 Carb issues
Last Post: rocketmangb
Posted On: 1 Hour Ago
Replies: 4
Views: 86
0 Sportsterpedia Progress
Last Post: Hippysmack
Posted On: 1 Hour Ago
Replies: 160
Views: 31,405
0 Stuck in fist after a spill
Last Post: Glamazon
Posted On: 1 Hour Ago
Replies: 1
Views: 46
0 Pictures of Sportster Scene 1960s
Last Post: BSA Bob
Posted On: 1 Hour Ago
Replies: 1,816
Views: 777,676
0 Official XL Forum Random Image Thread (NO NUDITY!)
Last Post: Ireeman
Posted On: 2 Hours Ago
Replies: 40,906
Views: 6,273,890
4 Occasionally running troubles
Last Post: Toejam503
Posted On: 2 Hours Ago
Replies: 4
Views: 96
0 Anyone go racing last weekend?
Last Post: jcro61
Posted On: 2 Hours Ago
Replies: 2,661
Views: 238,635
0 My last real nagging problem
Last Post: Keep it running
Posted On: 2 Hours Ago
Replies: 10
Views: 352
0 Oil Pump upgrade
Last Post: hotrodbiker
Posted On: 2 Hours Ago
Replies: 8
Views: 217
0 ....1
Last Post: Graywolf
Posted On: 3 Hours Ago
Replies: 4,523
Views: 209,720
0 Patriot Defender whats the next best exhaust?
Last Post: wongjohnson
Posted On: 3 Hours Ago
Replies: 152
Views: 24,009
0 What kind of saddle do you use on your sporty?
Last Post: Ridneck1986
Posted On: 3 Hours Ago
Replies: 263
Views: 63,588
0 Xl/Buell drag bike parts
Last Post: cycowrencher
Posted On: 3 Hours Ago
Replies: 24
Views: 2,572
0 The country store
Last Post: lugster
Posted On: 3 Hours Ago
Replies: 281
Views: 14,263
0 XR1000 carbs Dellorto
Last Post: Toejam503
Posted On: 3 Hours Ago
Replies: 1
Views: 67
0 1995 Odometer Acting Strange
Last Post: JackFrost71
Posted On: 3 Hours Ago
Replies: 3
Views: 130
0 Poll: Hwy Pegs: fwd mount or crash bar mount?
Last Post: NZstu
Posted On: 4 Hours Ago
Replies: 61
Views: 22,130
More...
Members Birthdays
stevervp, philvet (75), outlawreb (63), rabes56 (62), Bigmatt (60), Beaker666 (54), hippiemwc (54), wumm883c (52), 2wheeltodd (51), israel (46), XRWeasel (44), Stitch (41), Dekooy (35), Titaniumrust (35), Ameri-Deutsch (34)
Sponsored Links
Reply
 
Share Thread Tools Display Modes
  #1  
Old 25th May 2018
Jowniofownio Jowniofownio is offline
Biker
 
Join Date: Feb 2018
Posts: 31
Sportster/Buell Model: Sportster Evo
Sportster/Buell Year: 1989
Reputation: 10
Jowniofownio is an unknown quantity at this point
Default Front brake won't bleed 1989 sportster

I have had the master cylinder in pieces and re sealed it the way it came out. I am now trying to bleed the brake and cannot get any fluid to leave the reservoir. Both holes are clear, the seals look good and I'm pretty sure it's built up as it sprang apart.

I would have thought that if the res was filled up and the hose off the master cylinder, fluid should slowly drain out through the small hole onto the floor. I'm not having any fluid leave the res. If I try bleeding it, nothing leaves the res. If I have it all connected up with fluid in re res and prime the piston and master, if I push back on the brake pads, the level of the res doesn't raise?

I'm very confused as never had issues bleeding brakes before

Any ideas?
Reply With Quote
  #2  
Old 26th May 2018
decman decman is offline
Post no Avatars!
 
Join Date: Jan 2005
Location: Dubois, WY
Posts: 3,755
Sportster/Buell Model: 1200S
Sportster/Buell Year: 2001
Sportster/Buell Model #2: XLH-883D
Sportster/Buell Year #2: 1988
Other Motorcycle Model: FXDXT
Other Motorcycle Year: 2001
Reputation: 1920872
decman has a reputation beyond reputedecman has a reputation beyond reputedecman has a reputation beyond reputedecman has a reputation beyond reputedecman has a reputation beyond reputedecman has a reputation beyond reputedecman has a reputation beyond reputedecman has a reputation beyond reputedecman has a reputation beyond reputedecman has a reputation beyond reputedecman has a reputation beyond repute
Default

Fluid doesn't drain anywere when it is needed.

Put fluid in and "pump" the lever (Hand or foot) "a lot" before trying
anything else.
When you finally feel some resistance to the pumping 'then and only then'
do you resort to the normal bleeding process.
Reply With Quote
  #3  
Old 4th June 2018
Jowniofownio Jowniofownio is offline
Biker
 
Join Date: Feb 2018
Posts: 31
Sportster/Buell Model: Sportster Evo
Sportster/Buell Year: 1989
Reputation: 10
Jowniofownio is an unknown quantity at this point
Default

Right, used a vacuum bleeding tool to pull the fluid through. The front brake works a bit but if you hold the brake down, it goes hard then slowly pulls in towards the grip and I loose all braking whitch was a bit dodgy heading to the junction! Does this sound like air still in the system or passing seal? The seal looks good but may be old.

The rear brake, I'm having no luck getting a brake at all.

Any ideas?
Reply With Quote
  #4  
Old 4th June 2018
rokytnji's Avatar
rokytnji rokytnji is offline
XL FORUM LIFE MEMBER
 
Join Date: Apr 2016
Location: Texas/Mexican Border
Posts: 1,959
Sportster/Buell Model: xls 1000
Sportster/Buell Year: 1980
Sportster/Buell Model #2: xls 1000
Sportster/Buell Year #2: 1985
Other Motorcycle Model: 1200 Chopper XL
Other Motorcycle Year: 1990
Reputation: 3028126
rokytnji has a reputation beyond reputerokytnji has a reputation beyond reputerokytnji has a reputation beyond reputerokytnji has a reputation beyond reputerokytnji has a reputation beyond reputerokytnji has a reputation beyond reputerokytnji has a reputation beyond reputerokytnji has a reputation beyond reputerokytnji has a reputation beyond reputerokytnji has a reputation beyond reputerokytnji has a reputation beyond repute
Default

You put in a rebuild kit and did not change the seal. This rebuild sounds a bit dodgy to me.

I'd start over and do it right. This posted by a dude who who just did front and rear brakes on a 1980.
__________________
*Reference the Sportsterpedia! For Helpful info on your scooter.
I don't live in a What If world.
Traveled to
Reply With Quote
  #5  
Old 4th June 2018
Jowniofownio Jowniofownio is offline
Biker
 
Join Date: Feb 2018
Posts: 31
Sportster/Buell Model: Sportster Evo
Sportster/Buell Year: 1989
Reputation: 10
Jowniofownio is an unknown quantity at this point
Default

Quote:
Originally Posted by rokytnji View Post
You put in a rebuild kit and did not change the seal. This rebuild sounds a bit dodgy to me.

I'd start over and do it right. This posted by a dude who who just did front and rear brakes on a 1980.
I didn't fit a new kit. Just stripped it and noticed the o ring was broken and replaced this. The cup seal hasn't been changed as looks ok. I have rebuilt it about 5 times now and this is the closest I have got it to working now.
Reply With Quote
  #6  
Old 4th June 2018
rokytnji's Avatar
rokytnji rokytnji is offline
XL FORUM LIFE MEMBER
 
Join Date: Apr 2016
Location: Texas/Mexican Border
Posts: 1,959
Sportster/Buell Model: xls 1000
Sportster/Buell Year: 1980
Sportster/Buell Model #2: xls 1000
Sportster/Buell Year #2: 1985
Other Motorcycle Model: 1200 Chopper XL
Other Motorcycle Year: 1990
Reputation: 3028126
rokytnji has a reputation beyond reputerokytnji has a reputation beyond reputerokytnji has a reputation beyond reputerokytnji has a reputation beyond reputerokytnji has a reputation beyond reputerokytnji has a reputation beyond reputerokytnji has a reputation beyond reputerokytnji has a reputation beyond reputerokytnji has a reputation beyond reputerokytnji has a reputation beyond reputerokytnji has a reputation beyond repute
Default

Uh huh.

Quote:
I have rebuilt it about 5 times now and this is the closest I have got it to working now.
Cool that it almost working. No details though on honing. Parts used. Etc.....

So I expect loosey goosey. Hell. I even cheated on mine. But I was not afeared to go into detail on what I did, and what I did not do. But I got broad shoulders and dgaf on what others think of my repair methods.
Since it is a personal thing < parts available, budget > for me out here in the wild west.
Reply With Quote
  #7  
Old 4th June 2018
Jowniofownio Jowniofownio is offline
Biker
 
Join Date: Feb 2018
Posts: 31
Sportster/Buell Model: Sportster Evo
Sportster/Buell Year: 1989
Reputation: 10
Jowniofownio is an unknown quantity at this point
Default

Right, got a decent front brake now. Kept bleeding and finally got there. Now onto the rear....

I can't get anything there. Been bleeding for hours and nothing. Using the vacuum thing and it pulls fluid through but not building pressure. No obvious leaks and everything seems tight?
Reply With Quote
  #8  
Old 4 Weeks Ago
Jowniofownio Jowniofownio is offline
Biker
 
Join Date: Feb 2018
Posts: 31
Sportster/Buell Model: Sportster Evo
Sportster/Buell Year: 1989
Reputation: 10
Jowniofownio is an unknown quantity at this point
Default

right, I no longer have a front brake now!! If I give the brake leaver long hard pumps it stays solid and doesn't loose pressure. But if I give it soft slow pumps, and let out a bit then pump again, the leaver keeps coming in until it is at the grip and I don't have a brake! Could someone confirm that this is the master cylinder seals? Which could cause this as I have replaced the O rings just not the cup seal as that looks good. Or could it be a problem with the slide pins on the front brake caliper?
Reply With Quote
  #9  
Old 4 Weeks Ago
JacksBrother's Avatar
JacksBrother JacksBrother is offline
Drag Race Champion
 
Join Date: May 2010
Posts: 385
Sportster/Buell Model: XL1200
Sportster/Buell Year: 1998
Other Motorcycle Model: Harley Davidson FLH
Other Motorcycle Year: 1973
Reputation: 59478
JacksBrother is a splendid one to beholdJacksBrother is a splendid one to beholdJacksBrother is a splendid one to beholdJacksBrother is a splendid one to beholdJacksBrother is a splendid one to beholdJacksBrother is a splendid one to beholdJacksBrother is a splendid one to beholdJacksBrother is a splendid one to beholdJacksBrother is a splendid one to beholdJacksBrother is a splendid one to beholdJacksBrother is a splendid one to behold
Default

Quote:
Originally Posted by Jowniofownio View Post
right, I no longer have a front brake now!! If I give the brake leaver long hard pumps it stays solid and doesn't loose pressure. But if I give it soft slow pumps, and let out a bit then pump again, the leaver keeps coming in until it is at the grip and I don't have a brake! Could someone confirm that this is the master cylinder seals? Which could cause this as I have replaced the O rings just not the cup seal as that looks good. Or could it be a problem with the slide pins on the front brake caliper?
I Can't evaluate the pressure performance of a cup seal by eye, how can you? Cup seals can lose rigidity and/or elasticity which won't register by feel or by vision. The symptoms you are describing match a worn or degraded cup seal-- change it. If it doesn't fix your problem, it eliminates a suspect.
Just my $0.02 worth,
Joe
Reply With Quote
Sponsored Links
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Sponsored Links
All times are GMT +1. The time now is 00:49.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
XL Forum® - Linson Media LLC