The Sportster and Buell Motorcycle Forum - The XLFORUM®
 

Go Back   The Sportster and Buell Motorcycle Forum - The XLFORUM® > SPORTSTER MOTORCYCLE FORUM > Sportster Motorcycle Electrical > Sportster Motorcycle Electrical and Ignition
XLF Blogs XLF Arcade XLF Disclaimer/Privacy Statement/Terms Of Use

Active Threads
0 What did you do for your sporty Today?
Last Post: Glamazon
Posted On: 29 Minutes Ago
Replies: 6,131
Views: 778,801
0 EFI hose clamps
Last Post: Bikeaholic
Posted On: 37 Minutes Ago
Replies: 12
Views: 471
0 Removing oil pump
Last Post: harley506d
Posted On: 1 Hour Ago
Replies: 18
Views: 155
0 Grounded
Last Post: Nibelungen
Posted On: 2 Hours Ago
Replies: 84
Views: 3,121
0 Quick Question
Last Post: IXL2Relax
Posted On: 3 Hours Ago
Replies: 1
Views: 46
0 Front end swap
Last Post: kiwicafesporty
Posted On: 3 Hours Ago
Replies: 9
Views: 384
0 American Cycle Fab???
Last Post: THEWILDONE
Posted On: 3 Hours Ago
Replies: 23
Views: 9,366
0 Hardtail sporty ideas
Last Post: THEWILDONE
Posted On: 4 Hours Ago
Replies: 13
Views: 854
0 Trade: 91-03 Forward Controls for Mid Controls
Last Post: Toejam503
Posted On: 4 Hours Ago
Replies: 8
Views: 140
0 This week on Craig's list
Last Post: Kennyv
Posted On: 4 Hours Ago
Replies: 4,183
Views: 481,728
3 Wtb, Wts, Wtt, Wtg (Ironhead)
Last Post: SHAKY DAVE
Posted On: 5 Hours Ago
Replies: 135
Views: 232,000
0 Brake Line Part Number ?
Last Post: ferretface
Posted On: 5 Hours Ago
Replies: 16
Views: 426
0 Parrothead and the 2019 Iron Butt Rally
Last Post: sportsterpaul
Posted On: 5 Hours Ago
Replies: 109
Views: 5,825
0 Massachusetts rides 2019
Last Post: sportsterpaul
Posted On: 5 Hours Ago
Replies: 12
Views: 389
0 Hot
Last Post: Iron Mike
Posted On: 6 Hours Ago
Replies: 5
Views: 122
5 Keeping Secrets?
Last Post: flashedwards
Posted On: 6 Hours Ago
Replies: 93
Views: 13,285
12 POLL: How many times have you dropped a motorcycle?
Last Post: Graywolf
Posted On: 6 Hours Ago
Replies: 638
Views: 113,017
4 The no-debate OIL POLL
Last Post: boomerguy
Posted On: 6 Hours Ago
Replies: 233
Views: 64,997
0 Robbie's uncomfortable seat theory
Last Post: dieselvette
Posted On: 6 Hours Ago
Replies: 31
Views: 1,305
0 Roads I'd like to ride.
Last Post: rokytnji
Posted On: 7 Hours Ago
Replies: 2,025
Views: 170,557
0 Crusty's Travels
Last Post: sportsterpaul
Posted On: 8 Hours Ago
Replies: 2,289
Views: 287,961
0 You asked for it! "The Tess' Coffee Thread"
Last Post: rokytnji
Posted On: 8 Hours Ago
Replies: 10,796
Views: 871,275
0 Tuesday 23rd July 2019: Lympstone
Last Post: Folkie
Posted On: 9 Hours Ago
Replies: 11
Views: 651
0 2010 xl 1200 low solo seat fit
Last Post: Folkie
Posted On: 9 Hours Ago
Replies: 3
Views: 102
0 turn key on, no power at battery. key off battery good. help
Last Post: ken883/1200
Posted On: 9 Hours Ago
Replies: 15
Views: 683
0 Torquing Rubber
Last Post: bimbo
Posted On: 10 Hours Ago
Replies: 2
Views: 117
0 Hottie of the day, no nudity.
Last Post: trainman
Posted On: 10 Hours Ago
Replies: 12,258
Views: 1,118,360
0 How many (Sportsters Do You Own?)
Last Post: screndname
Posted On: 10 Hours Ago
Replies: 26
Views: 590
0 How many miles do you have on your rubbermount?
Last Post: Tincan
Posted On: 10 Hours Ago
Replies: 425
Views: 82,451
0 Single women, how old are you?
Last Post: Glamazon
Posted On: 10 Hours Ago
Replies: 74
Views: 10,343
More...
Members Birthdays
Sponsored Links
Reply
 
Share Thread Tools Display Modes
  #1  
Old 29th May 2019
Dave Knight Dave Knight is offline
Biker
 
Join Date: May 2019
Posts: 3
Sportster/Buell Model: XL883
Sportster/Buell Year: 2012
Reputation: 10
Dave Knight is an unknown quantity at this point
Default 2012 883L ECM Failure?

Hi all,

I have a problem with my 2012 883.

It has no Earth from the ECM to the Power supply relay , so the relay doesn’t get energised.

If I introduce an earth to it, the GN/O wire, the relay will energise and the bike will run.

Everything else is there.

I have had the ECM out, checked continuity from ECM harness plug to the system relay etc, all wiring checked out. Same with the earths at pins 10/28 at the ECM, so I’m thinking the ECM has an issue.

Any thoughts, or something I’m missing?

Thanks in advance!
Dave
Reply With Quote
  #2  
Old 29th May 2019
sportsterpaul's Avatar
sportsterpaul sportsterpaul is offline
XL FORUM TEAM MEMBER
 
Join Date: Jan 2009
Location: In a swamp/Michigan
Posts: 13,579
Sportster/Buell Model: XL1460C
Sportster/Buell Year: 2000
Sportster/Buell Model #2: XL1200R
Sportster/Buell Year #2: 2006
Other Motorcycle Model: XL1200R
Other Motorcycle Year: 2004
Reputation: 9621106
sportsterpaul has a reputation beyond reputesportsterpaul has a reputation beyond reputesportsterpaul has a reputation beyond reputesportsterpaul has a reputation beyond reputesportsterpaul has a reputation beyond reputesportsterpaul has a reputation beyond reputesportsterpaul has a reputation beyond reputesportsterpaul has a reputation beyond reputesportsterpaul has a reputation beyond reputesportsterpaul has a reputation beyond reputesportsterpaul has a reputation beyond repute
Default

Did you check diagnostics?
__________________
I.B.A.#26543, Growing old-Mandatory/ Growing up-optional. Men do not quit playing because they get old, they get old because they stop playing!

The XL Forum Sportsterpedia:
http://sportsterpedia.com/doku.php/start
Reply With Quote
  #3  
Old 29th May 2019
Dave Knight Dave Knight is offline
Biker
 
Join Date: May 2019
Posts: 3
Sportster/Buell Model: XL883
Sportster/Buell Year: 2012
Reputation: 10
Dave Knight is an unknown quantity at this point
Default

Yes, comes up with Power supply coil (Meaning the relay coil) High, and, same fault but with Low.

I have swapped relays with the crank/start relay, it makes no difference.

Like I say, if I give it an earth, it fires up straight away.

The pump doesn't prime when ign/run selected. But it won't without the relay working.
Reply With Quote
  #4  
Old 30th May 2019
IXL2Relax's Avatar
IXL2Relax IXL2Relax is offline
XL FORUM TEAM MEMBER
 
Join Date: Feb 2013
Location: Let Freedom Ring in PA
Posts: 6,533
Sportster/Buell Model: Sportster 883►1200
Sportster/Buell Year: 1994
IXL2Relax has disabled reputation
Default

When you're having issues with the electrical system, use this Sportsterpedia section about
checking the battery cables, voltages and grounds - DO THIS BEFORE ANYTHING ELSE:
http://sportsterpedia.com/doku.php/t...place_to_start

I would start there - And be absolutely sure to remove & clean the connections at the Powertrain Ground...

ECMs do fail - but they are very hardy and it's rare... Make sure all else is right before heading down that road...

Did you check the ECM 15A Fuse?
Did you check ECM Pin #31 for 12v from that fuse?

Did you check for solid grounds from Pin#10 & #28 to Battery Ground?
... (check for voltage from ECM Pin#10 (and #28) to Battery Ground)

Try using the Reference Voltage testing of the grounds all over the bike (see the link above)...

Check your connectors and the wires into them - Make sure each wire is fully seated in the connector so it doesn't back out when the connectors are mated... Check the wire connection at ECM #2 and at System Relay #86...


Do you have an alarm system on the bike?


IXL _______ >>>> My Motorcyle Chronicles Are Here <<<<
For FREE Sportster Tech Info from the XLForum:
Explore The Sportsterpedia - The Best Kept Secret on the XLForum!
__________________
### The ride is more enjoyable to nowhere in particular! ###
Reply With Quote
  #5  
Old 2nd June 2019
Dave Knight Dave Knight is offline
Biker
 
Join Date: May 2019
Posts: 3
Sportster/Buell Model: XL883
Sportster/Buell Year: 2012
Reputation: 10
Dave Knight is an unknown quantity at this point
Default

Well after pulling the ECM and tracing the wiring AGAIN, I have concluded that the ECM has partially failed, probably as a result of a corroded Earth point, (one behind primary).

The ECM is no longer sending an earth to the power supply relay.

So, I will be making a solution to this fault, without replacing the ECM.

Thanks for all your help.
Reply With Quote
  #6  
Old 4th June 2019
bustert's Avatar
bustert bustert is offline
XL FORUM TEAM MEMBER
 
Join Date: Jul 2008
Posts: 9,335
Sportster/Buell Model: 1200s
Sportster/Buell Year: 2001
Sportster/Buell Model #2: xlch
Sportster/Buell Year #2: 1974
Reputation: 2393179
bustert has a reputation beyond reputebustert has a reputation beyond reputebustert has a reputation beyond reputebustert has a reputation beyond reputebustert has a reputation beyond reputebustert has a reputation beyond reputebustert has a reputation beyond reputebustert has a reputation beyond reputebustert has a reputation beyond reputebustert has a reputation beyond reputebustert has a reputation beyond repute
Default

mr. lax makes a very fine point
you can have only a couple of strands wire and get a good reading but when under load, a diff story. add a jumper ground parallel to see if it improves.
would have to look at the print to see if the ecm provides the ground or the source.
Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Sponsored Links
All times are GMT +1. The time now is 10:03.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
XL Forum® - Linson Media LLC