The Sportster and Buell Motorcycle Forum - The XLFORUM®
 

Go Back   The Sportster and Buell Motorcycle Forum - The XLFORUM® > SPORTSTER MOTORCYCLE FORUM > Sportster Motorcycle Era Specific and Model Specific > Frame Mount EVO Sportster Talk (1986-2003 models)
XLF Blogs XLF Arcade XLF Disclaimer/Privacy Statement/Terms Of Use

Active Threads
0 Hottie of the day, no nudity.
Last Post: Stairman
Posted On: 4 Minutes Ago
Replies: 15,147
Views: 1,440,657
0 never mind
Last Post: IXL2Relax
Posted On: 16 Minutes Ago
Replies: 21
Views: 1,021
0 Head Porting 101
Last Post: 60Gunner
Posted On: 18 Minutes Ago
Replies: 2
Views: 53
0 Official XL Forum Random Image Thread (NO NUDITY!)
Last Post: Stairman
Posted On: 18 Minutes Ago
Replies: 45,574
Views: 7,194,371
0 98 Stator Removal / Inspection / Installation
Last Post: sportsterdoc
Posted On: 22 Minutes Ago
Replies: 68
Views: 2,003
0 Keep & Kill
Last Post: Crusty
Posted On: 23 Minutes Ago
Replies: 14,383
Views: 807,136
0 SBS Project - Sportster Chop w/ Lots of Photo's
Last Post: DK Custom
Posted On: 33 Minutes Ago
Replies: 290
Views: 82,008
0 Transformer XR1200
Last Post: Davo_137
Posted On: 35 Minutes Ago
Replies: 139
Views: 10,985
0 is a buell a harley
Last Post: rejeanprimeau
Posted On: 37 Minutes Ago
Replies: 169
Views: 20,660
0 Roads I'd like to ride.
Last Post: Coz
Posted On: 51 Minutes Ago
Replies: 2,594
Views: 222,189
5 HAMMER vs NRHS vs S&S Conversion Kits
Last Post: NLXL
Posted On: 1 Hour Ago
Replies: 86
Views: 6,823
0 Do you have the service manual?
Last Post: boomerguy
Posted On: 1 Hour Ago
Replies: 759
Views: 198,839
0 Crusty's Travels
Last Post: Davo_137
Posted On: 1 Hour Ago
Replies: 2,613
Views: 345,958
0 tubing strength if pressed?
Last Post: wedge
Posted On: 1 Hour Ago
Replies: 6
Views: 103
3 Shaky Dave Recovery
Last Post: wedge
Posted On: 2 Hours Ago
Replies: 61
Views: 8,775
0 69 oil pump breather timing mark
Last Post: ryder rick
Posted On: 2 Hours Ago
Replies: 7
Views: 194
0 Poll: If you had to have a stock sporty, what would it be?
Last Post: RDHenley
Posted On: 3 Hours Ago
Replies: 585
Views: 175,709
0 DK Custom-Parts Info, Testing, & Results w/ Pics & Fun-to-Read Ride Reports
Last Post: DK Custom
Posted On: 3 Hours Ago
Replies: 23
Views: 3,711
0 Blackstone HyperTek
Last Post: Stairman
Posted On: 4 Hours Ago
Replies: 7
Views: 171
0 Request for recommendations: Sissy Bar for chopped fender
Last Post: HUEMAN
Posted On: 4 Hours Ago
Replies: 0
Views: 36
0 Is it a carb issue
Last Post: doodah man
Posted On: 4 Hours Ago
Replies: 9
Views: 164
0 Was your 1st bike a Sportster?
Last Post: HUEMAN
Posted On: 5 Hours Ago
Replies: 1,026
Views: 237,170
0 On starting a new thread
Last Post: rokytnji
Posted On: 5 Hours Ago
Replies: 29
Views: 747
0 The country store
Last Post: rokytnji
Posted On: 5 Hours Ago
Replies: 372
Views: 25,665
0 You asked for it! "The Tess' Coffee Thread"
Last Post: rokytnji
Posted On: 6 Hours Ago
Replies: 10,934
Views: 917,712
10 how low do you let it idle
Last Post: night-train
Posted On: 6 Hours Ago
Replies: 44
Views: 7,146
0 Iree's late night cafe
Last Post: rokytnji
Posted On: 6 Hours Ago
Replies: 1,344
Views: 171,902
0 Electric Harley sub-forum(s)...?
Last Post: 60Gunner
Posted On: 6 Hours Ago
Replies: 11
Views: 262
0 Charging cell phone when camping?
Last Post: SLW210
Posted On: 7 Hours Ago
Replies: 66
Views: 19,491
0 Hot Rods, Rat Rods, and Customs.
Last Post: Stairman
Posted On: 7 Hours Ago
Replies: 3,798
Views: 478,370
More...
Members Birthdays
Sponsored Links
Reply
 
Share Thread Tools Display Modes
  #1  
Old 27th September 2019
edijse edijse is offline
Biker
 
Join Date: Sep 2019
Posts: 1
Sportster/Buell Model: XLH 1200C
Sportster/Buell Year: 1999
Reputation: 10
edijse is an unknown quantity at this point
Question Long crank time

Hello fellas!

About a week ago two oddities occured with my sporty. First, when I turn the key on, there is almost a minute long lag before the odometer and speedometer come on. The idiot lights are on always and everything else works fine.
About a week ago, I started to have an issue where the engine cranks for up to 20 seconds before the bike fires. Usually it fires on the first or second crank. The speed of cranking is not slowing down and it turns strong.

It's a 1999 1200 custom.

What do I need to look for? It still works but is getting me worried.

thanks in advance.
Edge
Reply With Quote
  #2  
Old 27th September 2019
IXL2Relax's Avatar
IXL2Relax IXL2Relax is offline
XL FORUM TEAM MEMBER
 
Join Date: Feb 2013
Location: Let Freedom Ring in PA
Posts: 6,918
Sportster/Buell Model: Sportster 883►1200
Sportster/Buell Year: 1994
IXL2Relax has disabled reputation
Default

When you're having issues with the electrical system, use this Sportsterpedia section about
checking the battery cables, voltages and grounds - DO THIS BEFORE ANYTHING ELSE:
http://sportsterpedia.com/doku.php/t...place_to_start

DO THE FOUR VOLTAGE TESTS - Report back with the voltage readings - they are important...

Your ground wires are located on the top rear motor mounts - Be sure they are clean & tight - Make sure the wires are not broken or frayed...


IXL _______ >>>> My Motorcycle Chronicles Are Here <<<<
For FREE Sportster Tech Info from the XLForum:
Explore The Sportsterpedia - The Best Kept Secret on the XLForum!
__________________
### The ride is more enjoyable to nowhere in particular! ###
Reply With Quote
  #3  
Old 29th September 2019
bustert's Avatar
bustert bustert is offline
XL FORUM TEAM MEMBER
 
Join Date: Jul 2008
Posts: 9,649
Sportster/Buell Model: 1200s
Sportster/Buell Year: 2001
Sportster/Buell Model #2: xlch
Sportster/Buell Year #2: 1974
Reputation: 3007546
bustert has a reputation beyond reputebustert has a reputation beyond reputebustert has a reputation beyond reputebustert has a reputation beyond reputebustert has a reputation beyond reputebustert has a reputation beyond reputebustert has a reputation beyond reputebustert has a reputation beyond reputebustert has a reputation beyond reputebustert has a reputation beyond reputebustert has a reputation beyond repute
Default

inline spark tester to confirm ignition during crank
if not there, check pickup, fusing/wiring and ign. module.
you might want to run compression test as low compression will cause start issues. before jumping the electronic dragon, nail all of the mechanical first.
Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Sponsored Links
All times are GMT +1. The time now is 22:35.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
XL Forum® - Linson Media LLC