The Sportster and Buell Motorcycle Forum - The XLFORUM®
 

Go Back   The Sportster and Buell Motorcycle Forum - The XLFORUM® > SPORTSTER MOTORCYCLE FORUM > Sportster Motorcycle Era Specific and Model Specific > EFI Sportster Motorcycle Talk (2007 and up)
XLF Blogs XLF Arcade XLF Disclaimer/Privacy Statement/Terms Of Use

EFI Sportster Motorcycle Talk (2007 and up) For 2007 and above Sportsters

Active Threads
0 Compression Tester Differences
Last Post: 60Gunner
Posted On: 4 Minutes Ago
Replies: 4
Views: 98
0 2003 XLH Battery install help
Last Post: John Harper
Posted On: 6 Minutes Ago
Replies: 10
Views: 279
0 My 1250 to 1275 build
Last Post: rejeanprimeau
Posted On: 1 Hour Ago
Replies: 144
Views: 8,999
0 Happy Birthday Joebobber
Last Post: mick42
Posted On: 1 Hour Ago
Replies: 1
Views: 19
0 Spokes or Mags
Last Post: 51 New West
Posted On: 1 Hour Ago
Replies: 341
Views: 73,461
0 Hottie of the day, no nudity.
Last Post: Stairman
Posted On: 2 Hours Ago
Replies: 13,836
Views: 1,277,739
0 ultima iggy plate near the end of travel
Last Post: Nitro57xl
Posted On: 2 Hours Ago
Replies: 21
Views: 690
0 hello and help!
Last Post: IronMick
Posted On: 2 Hours Ago
Replies: 2
Views: 116
3 Wtb, Wts, Wtt, Wtg (Ironhead)
Last Post: IronMick
Posted On: 2 Hours Ago
Replies: 63
Views: 236,264
0 Official XL Forum Random Image Thread (NO NUDITY!)
Last Post: Stairman
Posted On: 2 Hours Ago
Replies: 44,984
Views: 7,085,032
0 :( New deep rebuild on my 90 inch
Last Post: conv90
Posted On: 2 Hours Ago
Replies: 147
Views: 14,949
0 Hello!!!
Last Post: shanneba
Posted On: 3 Hours Ago
Replies: 12
Views: 187
0 Here goes...
Last Post: NLXL
Posted On: 3 Hours Ago
Replies: 8
Views: 125
0 Fubar (Rear Cylinder Not Firing)
Last Post: 93trident
Posted On: 4 Hours Ago
Replies: 13
Views: 465
0 74 XLH disk brake lower anchor pin
Last Post: needspeed
Posted On: 8 Hours Ago
Replies: 11
Views: 235
0 Suggestions on no start
Last Post: Whitewalls
Posted On: 8 Hours Ago
Replies: 67
Views: 1,776
0 What did you do for your sporty Today?
Last Post: thood
Posted On: 10 Hours Ago
Replies: 6,347
Views: 815,860
0 Speedometer issue
Last Post: IXL2Relax
Posted On: 10 Hours Ago
Replies: 3
Views: 216
0 Average age of the Ironhead forum users
Last Post: Kingrabbit
Posted On: 10 Hours Ago
Replies: 448
Views: 87,176
0 CV carb rubber bung
Last Post: IXL2Relax
Posted On: 10 Hours Ago
Replies: 16
Views: 450
0 Fitment between 2005 & 2006
Last Post: IXL2Relax
Posted On: 10 Hours Ago
Replies: 6
Views: 127
0 HAMMERING the Columbia!
Last Post: 60Gunner
Posted On: 10 Hours Ago
Replies: 53
Views: 10,450
0 1996 Sportster 1200 ignition/ idle/ warm up/ lost cylinder???
Last Post: IXL2Relax
Posted On: 10 Hours Ago
Replies: 3
Views: 147
0 This week on Craig's list
Last Post: A Seabee
Posted On: 11 Hours Ago
Replies: 4,296
Views: 511,870
0 Ulysses Oil Fittings?
Last Post: Davo_137
Posted On: 11 Hours Ago
Replies: 1
Views: 50
0 What is it and Where (Wiring Other Tail Light And Turn Signals)
Last Post: broknluck
Posted On: 11 Hours Ago
Replies: 20
Views: 989
0 5 gal tank
Last Post: Tonyb65
Posted On: 11 Hours Ago
Replies: 46
Views: 14,891
0 Mounting fatbob tanks on a '74
Last Post: Tonyb65
Posted On: 11 Hours Ago
Replies: 30
Views: 8,599
0 Larger gas tank for 1996?
Last Post: Tonyb65
Posted On: 11 Hours Ago
Replies: 24
Views: 1,732
0 is a buell a harley
Last Post: Scott
Posted On: 11 Hours Ago
Replies: 154
Views: 16,914
More...
Members Birthdays
Sponsored Links
Reply
 
Share Thread Tools Display Modes
  #11  
Old 29th January 2008
MacAttack's Avatar
MacAttack MacAttack is offline
Senior Chief Know It All
 
Join Date: Feb 2007
Location: Stumptown
Posts: 807
Sportster/Buell Model: 1200R
Sportster/Buell Year: 2007
Sportster/Buell Model #2: Wouldn't that be nice!
Sportster/Buell Year #2: 1957
Other Motorcycle Model: Kawasaki Concours 14
Other Motorcycle Year: 2014
Reputation: 4166
MacAttack is just really niceMacAttack is just really niceMacAttack is just really niceMacAttack is just really niceMacAttack is just really niceMacAttack is just really niceMacAttack is just really niceMacAttack is just really niceMacAttack is just really niceMacAttack is just really niceMacAttack is just really nice
Default

07 1200R - yes, stumbles a bit when cold, occasionally dies. Most of the time it just skips a beat about 30 seconds after startup.
Reply With Quote
  #12  
Old 29th January 2008
2007Low's Avatar
2007Low 2007Low is offline
Senior Chief Harley Engineer 2nd Class
 
Join Date: Oct 2007
Location: Southwestern Minnesota
Posts: 1,692
Sportster/Buell Model: XL1200 Low/TTS/Gronked
Sportster/Buell Year: 2007
Sportster/Buell Model #2: XLCH1000
Sportster/Buell Year #2: 1975
Reputation: 23358
2007Low is a name known to all2007Low is a name known to all2007Low is a name known to all2007Low is a name known to all2007Low is a name known to all2007Low is a name known to all2007Low is a name known to all2007Low is a name known to all2007Low is a name known to all2007Low is a name known to all2007Low is a name known to all
Default

Quote:
Originally Posted by MacAttack View Post
07 1200R - yes, stumbles a bit when cold, occasionally dies. Most of the time it just skips a beat about 30 seconds after startup.
Thanks for responding, it'll be great to show this thread to the dealer and hopefully get it off to corp HD too.
Reply With Quote
  #13  
Old 31st January 2008
uofkis1st uofkis1st is offline
Biker
 
Join Date: Jun 2007
Posts: 11
Sportster/Buell Model: 1200C
Sportster/Buell Year: 07
Reputation: 53
uofkis1st is an unknown quantity at this point
Default Warm or Cold

Ours (2007 1200C) stumbles about 30 seconds after start-up, no matter what the temp. is outside, or whether or not the bike is garaged, or sitting in a 110 degree parking lot. It has only died twice during these stumbles, most of the time it almost dies, then catches. After that it doesn't usually do it. I've been meaning to make an appointment for it, but just haven't gotten around to it yet.
Reply With Quote
  #14  
Old 31st January 2008
SPURS-DarkRider's Avatar
SPURS-DarkRider SPURS-DarkRider is offline
Biker
 
Join Date: Jan 2008
Location: Houston,tx
Posts: 46
Sportster/Buell Model: 1200XLC
Sportster/Buell Year: 2007
Reputation: 10
SPURS-DarkRider is an unknown quantity at this point
Default

07 1200XLC here, still breaking it in, just barely 500 miles on it. Im glad i saw this topic, because today as i was leaving work about 30 seconds into my ride home, i felt and heard the engine go silent then start up again, just for a single beat and it freaked me out, first time it ever happened to me. After reading these posts, i realized i didnt let the bike idle for a minute or so before taking off, i just goosed it, im gonna pay attention next time to see if it does it after warming up a little.
Reply With Quote
  #15  
Old 31st January 2008
whittlebeast's Avatar
whittlebeast whittlebeast is offline
Senior Master Custom Bike Builder
 
Join Date: Dec 2006
Posts: 5,002
Sportster/Buell Model: 1200 Low
Sportster/Buell Year: 2007
Other Motorcycle Model: Yamaha FZ1
Other Motorcycle Year: 2008
whittlebeast has disabled reputation
Default

This is easy. Check the part number on the bottom of the fuel pump plate. Lay on the floor looking up on the shifter side of the bike with a flashlight. There is a white tag on a metal plate under the tank. If the number ends in an A or a B you need a service bulletin done. It has to do with a leaking pressure regulator. Just describe the issue to the dealer and mention that there is a service bulletin. Your EFI will need about 200 miles to dial back in after this fix.

Hope this helps

AW
__________________
My new website is HowEFIworks dot com
Reply With Quote
  #16  
Old 31st January 2008
timmii timmii is offline
Biker
 
Join Date: Nov 2007
Posts: 42
Sportster/Buell Model: 1200r
Sportster/Buell Year: 2007
Reputation: 96
timmii is an unknown quantity at this point
Default

I've had my bike die on me while idling in neutral... after a thirty minute ride! It's just plain embarrassing shifting to neutral while glidding to a stop at a light, than having to restart it at the light.

But putting a couple thousand miles on it and a high flow A/C and rerouting the breather away from the intake (I don't know why they designed it to spit oil into the intake, that just makes stumbling 10x worse) solved that problem for me.
Reply With Quote
  #17  
Old 31st January 2008
danonator's Avatar
danonator danonator is offline
Flat Track Racer
 
Join Date: Mar 2007
Posts: 246
Sportster/Buell Model: XL1200R
Sportster/Buell Year: 2007
Reputation: 455
danonator is on a distinguished roaddanonator is on a distinguished roaddanonator is on a distinguished roaddanonator is on a distinguished roaddanonator is on a distinguished road
Default

Mine stumbles also about 30 or so seconds after startup.

Heck, I almost dropped the bike once when it happened going into a turn.

If there is a service fix for this I want it!

Danonator
Reply With Quote
  #18  
Old 31st January 2008
jimmyp's Avatar
jimmyp jimmyp is offline
Greasemonkey
 
Join Date: Oct 2007
Posts: 115
Sportster/Buell Model: xl1200N
Sportster/Buell Year: 08
Reputation: 44
jimmyp is an unknown quantity at this point
Default

my bike has almost 200mi on it and has been stumbling in the 1st minute or so until warm..
Reply With Quote
Sponsored Links
  #19  
Old 31st January 2008
XL50 XL50 is offline
Biker
 
Join Date: Oct 2006
Posts: 25
Sportster/Buell Model: XL50 #872
Sportster/Buell Year: 2007
XL50 has disabled reputation
Default

My XL 50 (#872) seems to do it when the temp is below 60
Reply With Quote
  #20  
Old 31st January 2008
linkin5's Avatar
linkin5 linkin5 is offline
Senior Chief Know It All 2nd Class
 
Join Date: Sep 2007
Location: Cabin
Posts: 1,442
Sportster/Buell Model: 1200R
Sportster/Buell Year: 2007
Other Motorcycle Model: Honda XL 125
Other Motorcycle Year: 1982
Reputation: 6485
linkin5 is just really nicelinkin5 is just really nicelinkin5 is just really nicelinkin5 is just really nicelinkin5 is just really nicelinkin5 is just really nicelinkin5 is just really nicelinkin5 is just really nicelinkin5 is just really nicelinkin5 is just really nicelinkin5 is just really nice
Default

I don't know if all bikes that stumble when cold are gonna have the fuel pump issue. I haven't checked my tag yet to see if I have the bad one yet, I don't think I do as I get good gas mileage and poor mileage was another symptom of the bad fuel pumps. But I do have the cold stumble and it has died on take off once due to this, and I will now check the lable on my fuel pump to see if I have an affected one.
Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Sponsored Links
All times are GMT +1. The time now is 14:13.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
XL Forum® - Linson Media LLC