The Sportster and Buell Motorcycle Forum - The XLFORUM®
 

Go Back   The Sportster and Buell Motorcycle Forum - The XLFORUM® > SPORTSTER MOTORCYCLE FORUM > Sportster Motorcycle Intake and Exhaust > Sportster Motorcycle Air intake, Carburetor, EFI, Fuel, and Exhaust
XLF Blogs XLF Arcade XLF Disclaimer/Privacy Statement/Terms Of Use

Sportster Motorcycle Air intake, Carburetor, EFI, Fuel, and Exhaust Problems, advice and/or how tos for Sporster and Buell motorcycle carburators, Electronic Fuel Injection (EFI), Air Intake, Fuel and Exhaust.

Active Threads
0 Crusty's Travels
Last Post: Crusty
Posted On: 7 Minutes Ago
Replies: 2,278
Views: 286,257
0 Official XL Forum Random Image Thread (NO NUDITY!)
Last Post: Graywolf
Posted On: 10 Minutes Ago
Replies: 44,348
Views: 6,961,290
0 Occasional carb spit back, am I missing something?
Last Post: ezmerf
Posted On: 22 Minutes Ago
Replies: 26
Views: 905
0 You asked for it! "The Tess' Coffee Thread"
Last Post: Flame__
Posted On: 35 Minutes Ago
Replies: 10,783
Views: 868,465
0 If You Have An '04+ (Buell's too), Please Read (Oil Usage)
Last Post: JaKaL
Posted On: 35 Minutes Ago
Replies: 152
Views: 22,803
0 Grounded
Last Post: Nibelungen
Posted On: 38 Minutes Ago
Replies: 60
Views: 2,521
0 Alternator/generator Conversion
Last Post: doodah man
Posted On: 43 Minutes Ago
Replies: 132
Views: 68,320
0 Thursday 18th July 2019: Lympstone
Last Post: Folkie
Posted On: 1 Hour Ago
Replies: 6
Views: 546
0 What did you do for your sporty Today?
Last Post: ParrotHead
Posted On: 1 Hour Ago
Replies: 6,118
Views: 777,166
0 Oil Filter Thread Size/Pitch?
Last Post: Rollbar
Posted On: 1 Hour Ago
Replies: 11
Views: 183
0 rattles like a can of bolts
Last Post: bustert
Posted On: 2 Hours Ago
Replies: 1
Views: 47
0 `83 XLX rebuid and questions thread
Last Post: spamer80
Posted On: 2 Hours Ago
Replies: 150
Views: 11,560
0 2020 Sportster?
Last Post: Desertfox
Posted On: 2 Hours Ago
Replies: 29
Views: 1,221
0 Power Loss At Sustained High RPMs
Last Post: Bigshankhank
Posted On: 3 Hours Ago
Replies: 23
Views: 483
0 Hot Rods, Rat Rods, and Customs.
Last Post: Stairman
Posted On: 3 Hours Ago
Replies: 3,517
Views: 415,067
0 Hottie of the day, no nudity.
Last Post: Stairman
Posted On: 3 Hours Ago
Replies: 12,191
Views: 1,112,934
0 how many run baffles, run open, or just run stock
Last Post: a-sad-anorak
Posted On: 3 Hours Ago
Replies: 411
Views: 93,601
7 I met a living legend.
Last Post: Stairman
Posted On: 4 Hours Ago
Replies: 29
Views: 1,565
0 PLEASE READ THIS Before You Post In 'The BUY - SELL - TRADE Zone'!
Last Post: Folkie
Posted On: 4 Hours Ago
Replies: 1
Views: 639
0 looking to swap mids for forwards
Last Post: Folkie
Posted On: 4 Hours Ago
Replies: 2
Views: 141
7 Oldest Motorcycle You've Owned
Last Post: Glamazon
Posted On: 5 Hours Ago
Replies: 56
Views: 2,931
0 What jets do you use?
Last Post: 60Gunner
Posted On: 5 Hours Ago
Replies: 244
Views: 77,543
0 Peanut, 3.3 or 4.5 gas tank ?
Last Post: 83XLX
Posted On: 6 Hours Ago
Replies: 222
Views: 63,522
0 This is gonna hurt.
Last Post: Graywolf
Posted On: 6 Hours Ago
Replies: 7,686
Views: 1,514,192
0 WTF is it with these F'n rocker cover leaks!
Last Post: 60Gunner
Posted On: 9 Hours Ago
Replies: 94
Views: 1,340
0 Can you Drown a Sportster ???
Last Post: IXL2Relax
Posted On: 9 Hours Ago
Replies: 22
Views: 613
0 Clutchlite ramps with pictures
Last Post: rocketmangb
Posted On: 9 Hours Ago
Replies: 27
Views: 4,836
0 For Sale: SE Race Ignition Tuner 32124-04B/Stock ICM
Last Post: 60Gunner
Posted On: 10 Hours Ago
Replies: 9
Views: 317
0 Cold Start. Then stall
Last Post: IXL2Relax
Posted On: 10 Hours Ago
Replies: 1
Views: 110
0 KT - 2019 - Done Riding - Not Hardly
Last Post: sportsterpaul
Posted On: 10 Hours Ago
Replies: 83
Views: 8,078
More...
Members Birthdays
merc, schvamf (47), MikeLightnin, o2man98 (39), Toadz (31), WingNut15B (31)
Sponsored Links
Reply
 
Share Thread Tools Display Modes
  #1  
Old 5 Days Ago
smm1200 smm1200 is offline
Biker
 
Join Date: Jul 2019
Posts: 3
Sportster/Buell Model: 1200xl
Sportster/Buell Year: 2008
Reputation: 10
smm1200 is an unknown quantity at this point
Default EFI hose clamps

I am having problems with a NOS sportster, 08 with 2700 miles that had its pump replaced last year. Gauge on the way to check pressure. The pump has let me know with loud squeal/whine that it is not happy. Trying to get parts in order in advance. Any one know what size the small hose clamps on the corrugated hose on the pump. I have 12.8, but cannot tell whether they might be 12.3 or 13.3....hmmm. The HD part does not help since no one describes size. thanks in advance.
Reply With Quote
  #2  
Old 5 Days Ago
seajay's Avatar
seajay seajay is offline
XL FORUM TEAM MEMBER
 
Join Date: Nov 2004
Location: jupiter fl
Posts: 2,573
Sportster/Buell Model: 1200C
Sportster/Buell Year: 04
Reputation: 649679
seajay has a reputation beyond reputeseajay has a reputation beyond reputeseajay has a reputation beyond reputeseajay has a reputation beyond reputeseajay has a reputation beyond reputeseajay has a reputation beyond reputeseajay has a reputation beyond reputeseajay has a reputation beyond reputeseajay has a reputation beyond reputeseajay has a reputation beyond reputeseajay has a reputation beyond repute
Default

Are you sure its the oil pump making the noise? What is the history of the bike? Oil pump replaced with only 2700 miles? Was oil circulating? Are the oil lines kinked or not going where they should? Might have other engine issues if oil wasn't circulating.
__________________
04/07 1275 BFH heads .590 cams S&S 1.725 rockers S&S premium lifters BDL+15% clutch TC88A HSR-45 S&S 3" ac LSR 2-1
Reply With Quote
  #3  
Old 5 Days Ago
smm1200 smm1200 is offline
Biker
 
Join Date: Jul 2019
Posts: 3
Sportster/Buell Model: 1200xl
Sportster/Buell Year: 2008
Reputation: 10
smm1200 is an unknown quantity at this point
Default

seajay....thanks for reply....but this is EFI, fuel, pump hoses. Was not talking oil pump. Sorry for any confusion.
Reply With Quote
  #4  
Old 5 Days Ago
seajay's Avatar
seajay seajay is offline
XL FORUM TEAM MEMBER
 
Join Date: Nov 2004
Location: jupiter fl
Posts: 2,573
Sportster/Buell Model: 1200C
Sportster/Buell Year: 04
Reputation: 649679
seajay has a reputation beyond reputeseajay has a reputation beyond reputeseajay has a reputation beyond reputeseajay has a reputation beyond reputeseajay has a reputation beyond reputeseajay has a reputation beyond reputeseajay has a reputation beyond reputeseajay has a reputation beyond reputeseajay has a reputation beyond reputeseajay has a reputation beyond reputeseajay has a reputation beyond repute
Default

Yeah, I got you. I'm a carb guy.
Reply With Quote
  #5  
Old 5 Days Ago
b0fh's Avatar
b0fh b0fh is offline
Harley Engineer
 
Join Date: Oct 2008
Location: Brazil
Posts: 326
Sportster/Buell Model: XL883R
Sportster/Buell Year: 2008
Sportster/Buell Model #2: XL1200CX Roadster
Sportster/Buell Year #2: 2017
Reputation: 100453
b0fh has much to be proud ofb0fh has much to be proud ofb0fh has much to be proud ofb0fh has much to be proud ofb0fh has much to be proud ofb0fh has much to be proud ofb0fh has much to be proud ofb0fh has much to be proud ofb0fh has much to be proud ofb0fh has much to be proud ofb0fh has much to be proud of
Default

mine does a horrible noise on turn-on whenever i let it sit for too long like a week or more. sounds like a cat dying... also a 2008 and does this since new, pump still pumping strong
Reply With Quote
  #6  
Old 5 Days Ago
Toejam503's Avatar
Toejam503 Toejam503 is offline
Air-Cooled Forever
 
Join Date: May 2010
Location: Dakota Territory
Posts: 2,302
Sportster/Buell Model: XL 1200 C
Sportster/Buell Year: 2006
Sportster/Buell Model #2: (Prev.Own)XLH Milw.Spec.
Sportster/Buell Year #2: 1981
Reputation: 4221351
Toejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond repute
Default

Quote:
Originally Posted by b0fh View Post
mine does a horrible noise on turn-on whenever i let it sit for too long like a week or more. sounds like a cat dying... also a 2008 and does this since new, pump still pumping strong
Sounds like the pump is dry, does it somehow lose it's prime, especially when setting for a while?
Reply With Quote
  #7  
Old 5 Days Ago
b0fh's Avatar
b0fh b0fh is offline
Harley Engineer
 
Join Date: Oct 2008
Location: Brazil
Posts: 326
Sportster/Buell Model: XL883R
Sportster/Buell Year: 2008
Sportster/Buell Model #2: XL1200CX Roadster
Sportster/Buell Year #2: 2017
Reputation: 100453
b0fh has much to be proud ofb0fh has much to be proud ofb0fh has much to be proud ofb0fh has much to be proud ofb0fh has much to be proud ofb0fh has much to be proud ofb0fh has much to be proud ofb0fh has much to be proud ofb0fh has much to be proud ofb0fh has much to be proud ofb0fh has much to be proud of
Default

Quote:
Originally Posted by Toejam503 View Post
Sounds like the pump is dry, does it somehow lose it's prime, especially when setting for a while?


no idea. this particular bike (its an 883) never failed to start on 1st try its whole life, even when sitting for more than a month due to work travel and whatnot.

just makes the dying cat sound for a minute or so.
Reply With Quote
  #8  
Old 5 Days Ago
Bikeaholic Bikeaholic is offline
XL FORUM LIFE MEMBER
 
Join Date: May 2015
Location: Australia.
Posts: 47
Sportster/Buell Model: xl1250
Sportster/Buell Year: 2008
Reputation: 118048
Bikeaholic has much to be proud ofBikeaholic has much to be proud ofBikeaholic has much to be proud ofBikeaholic has much to be proud ofBikeaholic has much to be proud ofBikeaholic has much to be proud ofBikeaholic has much to be proud ofBikeaholic has much to be proud ofBikeaholic has much to be proud ofBikeaholic has much to be proud ofBikeaholic has much to be proud of
Default

Hi,
So you had the fuel pump replaced last year? You now have 2700 miles and you are having squeal type noises when first priming the fuel pump. Are there any other problems with fuel this pump beside the noise? ( i know you are waiting on a pressure gauge to test it) . What was wrong with the first fuel pump?
I have a 2008 and mine has always made squeal, almost grating sound noises when turned on. It is worse when it has been sitting for a while at "first start" after sitting for long periods ( days, weeks etc) Always works and i have not noticed the bike suffer from incorrect fuel pressure. I think i remember reading that it not unusual to have noises from primming of the pump prior to starting. Please keep us informed. Ride safe.
Reply With Quote
  #9  
Old 4 Days Ago
Toejam503's Avatar
Toejam503 Toejam503 is offline
Air-Cooled Forever
 
Join Date: May 2010
Location: Dakota Territory
Posts: 2,302
Sportster/Buell Model: XL 1200 C
Sportster/Buell Year: 2006
Sportster/Buell Model #2: (Prev.Own)XLH Milw.Spec.
Sportster/Buell Year #2: 1981
Reputation: 4221351
Toejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond reputeToejam503 has a reputation beyond repute
Default

You can probably dismiss this as pure Bullshit, but if I had an EFI bike and the pump made a constant start-up squeal I'd be tempted to run a small amount of 2-cycle oil, mixed with the gas, to help lubricate the internal parts of the pump. Maybe it would help, maybe not. It shouldn't damage the pump.
Reply With Quote
Sponsored Links
  #10  
Old 4 Days Ago
smm1200 smm1200 is offline
Biker
 
Join Date: Jul 2019
Posts: 3
Sportster/Buell Model: 1200xl
Sportster/Buell Year: 2008
Reputation: 10
smm1200 is an unknown quantity at this point
Default

thanks for all discussion. ....the press gauge today.....runs near 60psi....so pump working. Not sure about flow rate.....not easy to just turn on pump and let it flow w/o another adapter.....the fittings have internal checks. But, revved up and no press loss.....soooo. Will now pull tank and pump assy for next steps. At this point I will replace some parts. Called dealer on parts....said they would call back...nonesuch. I still would like to know about size on the single ear clamps...may have to just go to harley to see if they have parts. Intend now to look at screen and filter, and probably replace pump as well due to noise....but I hear your points above on noise and been OK, I may change my mind on the pump for now since pressure ok. Will follow up with more findings. Now worried about injectors....maybe other problems like electrical since it just shuts down under full throttle over last several runs. But, will just follow the dots for now. thanks again.
Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Sponsored Links
All times are GMT +1. The time now is 14:47.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
XL Forum® - Linson Media LLC