The Sportster and Buell Motorcycle Forum - The XLFORUM®
 

Go Back   The Sportster and Buell Motorcycle Forum - The XLFORUM® > SPORTSTER MOTORCYCLE FORUM > Sportster Motorcycle Era Specific and Model Specific > EFI Sportster Motorcycle Talk (2007 and up)
XLF Blogs XLF Arcade XLF Disclaimer/Privacy Statement/Terms Of Use

EFI Sportster Motorcycle Talk (2007 and up) For 2007 and above Sportsters

Active Threads
0 1986-90 Evo Sportsters: What every owner should know but were afraid to ask
Last Post: Hippysmack
Posted On: 1 Minute Ago
Replies: 392
Views: 54,130
0 Hottie of the day, no nudity.
Last Post: ronccc
Posted On: 1 Minute Ago
Replies: 17,903
Views: 1,804,782
0 Keep & Kill
Last Post: Graywolf
Posted On: 22 Minutes Ago
Replies: 16,291
Views: 926,409
0 neat stuff, but didnt knopw where to put it
Last Post: 72 Ironhead XLH
Posted On: 39 Minutes Ago
Replies: 0
Views: 13
0 Corona Virus
Last Post: BKB
Posted On: 54 Minutes Ago
Replies: 360
Views: 18,100
0 Government and financial services rip-off
Last Post: Joe_jeep
Posted On: 1 Hour Ago
Replies: 19
Views: 588
0 Hot Chicks on Hot Bikes
Last Post: trainman
Posted On: 1 Hour Ago
Replies: 10,688
Views: 1,965,916
0 WTB: 40376-57 compensating sprocket extension
Last Post: Moon Wolf
Posted On: 2 Hours Ago
Replies: 2
Views: 71
0 xied or x14ied?
Last Post: Bluto
Posted On: 2 Hours Ago
Replies: 6
Views: 137
9 CV carburetor gurus...
Last Post: Dougray
Posted On: 2 Hours Ago
Replies: 6
Views: 93
0 Resto-Repair 84 ironhead
Last Post: ferretface
Posted On: 3 Hours Ago
Replies: 24
Views: 1,361
0 '03 883 custom only idles with the choke on
Last Post: Tomcatt
Posted On: 4 Hours Ago
Replies: 14
Views: 1,358
0 Official XL Forum Random Image Thread (NO NUDITY!)
Last Post: Graywolf
Posted On: 4 Hours Ago
Replies: 46,843
Views: 7,459,220
0 KT - 2020 - Where Eagles Dare
Last Post: IXL2Relax
Posted On: 4 Hours Ago
Replies: 24
Views: 3,525
1 Sportster's they are just sexy
Last Post: glbsportster
Posted On: 5 Hours Ago
Replies: 14
Views: 1,076
0 Why cafe a sportster?
Last Post: TUCCI
Posted On: 5 Hours Ago
Replies: 268
Views: 89,571
0 ....1
Last Post: Graywolf
Posted On: 5 Hours Ago
Replies: 5,167
Views: 309,191
0 I hope this is not the "New Normal"
Last Post: rokytnji
Posted On: 5 Hours Ago
Replies: 8
Views: 237
0 Is it true? (eliminate clutch spring plate)
Last Post: rejeanprimeau
Posted On: 6 Hours Ago
Replies: 62
Views: 26,280
0 fp3
Last Post: 11alan111
Posted On: 6 Hours Ago
Replies: 8
Views: 89
0 Coronavirus & DK Custom Products - Update 3/18/20
Last Post: DK Custom
Posted On: 6 Hours Ago
Replies: 6
Views: 389
0 15 sporty braided rear brake line
Last Post: Folkie
Posted On: 6 Hours Ago
Replies: 3
Views: 176
3 Wtb, Wts, Wtt, Wtg (Ironhead)
Last Post: SHAKY DAVE
Posted On: 6 Hours Ago
Replies: 51
Views: 251,864
0 Mid West Meet & Greet
Last Post: Stairman
Posted On: 7 Hours Ago
Replies: 387
Views: 31,003
0 Drastic Failure how to diagnose
Last Post: Iron Mike
Posted On: 7 Hours Ago
Replies: 59
Views: 4,847
0 Digital odometer
Last Post: Tim The Grim
Posted On: 8 Hours Ago
Replies: 7
Views: 236
0 Dual Disc Conversion - Slider Clearance
Last Post: shrimp
Posted On: 8 Hours Ago
Replies: 0
Views: 57
0 No spark
Last Post: IXL2Relax
Posted On: 9 Hours Ago
Replies: 1
Views: 98
0 My 900: half-H, half-CH
Last Post: IronMick
Posted On: 10 Hours Ago
Replies: 15
Views: 1,247
0 simple HF jack-lift for sporty mod.
Last Post: mikeLI_77
Posted On: 10 Hours Ago
Replies: 15
Views: 352
More...
Members Birthdays
shotgun46 (62), Xtr2der (60), davidsdad (54), moondog (54), scout2006 (54), Kajun (49), Sam (45)
Tags
ecm, efi, fuel, pump, relay

Reply
 
Share Thread Tools Display Modes
  #1  
Old 27th July 2019
SilverFox74 SilverFox74 is offline
Biker
 
Join Date: Jun 2019
Posts: 6
Sportster/Buell Model: 1200C
Sportster/Buell Year: 2007
Reputation: 1682
SilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura about
Default 07 XL1200C ECM, Fuel Pump, Wiring - No Start or Prime

Long story short, I bought an 07 XL1200C new in June 2007. Sold it in 2016. Just bought it back last week.

The guy had it about a year then a thief steals the ECM and battery. He waits 2 years before replacing the ECM (with a used one) and battery, all the while, the bike sits uncovered in an apartment parking lot, taking a beating from sun, rain, etc. He calls me about a month ago to see if I know anything about ECM replacement because he can't get it to start and needs to sell it before he moves out of state. I go ahead and buy the bike back in non-running condition with the belief that I can get it running again relatively easily. I took immaculate care of it before I sold it to him. He rode less than a year before it got hacked and sat out of commission and he had only put around 2K miles on it during that time.

I drained the old gas, cleaned the tank and put fresh gas in. I repaired some wires that got hacked when the thief stole the ECM and insulated the soldered connections with heat shrink. Checked all electrical connectors to make sure they're fully seated. I tried to start it as usual, and the first thing I noticed is that the fuel pump didn't seem to prime--it didn't make the usual loud whining sound when ignition and run switch are turned on--total silence. Tried to start it anyway, and starter turns, but no combustion. I cycled the switch a couple more times with my ear against the tank. No priming sound, but when I turn the switch off, I can hear a faint sound of fuel siphon/drip, as though pressure is releasing from the pump. So...

I checked the DTC codes and found these:

P0261 Front Injector Open/Low
P1001 System Relay Open/Low

Clear the P0261 code, but it won't let me clear the P1001 code. Still confused about that. Is the ECM keeping the system relay in an open state? Is that causing the P0261 code since the injector isn't getting voltage due to the open relay? Is there some other condition that would prevent the ECM from providing power to the fuel pump on startup? Bank angle sensor? Could it be that there's a wiring issue somewhere in the system relay path? I've read people having issues with corrosion at the fuse box terminals. Could it be something that simple? Do I have to remove the entire wiring harness to look at the terminal side of the fuse box?Just thinking out loud here...

So...I check all fuses, replace the relays, clean terminals with contact cleaner and a wire brush, etc. Still no start. Took the fuel pump out and visually inspected it--it looks perfect. It's the revision B pump. Hooked a 9V battery directly to the motor, and it spins freely, but very quietly. Bad fuel pump motor perhaps? There is fuel in the filter housing. Possibly a bad pressure regulator? Just for good measure I also removed and cleaned the fuel injectors. I applied 9V to them while putting carb cleaner through them and they both have good pressure and spray patterns. I still think the lack of pump priming at ignition is key to the issue.

So...I thought maybe there was a problem with the replacement ECM, p/n 32140-08. After looking into it, the ECM he bought SHOULD work after the proper password learn sequence that I found posted somewhere on here by ScrewLooseDan, which I've done twice so far, but I can't actually tell if it worked. And, of course, I can't verify that the replacement ECM is even good in the first place. Unless someone knows a way that I can?

Based on the symptoms, with my limited knowledge, I'm thinking it's got to be one or more of the following:

1. Bad ECM or ECM password learning procedure not successful.
2. Bad fuel pump and/or fuel pressure regulator.
3. Wiring issue, corrosion at relay or fuse terminals.

Please help! Any troubleshooting tips appreciated. I've scoured the forum for answers first, but have exhausted my ability.
Reply With Quote
  #2  
Old 27th July 2019
SilverFox74 SilverFox74 is offline
Biker
 
Join Date: Jun 2019
Posts: 6
Sportster/Buell Model: 1200C
Sportster/Buell Year: 2007
Reputation: 1682
SilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura about
Default

Forgot to mention that I replaced the spark plugs too.
Reply With Quote
  #3  
Old 28th July 2019
IXL2Relax's Avatar
IXL2Relax IXL2Relax is offline
XL FORUM TEAM MEMBER
 
Join Date: Feb 2013
Location: Let Freedom Ring in PA
Posts: 7,261
Sportster/Buell Model: Sportster 883►1200
Sportster/Buell Year: 1994
IXL2Relax has disabled reputation
Default

Did you check the Fuel Pump Fuse?

Did you get the 'P1001 System Relay Open/Low' DTC code after replacing the relays?
Did you get other codes?

Do you have the Factory Service Manual and the Electrical Diagnostic Manual for 2007?

You should be able to pull off the Coil connector & check for power on contacts 'A' or 'B' which is the same power that is supplied to the Fuel Pump (thru the Fuel Pump Fuse) during the first 2-seconds after turning on the keyswitch...

Put the RUN/STOP switch in RUN, pull the coil connector, put your RED meter probe on contact A or B, put your BLACK meter probe on a solid ground, then turn on the keyswitch - watch the meter to see if power is present during the first 2-seconds...


IXL _______ >>>> My Motorcycle Chronicles Are Here <<<<
For FREE Sportster Tech Info from the XLForum:
Explore The Sportsterpedia - The Best Kept Secret on the XLForum!
__________________
### The ride is more enjoyable to nowhere in particular! ###

Last edited by IXL2Relax; 28th July 2019 at 03:17..
Reply With Quote
  #4  
Old 29th July 2019
SilverFox74 SilverFox74 is offline
Biker
 
Join Date: Jun 2019
Posts: 6
Sportster/Buell Model: 1200C
Sportster/Buell Year: 2007
Reputation: 1682
SilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura about
Default

IXL2Relax--thanks for the response.

Fuel pump fuse is good. The P1001 code was there both before and after I changed the relays. When I clear it, I go immediately back into the P diagnostic menu and the code is still there. The P0261 code clears temporarily, but returns next time I crank the starter.

I have the factory service manual but not the Electrical Diagnostics Manual.

I'll check for voltage at the coil connector. I may actually pull the fuel pump, keep it powered and check for voltage at the connector there as well. Any idea what it should read when the key switch is engaged?
Reply With Quote
  #5  
Old 29th July 2019
IXL2Relax's Avatar
IXL2Relax IXL2Relax is offline
XL FORUM TEAM MEMBER
 
Join Date: Feb 2013
Location: Let Freedom Ring in PA
Posts: 7,261
Sportster/Buell Model: Sportster 883►1200
Sportster/Buell Year: 1994
IXL2Relax has disabled reputation
Default

Power path to the Fuel Pump

Battery to
MaxiFuse to
Keyswitch to
ECM Fuse to
System Relay (out) to
Fuel Pump Fuse to
Fuel Pump (Pin#1)

Nothing in that sequence should drag down the voltage level...
Check voltage directly across the battery terminals...
Check voltage at the Fuel Pump Pin#1 (+) and Pin#4 (-)...
Compare - should be within .2v-.4v of each other...


When you're having issues with the electrical system, use this Sportsterpedia section about
checking the battery cables, voltages and grounds - DO THIS BEFORE ANYTHING ELSE:
http://sportsterpedia.com/doku.php/t...place_to_start


Be sure the ground wire (fuel pump pin#4) is truly grounded...

Be sure to check the Powertrain Ground Point where the main harness ground is mounted to the engine stud - As others have, you may want to move those ground wires (along with the battery ground) to the more accessible stud on the back-side of the primary cover...


IXL _______ >>>> My Motorcycle Chronicles Are Here <<<<
For FREE Sportster Tech Info from the XLForum:
Explore The Sportsterpedia - The Best Kept Secret on the XLForum!
Reply With Quote
  #6  
Old 30th July 2019
SilverFox74 SilverFox74 is offline
Biker
 
Join Date: Jun 2019
Posts: 6
Sportster/Buell Model: 1200C
Sportster/Buell Year: 2007
Reputation: 1682
SilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura about
Default

Roger that. I'll report results after I've had a chance to check the power path.
Reply With Quote
  #7  
Old 30th July 2019
SilverFox74 SilverFox74 is offline
Biker
 
Join Date: Jun 2019
Posts: 6
Sportster/Buell Model: 1200C
Sportster/Buell Year: 2007
Reputation: 1682
SilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura about
Default

So, I was beginning my power path trace and I was thinking about the circumstances this bike suffered. The thief who stole the ecm damaged some wires near the main harness under the seat, which I had to repair. It made me wonder if there was more damage I hadn't seen yet. Pulled the ecm wiring harness connector and had a look at the receptors. Sure enough, the injector front and system relay receptors are broken.

Going to locate the proper female receptors, crimp, install and hopefully she'll fire right up.

Thanks IXL2Relax for setting me down the right path. If I hadn't started the power trace, I may not have discovered the broken receptors. Cheers.
Reply With Quote
  #8  
Old 30th July 2019
IXL2Relax's Avatar
IXL2Relax IXL2Relax is offline
XL FORUM TEAM MEMBER
 
Join Date: Feb 2013
Location: Let Freedom Ring in PA
Posts: 7,261
Sportster/Buell Model: Sportster 883►1200
Sportster/Buell Year: 1994
IXL2Relax has disabled reputation
Default

Quote:
Originally Posted by SilverFox74 View Post
If I hadn't started the power trace, I may not have discovered the broken receptors. Cheers.
Good find - I like to say: Be Patient, Be Accurate, Be Methodical & Be Thorough - Usually, one of those aspects will lead you to the right location to identify the problem...

Keep us posted...

IXL _______ >>>> My Motorcycle Chronicles Are Here <<<<
For FREE Sportster Tech Info from the XLForum:
Explore The Sportsterpedia - The Best Kept Secret on the XLForum!
Reply With Quote
  #9  
Old 30th July 2019
60Gunner's Avatar
60Gunner 60Gunner is offline
Chief of Security
 
Join Date: Sep 2017
Location: United States
Posts: 2,781
Sportster/Buell Model: 1200/1250C
Sportster/Buell Year: 05
Reputation: 2942552
60Gunner has a reputation beyond repute60Gunner has a reputation beyond repute60Gunner has a reputation beyond repute60Gunner has a reputation beyond repute60Gunner has a reputation beyond repute60Gunner has a reputation beyond repute60Gunner has a reputation beyond repute60Gunner has a reputation beyond repute60Gunner has a reputation beyond repute60Gunner has a reputation beyond repute60Gunner has a reputation beyond repute
Default

Report back. Always good to hear of successes in this type of electrical diagnostics.
__________________
05 1200/1250C/Hammer 570 Cams/E1 clutch kit +15% spring
TC88A Gunner's V00D00 map/DCPR7E/Taylor Pro 8mm
S&S Premium Lifters/KhromeWerks HP Plus 3" slip ons
HSR42 25 pilot 2 turns Y8 needle jet 97 needle 2nd groove 170 main
Dragtron II AC K&N filter/VR1 20W50/Spectro 85wt Primary Oil
Max torque 87.7@4400rpm/max hp 86.8@5600rpm




Need help with your Sportster? Check out the Sportsterpedia!
Reply With Quote
  #10  
Old 11th August 2019
SilverFox74 SilverFox74 is offline
Biker
 
Join Date: Jun 2019
Posts: 6
Sportster/Buell Model: 1200C
Sportster/Buell Year: 2007
Reputation: 1682
SilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura aboutSilverFox74 has a spectacular aura about
Default

Just a follow-up. Had to end up crimping new female receptors on 3 wires of my ECM connector. Tightened up a frame ground point and she fired up. Since then, I've put on a new breather and V&H FP3, tuned her up a bit and she runs great! Thanks for the help IXL2Relax. It felt great to take a nice, long ride this weekend with a properly tuned bike.
Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT +1. The time now is 04:07.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
XL Forum® - Linson Media LLC