The Sportster and Buell Motorcycle Forum - The XLFORUM®
 

Go Back   The Sportster and Buell Motorcycle Forum - The XLFORUM® > SPORTSTER MOTORCYCLE FORUM > Sportster Motorcycle Drivetrain > Sportster Motorcycle Tires, Wheels, and Brakes
XLF Blogs XLF Arcade XLF Disclaimer/Privacy Statement/Terms Of Use

Notices

Sportster Motorcycle Tires, Wheels, and Brakes Discuss issues with Sportster motorcycle tires, wheels and brakes.

Active Threads
0 Recommendations for a good parts vendor
Last Post: brucstoudt
Posted On: 18 Minutes Ago
Replies: 16
Views: 787
0 Hottie of the day, no nudity.
Last Post: Stairman
Posted On: 27 Minutes Ago
Replies: 8,416
Views: 674,359
0 With this fit my 99
Last Post: jordan1200
Posted On: 38 Minutes Ago
Replies: 9
Views: 126
0 Happy Birthday wandrur!
Last Post: wandrur
Posted On: 38 Minutes Ago
Replies: 4
Views: 77
0 Iree's late night cafe
Last Post: Graywolf
Posted On: 38 Minutes Ago
Replies: 984
Views: 99,995
0 Will a 2000 swingarm bolt up/ fit my 99?
Last Post: jordan1200
Posted On: 50 Minutes Ago
Replies: 13
Views: 185
0 Were your parents anti bike?
Last Post: jcn59
Posted On: 1 Hour Ago
Replies: 11
Views: 118
0 Thinking of a fall SE Ohio ride
Last Post: mick42
Posted On: 1 Hour Ago
Replies: 54
Views: 3,094
0 1200s mid throttle stumble
Last Post: NZstu
Posted On: 2 Hours Ago
Replies: 15
Views: 271
0 New England 2018
Last Post: Boudwood
Posted On: 2 Hours Ago
Replies: 225
Views: 11,588
0 Poll for the legalization of cannabis
Last Post: tigger
Posted On: 3 Hours Ago
Replies: 380
Views: 52,328
0 Hi from Queensland Australia
Last Post: juzyHD
Posted On: 3 Hours Ago
Replies: 13
Views: 104
0 What are your thoughts on this 2004 rubbermount Sporty?
Last Post: farmall
Posted On: 3 Hours Ago
Replies: 68
Views: 2,907
0 PLEASE READ THIS Before You Post In 'The BUY - SELL - TRADE Zone'!
Last Post: Folkie
Posted On: 3 Hours Ago
Replies: 1
Views: 2,068
0 FS Stock 2012 Xl1200 and 1275 jugs
Last Post: Folkie
Posted On: 3 Hours Ago
Replies: 1
Views: 90
0 Reflectors...Yeah, or Neh
Last Post: Toejam503
Posted On: 3 Hours Ago
Replies: 159
Views: 36,547
0 Folkie's Rural Rambles
Last Post: Folkie
Posted On: 4 Hours Ago
Replies: 43
Views: 8,962
0 Preston Candover
Last Post: Folkie
Posted On: 5 Hours Ago
Replies: 0
Views: 56
0 Cylinder wall scoring after rebuild, can you live with it?
Last Post: doodah man
Posted On: 5 Hours Ago
Replies: 1
Views: 101
0 Ironhead primary filling with oil not puking
Last Post: doodah man
Posted On: 5 Hours Ago
Replies: 4
Views: 98
0 Tranny Question
Last Post: doodah man
Posted On: 5 Hours Ago
Replies: 3
Views: 168
0 Gravydog crashed again.
Last Post: gravydog
Posted On: 5 Hours Ago
Replies: 86
Views: 3,667
0 09 Buell XB12 crank
Last Post: Boudwood
Posted On: 6 Hours Ago
Replies: 13
Views: 335
0 Roads I'd like to ride.
Last Post: Stairman
Posted On: 6 Hours Ago
Replies: 573
Views: 30,867
3 Transmission Assembly, Tutorial w/Pics
Last Post: sltm1
Posted On: 6 Hours Ago
Replies: 71
Views: 50,437
0 2019 Suzuki Katana
Last Post: jammantoo
Posted On: 6 Hours Ago
Replies: 11
Views: 345
0 Crusty's Travels
Last Post: Crusty
Posted On: 7 Hours Ago
Replies: 1,649
Views: 171,806
0 HAMMERING the Columbia!
Last Post: sportsterpaul
Posted On: 7 Hours Ago
Replies: 51
Views: 8,545
0 Big bore stroker - the beginning of a 10-year long build
Last Post: RKN
Posted On: 7 Hours Ago
Replies: 796
Views: 72,512
0 I have a problem with my sportster. (Intermittent Starting Problem)
Last Post: DYLAN
Posted On: 7 Hours Ago
Replies: 15
Views: 886
More...
Members Birthdays
Sponsored Links
Reply
 
Share Thread Tools Display Modes
  #1  
Old 25th May 2018
Jowniofownio Jowniofownio is offline
Biker
 
Join Date: Feb 2018
Posts: 31
Sportster/Buell Model: Sportster Evo
Sportster/Buell Year: 1989
Reputation: 10
Jowniofownio is an unknown quantity at this point
Default Front brake won't bleed 1989 sportster

I have had the master cylinder in pieces and re sealed it the way it came out. I am now trying to bleed the brake and cannot get any fluid to leave the reservoir. Both holes are clear, the seals look good and I'm pretty sure it's built up as it sprang apart.

I would have thought that if the res was filled up and the hose off the master cylinder, fluid should slowly drain out through the small hole onto the floor. I'm not having any fluid leave the res. If I try bleeding it, nothing leaves the res. If I have it all connected up with fluid in re res and prime the piston and master, if I push back on the brake pads, the level of the res doesn't raise?

I'm very confused as never had issues bleeding brakes before

Any ideas?
Reply With Quote
  #2  
Old 26th May 2018
decman decman is offline
Post no Avatars!
 
Join Date: Jan 2005
Location: Dubois, WY
Posts: 3,786
Sportster/Buell Model: 1200S
Sportster/Buell Year: 2001
Sportster/Buell Model #2: XLH-883D
Sportster/Buell Year #2: 1988
Other Motorcycle Model: FXDXT
Other Motorcycle Year: 2001
Reputation: 2092658
decman has a reputation beyond reputedecman has a reputation beyond reputedecman has a reputation beyond reputedecman has a reputation beyond reputedecman has a reputation beyond reputedecman has a reputation beyond reputedecman has a reputation beyond reputedecman has a reputation beyond reputedecman has a reputation beyond reputedecman has a reputation beyond reputedecman has a reputation beyond repute
Default

Fluid doesn't drain anywere when it is needed.

Put fluid in and "pump" the lever (Hand or foot) "a lot" before trying
anything else.
When you finally feel some resistance to the pumping 'then and only then'
do you resort to the normal bleeding process.
Reply With Quote
  #3  
Old 4th June 2018
Jowniofownio Jowniofownio is offline
Biker
 
Join Date: Feb 2018
Posts: 31
Sportster/Buell Model: Sportster Evo
Sportster/Buell Year: 1989
Reputation: 10
Jowniofownio is an unknown quantity at this point
Default

Right, used a vacuum bleeding tool to pull the fluid through. The front brake works a bit but if you hold the brake down, it goes hard then slowly pulls in towards the grip and I loose all braking whitch was a bit dodgy heading to the junction! Does this sound like air still in the system or passing seal? The seal looks good but may be old.

The rear brake, I'm having no luck getting a brake at all.

Any ideas?
Reply With Quote
  #4  
Old 4th June 2018
rokytnji's Avatar
rokytnji rokytnji is offline
XL FORUM LIFE MEMBER
 
Join Date: Apr 2016
Location: Texas/Mexican Border
Posts: 2,069
Sportster/Buell Model: xls 1000
Sportster/Buell Year: 1980
Sportster/Buell Model #2: xls 1000
Sportster/Buell Year #2: 1983
Other Motorcycle Model: 1200 Chopper XL
Other Motorcycle Year: 1990
Reputation: 3217530
rokytnji has a reputation beyond reputerokytnji has a reputation beyond reputerokytnji has a reputation beyond reputerokytnji has a reputation beyond reputerokytnji has a reputation beyond reputerokytnji has a reputation beyond reputerokytnji has a reputation beyond reputerokytnji has a reputation beyond reputerokytnji has a reputation beyond reputerokytnji has a reputation beyond reputerokytnji has a reputation beyond repute
Default

You put in a rebuild kit and did not change the seal. This rebuild sounds a bit dodgy to me.

I'd start over and do it right. This posted by a dude who who just did front and rear brakes on a 1980.
__________________
*Reference the Sportsterpedia! For Helpful info on your scooter.
I don't live in a What If world.
Traveled to
Reply With Quote
  #5  
Old 4th June 2018
Jowniofownio Jowniofownio is offline
Biker
 
Join Date: Feb 2018
Posts: 31
Sportster/Buell Model: Sportster Evo
Sportster/Buell Year: 1989
Reputation: 10
Jowniofownio is an unknown quantity at this point
Default

Quote:
Originally Posted by rokytnji View Post
You put in a rebuild kit and did not change the seal. This rebuild sounds a bit dodgy to me.

I'd start over and do it right. This posted by a dude who who just did front and rear brakes on a 1980.
I didn't fit a new kit. Just stripped it and noticed the o ring was broken and replaced this. The cup seal hasn't been changed as looks ok. I have rebuilt it about 5 times now and this is the closest I have got it to working now.
Reply With Quote
  #6  
Old 4th June 2018
rokytnji's Avatar
rokytnji rokytnji is offline
XL FORUM LIFE MEMBER
 
Join Date: Apr 2016
Location: Texas/Mexican Border
Posts: 2,069
Sportster/Buell Model: xls 1000
Sportster/Buell Year: 1980
Sportster/Buell Model #2: xls 1000
Sportster/Buell Year #2: 1983
Other Motorcycle Model: 1200 Chopper XL
Other Motorcycle Year: 1990
Reputation: 3217530
rokytnji has a reputation beyond reputerokytnji has a reputation beyond reputerokytnji has a reputation beyond reputerokytnji has a reputation beyond reputerokytnji has a reputation beyond reputerokytnji has a reputation beyond reputerokytnji has a reputation beyond reputerokytnji has a reputation beyond reputerokytnji has a reputation beyond reputerokytnji has a reputation beyond reputerokytnji has a reputation beyond repute
Default

Uh huh.

Quote:
I have rebuilt it about 5 times now and this is the closest I have got it to working now.
Cool that it almost working. No details though on honing. Parts used. Etc.....

So I expect loosey goosey. Hell. I even cheated on mine. But I was not afeared to go into detail on what I did, and what I did not do. But I got broad shoulders and dgaf on what others think of my repair methods.
Since it is a personal thing < parts available, budget > for me out here in the wild west.
Reply With Quote
  #7  
Old 4th June 2018
Jowniofownio Jowniofownio is offline
Biker
 
Join Date: Feb 2018
Posts: 31
Sportster/Buell Model: Sportster Evo
Sportster/Buell Year: 1989
Reputation: 10
Jowniofownio is an unknown quantity at this point
Default

Right, got a decent front brake now. Kept bleeding and finally got there. Now onto the rear....

I can't get anything there. Been bleeding for hours and nothing. Using the vacuum thing and it pulls fluid through but not building pressure. No obvious leaks and everything seems tight?
Reply With Quote
  #8  
Old 21st June 2018
Jowniofownio Jowniofownio is offline
Biker
 
Join Date: Feb 2018
Posts: 31
Sportster/Buell Model: Sportster Evo
Sportster/Buell Year: 1989
Reputation: 10
Jowniofownio is an unknown quantity at this point
Default

right, I no longer have a front brake now!! If I give the brake leaver long hard pumps it stays solid and doesn't loose pressure. But if I give it soft slow pumps, and let out a bit then pump again, the leaver keeps coming in until it is at the grip and I don't have a brake! Could someone confirm that this is the master cylinder seals? Which could cause this as I have replaced the O rings just not the cup seal as that looks good. Or could it be a problem with the slide pins on the front brake caliper?
Reply With Quote
  #9  
Old 22nd June 2018
JacksBrother's Avatar
JacksBrother JacksBrother is offline
Drag Race Champion
 
Join Date: May 2010
Posts: 399
Sportster/Buell Model: XL1200
Sportster/Buell Year: 1998
Other Motorcycle Model: Harley Davidson FLH
Other Motorcycle Year: 1973
Reputation: 108165
JacksBrother has much to be proud ofJacksBrother has much to be proud ofJacksBrother has much to be proud ofJacksBrother has much to be proud ofJacksBrother has much to be proud ofJacksBrother has much to be proud ofJacksBrother has much to be proud ofJacksBrother has much to be proud ofJacksBrother has much to be proud ofJacksBrother has much to be proud ofJacksBrother has much to be proud of
Default

Quote:
Originally Posted by Jowniofownio View Post
right, I no longer have a front brake now!! If I give the brake leaver long hard pumps it stays solid and doesn't loose pressure. But if I give it soft slow pumps, and let out a bit then pump again, the leaver keeps coming in until it is at the grip and I don't have a brake! Could someone confirm that this is the master cylinder seals? Which could cause this as I have replaced the O rings just not the cup seal as that looks good. Or could it be a problem with the slide pins on the front brake caliper?
I Can't evaluate the pressure performance of a cup seal by eye, how can you? Cup seals can lose rigidity and/or elasticity which won't register by feel or by vision. The symptoms you are describing match a worn or degraded cup seal-- change it. If it doesn't fix your problem, it eliminates a suspect.
Just my $0.02 worth,
Joe
Reply With Quote
Sponsored Links
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Sponsored Links
All times are GMT +1. The time now is 23:35.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
XL Forum® - Linson Media LLC