The Sportster and Buell Motorcycle Forum - The XLFORUM®
 

Go Back   The Sportster and Buell Motorcycle Forum - The XLFORUM® > SPORTSTER MOTORCYCLE FORUM > Sportster Motorcycle Electrical > Sportster Motorcycle Lighting
XLF Blogs XLF Arcade XLF Disclaimer/Privacy Statement/Terms Of Use

Active Threads
0 IH steering stem
Last Post: bustert
Posted On: 11 Minutes Ago
Replies: 6
Views: 171
0 Dale's Killer 40mm CV Carb
Last Post: bremoit
Posted On: 15 Minutes Ago
Replies: 0
Views: 9
0 Crusty's Travels
Last Post: rokytnji
Posted On: 19 Minutes Ago
Replies: 1,742
Views: 190,201
0 Iree's jukbox joint
Last Post: rokytnji
Posted On: 21 Minutes Ago
Replies: 4,900
Views: 282,637
0 XR heads on XL?
Last Post: aswracing
Posted On: 26 Minutes Ago
Replies: 6
Views: 120
0 Do people notice your bike?
Last Post: rokytnji
Posted On: 27 Minutes Ago
Replies: 1,146
Views: 303,760
0 1986-90 Evo Sportsters: What every owner should know but were afraid to ask
Last Post: Gary E
Posted On: 32 Minutes Ago
Replies: 210
Views: 24,840
0 Oil Pump Upgrade '86-'90
Last Post: Hippysmack
Posted On: 45 Minutes Ago
Replies: 47
Views: 1,654
0 XR1200 Torquehammer exhaust failure.. again.
Last Post: CT XR rider
Posted On: 1 Hour Ago
Replies: 21
Views: 760
0 Hyundai/Kia
Last Post: Tom Beckner
Posted On: 1 Hour Ago
Replies: 3
Views: 123
0 Helmet poll
Last Post: sleighcrane
Posted On: 1 Hour Ago
Replies: 821
Views: 149,096
0 Spokes or Mags
Last Post: Eric Von Zipper
Posted On: 1 Hour Ago
Replies: 328
Views: 59,069
0 Tires
Last Post: Popgadget
Posted On: 1 Hour Ago
Replies: 19
Views: 885
0 Roads I'd like to ride.
Last Post: Stairman
Posted On: 2 Hours Ago
Replies: 793
Views: 49,218
0 You asked for it! "The Tess' Coffee Thread"
Last Post: Screw Loose Dan
Posted On: 2 Hours Ago
Replies: 10,409
Views: 745,035
0 Spokes and dual disc
Last Post: Screw Loose Dan
Posted On: 3 Hours Ago
Replies: 25
Views: 816
0 Official XL Forum Random Image Thread (NO NUDITY!)
Last Post: Davo_137
Posted On: 4 Hours Ago
Replies: 42,175
Views: 6,535,985
0 ....1
Last Post: Graywolf
Posted On: 4 Hours Ago
Replies: 4,717
Views: 235,122
0 77 kicker engagement issues
Last Post: doodah man
Posted On: 5 Hours Ago
Replies: 8
Views: 210
0 How stock is your bike
Last Post: commando57
Posted On: 6 Hours Ago
Replies: 144
Views: 29,773
0 Hottie of the day, no nudity.
Last Post: Stairman
Posted On: 6 Hours Ago
Replies: 9,114
Views: 748,804
0 Hot Rods, Rat Rods, and Customs.
Last Post: Stairman
Posted On: 6 Hours Ago
Replies: 2,857
Views: 277,647
0 What jets do you use?
Last Post: 60Gunner
Posted On: 6 Hours Ago
Replies: 244
Views: 75,348
0 New XL1200L from Oakland
Last Post: themadone
Posted On: 7 Hours Ago
Replies: 10
Views: 141
0 Big bore stroker - the beginning of a 10-year long build
Last Post: RKN
Posted On: 8 Hours Ago
Replies: 829
Views: 77,084
0 WTB Stock 4.3 gal Custom tank
Last Post: steveolds
Posted On: 13 Hours Ago
Replies: 0
Views: 50
0 Tire Size
Last Post: Civil War Harley
Posted On: 13 Hours Ago
Replies: 2
Views: 109
0 Best Riding/Motorcycle Memes-Let's see 'em!
Last Post: Graywolf
Posted On: 13 Hours Ago
Replies: 256
Views: 38,543
0 Mag wheel corrosion
Last Post: John Harper
Posted On: 14 Hours Ago
Replies: 5
Views: 127
0 Cheers from Germany
Last Post: oreocat1
Posted On: 14 Hours Ago
Replies: 20
Views: 345
More...
Members Birthdays
bobman, eagle101 (71), nemosengineer@yahoo.com (62), Callao (62), Dweezil (54), Dnew73, JimmyHBS (43), Ulv666 (42), 883ccXL (37), jmr1283 (35), dtschrum (31)
Tags
load equalizer, turn signal

Sponsored Links
Reply
 
Share Thread Tools Display Modes
  #1  
Old 29th April 2014
Bob On This Bob On This is offline
Biker
 
Join Date: Sep 2013
Posts: 4
Sportster/Buell Model: xlh883 Deluxe
Sportster/Buell Year: 1993
Other Motorcycle Model: Ural Bavarian Classic
Other Motorcycle Year: 2003
Reputation: 10
Bob On This is an unknown quantity at this point
Default Left turn signal only works intermittently

I have a '93 xl883 with some LEDs and some regular bulbs in the turn signals. Everything was working fine (with a load equalizer) until about a month ago, when the left only would only occasionally work. Sometimes I'd hit the switch multiple times, sometimes hold it in for a while, and it would eventually come on. Same problem turning it off. I usually just hit the right twice to turn it off. Any ideas?
Thanks.
Reply With Quote
  #2  
Old 29th April 2014
sportsterdoc's Avatar
sportsterdoc sportsterdoc is offline
Senior Master Custom Bike Builder
 
Join Date: Apr 2012
Location: Mojave Desert
Posts: 13,019
Sportster/Buell Model: 1200S
Sportster/Buell Year: 2002
Sportster/Buell Model #2: XLH883
Sportster/Buell Year #2: 2003
Reputation: 4777439
sportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond repute
Default

Quote:
Originally Posted by Bob On This View Post
I have a '93 xl883 with some LEDs and some regular bulbs in the turn signals. Everything was working fine (with a load equalizer) until about a month ago, when the left only would only occasionally work. Sometimes I'd hit the switch multiple times, sometimes hold it in for a while, and it would eventually come on. Same problem turning it off. I usually just hit the right twice to turn it off. Any ideas?
Thanks.
Where are the bulbs and where are the LEDs?
Bulb/LED sockets clean-not corroded?
All the wiring intact?
Does the right always work?
Reply With Quote
  #3  
Old 29th April 2014
Bob On This Bob On This is offline
Biker
 
Join Date: Sep 2013
Posts: 4
Sportster/Buell Model: xlh883 Deluxe
Sportster/Buell Year: 1993
Other Motorcycle Model: Ural Bavarian Classic
Other Motorcycle Year: 2003
Reputation: 10
Bob On This is an unknown quantity at this point
Default

I have bulbs in the four corners (stock fork mounts in front, fender side bullets in rear), and auxiliary LEDs in the license plate frame and front mirrors. I haven't checked the bulb sockets yet, but with the l still flash. I haven't gotten to checking ALL the wiring either (the stuff that's buried deepest). It's possible that there's a bad connection under the seat or tank. The right side always works perfectly. Does the TSM ever lose one side?
Thanks.
Reply With Quote
  #4  
Old 29th April 2014
sportsterdoc's Avatar
sportsterdoc sportsterdoc is offline
Senior Master Custom Bike Builder
 
Join Date: Apr 2012
Location: Mojave Desert
Posts: 13,019
Sportster/Buell Model: 1200S
Sportster/Buell Year: 2002
Sportster/Buell Model #2: XLH883
Sportster/Buell Year #2: 2003
Reputation: 4777439
sportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond repute
Default

Quote:
Originally Posted by Bob On This View Post
Does the TSM ever lose one side?
Possibly, as I have read about instances which seem to be the case, but no personal experience.

If the bulbs light and do not flash, it could be a TSM issue or resistor issue.
If the bulbs do not light, then I would first check bulbs, bulb sockets, wiring and then the switch. From what you have described, I am thinking it may be the switch.
Reply With Quote
  #5  
Old 29th April 2014
LOWPT's Avatar
LOWPT LOWPT is offline
Greasemonkey
 
Join Date: Jan 2014
Posts: 116
Sportster/Buell Model: Xl1200C
Sportster/Buell Year: 2009
Other Motorcycle Model: Suzuki GS1100E
Other Motorcycle Year: 1980
Reputation: 26199
LOWPT is a name known to allLOWPT is a name known to allLOWPT is a name known to allLOWPT is a name known to allLOWPT is a name known to allLOWPT is a name known to allLOWPT is a name known to allLOWPT is a name known to allLOWPT is a name known to allLOWPT is a name known to allLOWPT is a name known to all
Default

I am also having an issue with my left signal. It is working but flashing fast as though a bulb is out. Any ideas? ?

Low and Slow
Reply With Quote
  #6  
Old 29th April 2014
sportsterdoc's Avatar
sportsterdoc sportsterdoc is offline
Senior Master Custom Bike Builder
 
Join Date: Apr 2012
Location: Mojave Desert
Posts: 13,019
Sportster/Buell Model: 1200S
Sportster/Buell Year: 2002
Sportster/Buell Model #2: XLH883
Sportster/Buell Year #2: 2003
Reputation: 4777439
sportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond repute
Default

Quote:
Originally Posted by LOWPT View Post
I am also having an issue with my left signal. It is working but flashing fast as though a bulb is out. Any ideas? ?

Low and Slow
Both front and back flashing?
Reply With Quote
  #7  
Old 29th April 2014
LOWPT's Avatar
LOWPT LOWPT is offline
Greasemonkey
 
Join Date: Jan 2014
Posts: 116
Sportster/Buell Model: Xl1200C
Sportster/Buell Year: 2009
Other Motorcycle Model: Suzuki GS1100E
Other Motorcycle Year: 1980
Reputation: 26199
LOWPT is a name known to allLOWPT is a name known to allLOWPT is a name known to allLOWPT is a name known to allLOWPT is a name known to allLOWPT is a name known to allLOWPT is a name known to allLOWPT is a name known to allLOWPT is a name known to allLOWPT is a name known to allLOWPT is a name known to all
Default

^^yes

Low and Slow
Reply With Quote
  #8  
Old 29th April 2014
Folkie's Avatar
Folkie Folkie is online now
Brass Nut
 
Join Date: Feb 2005
Location: Western Weald
Posts: 44,734
Sportster/Buell Model: XL1200CB
Sportster/Buell Year: 2015
Other Motorcycle Model: CRF250L
Other Motorcycle Year: 2017
Reputation: 10101566
Folkie has a reputation beyond reputeFolkie has a reputation beyond reputeFolkie has a reputation beyond reputeFolkie has a reputation beyond reputeFolkie has a reputation beyond reputeFolkie has a reputation beyond reputeFolkie has a reputation beyond reputeFolkie has a reputation beyond reputeFolkie has a reputation beyond reputeFolkie has a reputation beyond reputeFolkie has a reputation beyond repute
Default

Quote:
Originally Posted by Bob On This View Post
turn signal only works intermittently
Mine too. I turn it on, and it comes on, then it goes off, on , off, on, off, …
__________________
Folkie
Super Moderator
South East England Riders



There is nothing at the end of any road better than may be found beside it. Edward Thomas (1878 - 1917)
Reply With Quote
  #9  
Old 29th April 2014
sportsterdoc's Avatar
sportsterdoc sportsterdoc is offline
Senior Master Custom Bike Builder
 
Join Date: Apr 2012
Location: Mojave Desert
Posts: 13,019
Sportster/Buell Model: 1200S
Sportster/Buell Year: 2002
Sportster/Buell Model #2: XLH883
Sportster/Buell Year #2: 2003
Reputation: 4777439
sportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond repute
Default

Quote:
Originally Posted by LOWPT View Post
^^yes

Low and Slow
At this point I would remove the bulbs, clean the sockets, apply dielectric grease, reinsert and check it.

When you remove the bulbs, check for the glass bulb to be loose in the base
Reply With Quote
Sponsored Links
  #10  
Old 29th April 2014
sportsterdoc's Avatar
sportsterdoc sportsterdoc is offline
Senior Master Custom Bike Builder
 
Join Date: Apr 2012
Location: Mojave Desert
Posts: 13,019
Sportster/Buell Model: 1200S
Sportster/Buell Year: 2002
Sportster/Buell Model #2: XLH883
Sportster/Buell Year #2: 2003
Reputation: 4777439
sportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond reputesportsterdoc has a reputation beyond repute
Default

Quote:
Originally Posted by Folkie View Post
Mine too. I turn it on, and it comes on, then it goes off, on , off, on, off, …
Hmmm...you could trade your TSM with LOWPT!
Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Sponsored Links
All times are GMT +1. The time now is 18:04.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
XL Forum® - Linson Media LLC