The Sportster and Buell Motorcycle Forum - The XLFORUM®
 

Go Back   The Sportster and Buell Motorcycle Forum - The XLFORUM® > SPORTSTER MOTORCYCLE FORUM > Sportster Motorcycle Era Specific and Model Specific > EFI Sportster Motorcycle Talk (2007 and up)
XLF Blogs XLF Arcade XLF Disclaimer/Privacy Statement/Terms Of Use

EFI Sportster Motorcycle Talk (2007 and up) For 2007 and above Sportsters

Active Threads
0 Benelli tank on 79’ sportster
Last Post: bustert
Posted On: 7 Minutes Ago
Replies: 2
Views: 47
0 Share your Man Cave Garage ideas
Last Post: NLXL
Posted On: 10 Minutes Ago
Replies: 6
Views: 99
0 Keep & Kill
Last Post: Yakcm2
Posted On: 14 Minutes Ago
Replies: 14,262
Views: 801,957
0 SBS Project - Sportster Chop w/ Lots of Photo's
Last Post: okiejim
Posted On: 16 Minutes Ago
Replies: 287
Views: 81,025
0 Hottie of the day, no nudity.
Last Post: Stairman
Posted On: 22 Minutes Ago
Replies: 14,949
Views: 1,411,778
0 lighter clutch
Last Post: NLXL
Posted On: 23 Minutes Ago
Replies: 12
Views: 186
0 This is gonna hurt.
Last Post: priell3
Posted On: 25 Minutes Ago
Replies: 7,820
Views: 1,576,513
0 Questions on popping after start
Last Post: doodah man
Posted On: 25 Minutes Ago
Replies: 3
Views: 44
0 Black Friday 2019 deals???
Last Post: Turbo Sporty 48
Posted On: 27 Minutes Ago
Replies: 5
Views: 206
3 Shaky Dave Recovery
Last Post: wedge
Posted On: 31 Minutes Ago
Replies: 43
Views: 6,866
5 What year is the most collectible Sportster.
Last Post: NLXL
Posted On: 33 Minutes Ago
Replies: 5
Views: 120
0 What weight oil?
Last Post: IronMick
Posted On: 37 Minutes Ago
Replies: 9
Views: 222
0 Official XL Forum Random Image Thread (NO NUDITY!)
Last Post: Crusty
Posted On: 1 Hour Ago
Replies: 45,465
Views: 7,177,466
0 Sportster Tacho
Last Post: Folkie
Posted On: 1 Hour Ago
Replies: 4
Views: 48
3 Wtb, Wts, Wtt, Wtg (Ironhead)
Last Post: MrYeats
Posted On: 1 Hour Ago
Replies: 52
Views: 240,140
0 xlcr elusive parts
Last Post: Speedyone
Posted On: 2 Hours Ago
Replies: 16
Views: 618
4 The no-debate OIL POLL
Last Post: 60Gunner
Posted On: 2 Hours Ago
Replies: 266
Views: 69,424
0 Wet Sump Ifo, fix and tools
Last Post: Ferrous Head
Posted On: 3 Hours Ago
Replies: 82
Views: 6,001
0 This week on Craig's list
Last Post: Ferrous Head
Posted On: 3 Hours Ago
Replies: 4,438
Views: 540,307
0 Roads I'd like to ride.
Last Post: Stairman
Posted On: 3 Hours Ago
Replies: 2,556
Views: 218,338
0 70 XLCH Piston, Connecting rod issue
Last Post: Wilkinson949
Posted On: 3 Hours Ago
Replies: 76
Views: 4,808
0 diagnose noise in engine after rebuild
Last Post: Hippysmack
Posted On: 3 Hours Ago
Replies: 11
Views: 342
0 Think my stator needs replaced
Last Post: Hippysmack
Posted On: 4 Hours Ago
Replies: 29
Views: 1,640
0 Best Battery Maintainer and/or Booster?
Last Post: NLXL
Posted On: 4 Hours Ago
Replies: 17
Views: 380
0 Huge cock up (XR1200 Clutch Mod)
Last Post: IXL2Relax
Posted On: 5 Hours Ago
Replies: 66
Views: 2,303
0 Do you use premium gas in your Sportster?
Last Post: THEWILDONE
Posted On: 6 Hours Ago
Replies: 1,789
Views: 369,112
0 Cheap 7200B bearing = NO!
Last Post: THEWILDONE
Posted On: 6 Hours Ago
Replies: 15
Views: 1,116
0 Food porn
Last Post: Stairman
Posted On: 6 Hours Ago
Replies: 1,670
Views: 289,421
0 Grüezi aus der Schweiz
Last Post: DéDé
Posted On: 6 Hours Ago
Replies: 8
Views: 128
More...
Members Birthdays
View Poll Results: Has your fuel pump failed?
Yes. It did. 88 14.22%
No. It hasn't. 531 85.78%
Voters: 619. You may not vote on this poll

Sponsored Links
Reply
 
Share Thread Tools Display Modes
  #21  
Old 14th June 2007
jchick's Avatar
jchick jchick is offline
Biker
 
Join Date: Dec 2006
Location: Maine
Posts: 80
Sportster/Buell Model: XL50
Sportster/Buell Year: 2007
Sportster/Buell Model #2: XL883 (traded up)
Sportster/Buell Year #2: 2004
Reputation: 75
jchick is an unknown quantity at this point
Default

Quote:
Originally Posted by HellRazur View Post
The second choise shouldnt be No it hasent... it should be " Not Yet! "
Ditto. Mine hasn't failed *yet*, but something ain't right with the EFI system on my bike. (See herky-jerky XL50). I'd rather have carb farts, at least that can be fixed.

JC
Reply With Quote
  #22  
Old 18th June 2007
MWD MWD is offline
Biker
 
Join Date: Feb 2007
Posts: 89
Sportster/Buell Model: XL1200R
Sportster/Buell Year: 2007
MWD has disabled reputation
Default

Here's a possible cause for the "fuel pump problem." Loosen your front tank bolt, and remove the rear one. Lift the back of the tank a couple of inches and set it down on a piece of 2x4:



You don't have to disconnect anything if you're careful and if you lift the rear of the tank only a couple of inches.

Now reach up into the center of the tank and pull down the fuel-pump wire. It may be taped to the tank as part of the assembly process. My wire looked like this, having been totally mashed between the tank and the frame rail.



Note the severe pinch in it from one edge of a backbone saddle trough. This is not just a cosmetic thing going on here -- we are talking about big-time pressure on a near knife-edge. I think this is the spot that may be wearing through with time and vibration.

Now drop the tank back into place and route the wire elsewhere. I winged it thus:



I'll probably tie-wrap it into place tomorrow before I hop on.

I believe the assemblers need this wire to be manufactured about six inches longer so they can put a proper loop in it, the way the service manual recommends, to keep it away from sharp edges.

I am not saying this *is* the cause of all these failures, but having a cable nearly knife-edged up against a hard surface can't be helping matters, and may be responsible for at least some of the recent non-starts.

p.s. I hope the images come through on this post. They aren't showing up in the preview, nor is the code. If I don't see them when this goes up, I'll post another reply with links to flickr.

Last edited by MWD; 18th June 2007 at 00:30.. Reason: repaired poor grammar
Reply With Quote
  #23  
Old 18th June 2007
MWD MWD is offline
Biker
 
Join Date: Feb 2007
Posts: 89
Sportster/Buell Model: XL1200R
Sportster/Buell Year: 2007
MWD has disabled reputation
Default

Here are the pics:

Tank rear on block
Big pic of above

Pinched wire
Big pic of above

Wire relocated
Big pic of above

Any advice on how better to re-route this wire?

Last edited by MWD; 18th June 2007 at 00:40.. Reason: added links to larger pics
Reply With Quote
  #24  
Old 18th June 2007
nightsterman's Avatar
nightsterman nightsterman is offline
Senior Chief Know It All
 
Join Date: Mar 2007
Posts: 822
Sportster/Buell Model: Nightster
Sportster/Buell Year: 2007
Reputation: 1337
nightsterman has a spectacular aura aboutnightsterman has a spectacular aura aboutnightsterman has a spectacular aura aboutnightsterman has a spectacular aura aboutnightsterman has a spectacular aura aboutnightsterman has a spectacular aura aboutnightsterman has a spectacular aura aboutnightsterman has a spectacular aura aboutnightsterman has a spectacular aura aboutnightsterman has a spectacular aura about
Thumbs up Thanks for the photos!

Thanks, I'm going to check mine out in the AM.

Peace,
Mark
Reply With Quote
  #25  
Old 19th June 2007
btkicker btkicker is offline
Master Mechanic
 
Join Date: Aug 2006
Posts: 268
Sportster/Buell Model: 1200 Roadster
Sportster/Buell Year: 07
btkicker has disabled reputation
Default

Great work MWD!

I checked my '07 Roadster (same small tank, efi, and all) and it's wires are where your new re-routed wires are!

Why the hell did HD move the wires only on the Nightster? I smell a recall to re-route the Nightster fuel-pump wires back to the normal spot.

again, good investigating.
Reply With Quote
  #26  
Old 19th June 2007
btkicker btkicker is offline
Master Mechanic
 
Join Date: Aug 2006
Posts: 268
Sportster/Buell Model: 1200 Roadster
Sportster/Buell Year: 07
btkicker has disabled reputation
Default

'07 Roadster fuel-pump wires:
Reply With Quote
  #27  
Old 19th June 2007
MWD MWD is offline
Biker
 
Join Date: Feb 2007
Posts: 89
Sportster/Buell Model: XL1200R
Sportster/Buell Year: 2007
MWD has disabled reputation
Default

Thanks for that pic, BT. However, I may have confused some people. That pic of the crushed harness was taken *after* I pulled it out of the upper trough in the backbone saddle (where yours probably is right now). The crushed part was buried up between the tank and the trough. I pulled it down out of the trough and ran it straight back, avoiding either trough. In the "relocated" pic, the crushed area is invisible because it is now directly behind the tank's quick-connect.

I'm going to take a guess here: the tanks are delivered to final assembly with the harnesses taped to the bottom of the tanks, to save stress on the wires right where they enter the tanks while the tanks are being handled. If so, it's possible that the guy building my bike forgot to yank the harness free of the tape so he could loop/route it properly, and when he dropped the tank into place the harness got crushed. I don't know -- I'm just thinking out loud. If I try hard enough I can imagine ten different possible causes for what I saw on my bike. Perhaps my experience was one in a million rather than indicative of a trend.
Reply With Quote
Sponsored Links
  #28  
Old 20th June 2007
Thumper74 Thumper74 is offline
Biker
 
Join Date: Jun 2007
Posts: 6
Sportster/Buell Model: 1200 Custom
Sportster/Buell Year: 2007
Reputation: 59
Thumper74 is an unknown quantity at this point
Default

When I was buying my 07 Custom, I had picked out a Pearl white w/o security system. They got it down stairs from the third floor, we did the paperwork, put the tags on it and they fueled it up. Bike wouldn't start. The fuel pump was bad with .2 miles on the odometer. The F&I manager came out and put me on the two tone custom that I had been eyeballing for the same price as the white bike. So far I'm happy and Helen (the sales lady) made sure to put a Freedom bell on the bike for me
Reply With Quote
  #29  
Old 20th June 2007
soto1994 soto1994 is offline
Biker
 
Join Date: Jun 2007
Posts: 3
Sportster/Buell Model: Sportster 1200 Custom
Sportster/Buell Year: 2007
Reputation: 10
soto1994 is an unknown quantity at this point
Default Fuel Pump Failed

I have a 2007 Sportster Custom with the failed fuel pump at 225 mile. Tomorrow will be a week since the HD shop had it. They hope the new pump will be in by Friday. HD should give us something for the inconvenience.

ASOTO
Reply With Quote
  #30  
Old 20th June 2007
Bill2's Avatar
Bill2 Bill2 is offline
Custom Bike Builder
 
Join Date: Mar 2005
Location: Texas gulfcoast
Posts: 2,411
Sportster/Buell Model: Sportster
Sportster/Buell Year: 2005
Sportster/Buell Model #2: XL standard 883/1200 conv
Bill2 has disabled reputation
Default

Quote:
Originally Posted by btkicker View Post
Great work MWD!

I checked my '07 Roadster (same small tank, efi, and all) and it's wires are where your new re-routed wires are!

Why the hell did HD move the wires only on the Nightster? I smell a recall to re-route the Nightster fuel-pump wires back to the normal spot.

again, good investigating.
Might be a service bulletin but i don't think theres no way its gonna be a recall.
__________________
'05 Standard 883/1200 touring conversion with: '07 XB heads with 8.8:1 c/r, dragtron II a/c, Caliber 2into1 five step header, rejetted to: 46pilotjet @ two turns,needle clip on 4th groove,185 main jet,twin tech high performance ignition, 30 tooth trans pulley, jagg oil cooler, forward controls, pullback type handle bars,memphis fats windshield, Corbin classic solo seat with back rest, 10" pillion pad, black progressive 412 shocks 12.5" H-D springs, progressive fork springs, vista cruise control, and relocated ignition & coil to a stainless steel home brewed mount between the cylinders. (Temp. runs around 165-180 degrees in town and 180- 210 degrees on the freeway running 70-90mph and it uses no oil in between 3000 mile changes.) GPS calibrated speedometer.
Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Sponsored Links
All times are GMT +1. The time now is 01:47.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
XL Forum® - Linson Media LLC