The Sportster and Buell Motorcycle Forum - The XLFORUM®
 

Go Back   The Sportster and Buell Motorcycle Forum - The XLFORUM® > SPORTSTER MOTORCYCLE FORUM > Sportster Motorcycle Era Specific and Model Specific > EFI Sportster Motorcycle Talk (2007 and up)
XLF Blogs XLF Arcade XLF Disclaimer/Privacy Statement/Terms Of Use

EFI Sportster Motorcycle Talk (2007 and up) For 2007 and above Sportsters

Active Threads
0 Gave up and made a bigger fuel tank (see pic)
Last Post: Ferrous Head
Posted On: 24 Minutes Ago
Replies: 17
Views: 430
0 How many miles are on your sporty?
Last Post: BKB
Posted On: 1 Hour Ago
Replies: 1,170
Views: 280,715
0 This week on Craig's list
Last Post: ryder rick
Posted On: 1 Hour Ago
Replies: 4,114
Views: 471,821
0 Poweraythor alternator conversion
Last Post: ryder rick
Posted On: 1 Hour Ago
Replies: 46
Views: 16,521
0 Which cams ?
Last Post: gusm2
Posted On: 1 Hour Ago
Replies: 3
Views: 83
0 The White Bike is the Right Bike Thread.
Last Post: A Seabee
Posted On: 2 Hours Ago
Replies: 198
Views: 59,520
0 need service information for my '71 Ironheqad
Last Post: Toejam503
Posted On: 2 Hours Ago
Replies: 6
Views: 75
3 Wtb, Wts, Wtt, Wtg (Ironhead)
Last Post: SHAKY DAVE
Posted On: 2 Hours Ago
Replies: 112
Views: 229,638
0 Torque Cones
Last Post: Toejam503
Posted On: 2 Hours Ago
Replies: 9
Views: 93
0 Ironhead Survey: Most desired bike
Last Post: IronMick
Posted On: 2 Hours Ago
Replies: 78
Views: 11,876
0 ....1
Last Post: Graywolf
Posted On: 2 Hours Ago
Replies: 4,879
Views: 282,684
0 How many when You park.... (Leave Your Bike In Gear)
Last Post: boomerguy
Posted On: 3 Hours Ago
Replies: 367
Views: 49,427
0 Throttle Cable Adjustment Question
Last Post: wedge
Posted On: 3 Hours Ago
Replies: 50
Views: 920
0 I recieved my new 1960 XLCH from New-Orleans
Last Post: Model H
Posted On: 4 Hours Ago
Replies: 551
Views: 74,614
0 Stator wire hot!
Last Post: oldboy
Posted On: 4 Hours Ago
Replies: 29
Views: 646
0 Harley quoted me $1300 for a mini ape install
Last Post: Lowe175
Posted On: 4 Hours Ago
Replies: 170
Views: 36,619
0 Happy Birthday 'jzink0883'
Last Post: Folkie
Posted On: 5 Hours Ago
Replies: 1
Views: 27
0 will not start
Last Post: 01rk
Posted On: 5 Hours Ago
Replies: 26
Views: 709
0 Do Loud Pipes in fact save lives?
Last Post: wedge
Posted On: 5 Hours Ago
Replies: 2,490
Views: 259,214
0 2019 East Coast Meet and Greet
Last Post: sprink
Posted On: 5 Hours Ago
Replies: 322
Views: 35,471
0 For Sale: 2012 XR1200X
Last Post: joes95bobber
Posted On: 5 Hours Ago
Replies: 17
Views: 631
0 Jockey Shifter on a Right Side Shift Bike?
Last Post: dodgetrucken
Posted On: 5 Hours Ago
Replies: 50
Views: 15,304
6 1997 Sportster S putting +4 front shocks??
Last Post: Toejam503
Posted On: 6 Hours Ago
Replies: 7
Views: 323
0 Do you blip the throttle when downshifting?
Last Post: boomerguy
Posted On: 6 Hours Ago
Replies: 457
Views: 73,149
0 Wet sumping?
Last Post: Toejam503
Posted On: 6 Hours Ago
Replies: 92
Views: 3,548
0 Some oil issues!
Last Post: bustert
Posted On: 6 Hours Ago
Replies: 19
Views: 668
0 Marshwood Vale, 17th June 2019
Last Post: ChinCactus
Posted On: 7 Hours Ago
Replies: 3
Views: 64
0 Hottie of the day, no nudity.
Last Post: Stairman
Posted On: 7 Hours Ago
Replies: 11,720
Views: 1,053,038
More...
Members Birthdays
breilly888 (67), txsporty (63), michtif (54), Rabs (46)
Sponsored Links
Reply
 
Share Thread Tools Display Modes
  #11  
Old 3rd October 2007
Todd31de's Avatar
Todd31de Todd31de is offline
Chief Harley Engineer
 
Join Date: Jan 2007
Location: Newark, Delaware
Posts: 587
Sportster/Buell Model: XLH 1100
Sportster/Buell Year: 1987
Sportster/Buell Model #2: Road Glide FLTRI
Sportster/Buell Year #2: 06
Other Motorcycle Model: Norton Commando
Other Motorcycle Year: 1970
Reputation: 88429
Todd31de has much to be proud ofTodd31de has much to be proud ofTodd31de has much to be proud ofTodd31de has much to be proud ofTodd31de has much to be proud ofTodd31de has much to be proud ofTodd31de has much to be proud ofTodd31de has much to be proud ofTodd31de has much to be proud ofTodd31de has much to be proud ofTodd31de has much to be proud of
Default

Also don't forget if you don't have a spare relay with you, HIT IT!!!. Doesn't work all the time but it just may get you by.

My starter relay went bad and smacking with the end of a screw driver while pushing the starter button was enough so I could get to the dealer to pick up a a new one.
__________________
87 Xlh1100 Streetracker
70 Norton Commando

"Beer is proof god loves us and wants us to be happy" Benjamin Franklin
Reply With Quote
  #12  
Old 6th October 2007
Moved On / My Own Choice Moved On / My Own Choice is offline
Senior Master Custom Bike Builder
 
Join Date: Sep 2005
Posts: 18,120
Moved On / My Own Choice has disabled reputation
Default

Quote:
Originally Posted by ColinB View Post
Hi, although I'm not Kev (phew!) I followed his advice and got myself a spare relay - mine was already corroding up after 4 months of a wet summer over here.

The number is 31601-04 Relay, SPST, Sealed (or so it sez on the pack)
Thanks for handling that for me.

Ya see, I don't use the same spare, since I use a 5-pin relay that can be a spare on the Guzzi too if need be.

K
Reply With Quote
  #13  
Old 10th October 2007
2007Low's Avatar
2007Low 2007Low is offline
Senior Chief Harley Engineer 2nd Class
 
Join Date: Oct 2007
Location: Southwestern Minnesota
Posts: 1,692
Sportster/Buell Model: XL1200 Low/TTS/Gronked
Sportster/Buell Year: 2007
Sportster/Buell Model #2: XLCH1000
Sportster/Buell Year #2: 1975
Reputation: 23358
2007Low is a name known to all2007Low is a name known to all2007Low is a name known to all2007Low is a name known to all2007Low is a name known to all2007Low is a name known to all2007Low is a name known to all2007Low is a name known to all2007Low is a name known to all2007Low is a name known to all2007Low is a name known to all
Default

2007 1200 low, mine will stumble usually once during warm up, sometimes just sitting and idling and sometimes when I first take off. Anyone else have this problem? Thanks
Reply With Quote
  #14  
Old 10th October 2007
Moved On / My Own Choice Moved On / My Own Choice is offline
Senior Master Custom Bike Builder
 
Join Date: Sep 2005
Posts: 18,120
Moved On / My Own Choice has disabled reputation
Default

Quote:
Originally Posted by 2007Low View Post
2007 1200 low, mine will stumble usually once during warm up, sometimes just sitting and idling and sometimes when I first take off. Anyone else have this problem? Thanks
Not really hte point of this thread, so why don't you start your own and I'll be glad to help.

That said, I THINK we've discussed this before.

I think it is normal, and tends to occur on our 1200L but only in the first 30 seconds or so, more likely on a colder startup. Doesn't seem to stumble more than once IF at all...
Reply With Quote
  #15  
Old 10th October 2007
rick szymanski's Avatar
rick szymanski rick szymanski is offline
Flat Track Champion
 
Join Date: Apr 2007
Posts: 638
Sportster/Buell Model: Sportster
Sportster/Buell Year: 2005
Reputation: 50261
rick szymanski is a splendid one to beholdrick szymanski is a splendid one to beholdrick szymanski is a splendid one to beholdrick szymanski is a splendid one to beholdrick szymanski is a splendid one to beholdrick szymanski is a splendid one to beholdrick szymanski is a splendid one to beholdrick szymanski is a splendid one to beholdrick szymanski is a splendid one to beholdrick szymanski is a splendid one to beholdrick szymanski is a splendid one to behold
Default

i had an issue a while back after my bike was painted. i was most of the way home from work...thank God, work's 24 miles from home. the bike sputtered and stalled applying throttle. had half a tank of gas, the second tank since painting. the problem at hand on the road was rush hour traffic, a curb on one side and guard rail on the other...nowhere to pull over. i kept messing with it to try to start it.... nothing. cranks like hell, but no start. cars were behind me...i damn sure wasn't pushing, i let the clutch out and cranked it lurching up a hill to a parking lot. i walked 2 miles home got gas and a car...filled the tank. started right up. ran like crap, but started. once i got the turd back to the house i checked the fuel at the carb...i could see it squirting and smell it. pulled a plug, wet looking...started thinking the jets i put in may be too large...didn't change them at this point. i did start to wonder if something from the painting got into the tank. i disconnected the line to the carb, pulled a vacuum on the diaphragm and drained a sample of gas...reserve side, duh! when water in fuel settles it looks urine pale. it was evenly pale and didn't smell right. i figured hell, drain it all and start fresh. i caught it all in pepsi bottles, 2liters and 20 ounces later(mixed measurements...different bottles) gas started flowing through. remember stalling can stem from something simple as filling up. check the basics before fixing stuff that wasn't broke until you tinkered.
Reply With Quote
  #16  
Old 10th October 2007
mstngjoe's Avatar
mstngjoe mstngjoe is offline
Know It All
 
Join Date: May 2007
Location: Milwaukie, Oregon
Posts: 158
Other Motorcycle Model: Softail Custom
Other Motorcycle Year: 2007
Reputation: 50
mstngjoe is an unknown quantity at this point
Default

Quote:
Originally Posted by 2007Low View Post
2007 1200 low, mine will stumble usually once during warm up, sometimes just sitting and idling and sometimes when I first take off. Anyone else have this problem? Thanks
Welcome to the XL Forums.

You'll find a wealth of good info here....

Try a subject search on "stumble". Might find some helpful input that way.
__________________
[SIGPIC][/SIGPIC]
2007 Softail Custom, Cobalt Pearl/Pewter Pearl, Khrome Werks HP+ slip-ons, ISO grips & pegs.
Reply With Quote
  #17  
Old 10th October 2007
ColinB ColinB is offline
Senior Master Custom Bike Builder
 
Join Date: May 2007
Posts: 3,745
Sportster/Buell Model: 883R
Sportster/Buell Year: 2007
Reputation: 1721574
ColinB has a reputation beyond reputeColinB has a reputation beyond reputeColinB has a reputation beyond reputeColinB has a reputation beyond reputeColinB has a reputation beyond reputeColinB has a reputation beyond reputeColinB has a reputation beyond reputeColinB has a reputation beyond reputeColinB has a reputation beyond reputeColinB has a reputation beyond reputeColinB has a reputation beyond repute
Default

Quote:
Originally Posted by 2007Low View Post
2007 1200 low, mine will stumble usually once during warm up, sometimes just sitting and idling and sometimes when I first take off. Anyone else have this problem? Thanks
Yep, mine does that and, like you say, just once about a minute after start up. It still did it after I put a Cobra Fueler on. It never stalls, just dips momentarily. I presume it's the 'electronic enricher' part of the EFI program getting 'pushed in' as it warms up.
Reply With Quote
  #18  
Old 13th October 2007
2007Low's Avatar
2007Low 2007Low is offline
Senior Chief Harley Engineer 2nd Class
 
Join Date: Oct 2007
Location: Southwestern Minnesota
Posts: 1,692
Sportster/Buell Model: XL1200 Low/TTS/Gronked
Sportster/Buell Year: 2007
Sportster/Buell Model #2: XLCH1000
Sportster/Buell Year #2: 1975
Reputation: 23358
2007Low is a name known to all2007Low is a name known to all2007Low is a name known to all2007Low is a name known to all2007Low is a name known to all2007Low is a name known to all2007Low is a name known to all2007Low is a name known to all2007Low is a name known to all2007Low is a name known to all2007Low is a name known to all
Default

Hi, I'm not sure which member mentioned it, it was quite a few pages back in one of these threads about EFI problems. But I think he was right on the money when he said "it's not the fuel pump, it's the fuel pressure regulator that's the problem", which is part of the fuel pump assembly. He also mentioned HD Tech Tip #328 and posted an excerpt from it which fixes the low fuel pressure that the faulty regulator is producing.

My bike was occasionally having a hiccup in the first few minutes after cold start. It also was only getting about 40 mpg consistently, city or highway. Yesterday I went to the dealer and had them install the service kit from Tech Tip #328 and I could definitely tell that it runs a little smoother which stands to reason if the fuel pressure is too low it doesn't atomize as well as when it is sprayed into the cylinders at a higher pressure. When they got done with my bike I filled it up for the 100 mile drive home and my fuel mileage went from 40 mpg to 51.25 mpg and this included drive 80 mph for 50 of the 100 miles that I drove. Jury is still out on the hiccup but so far so good.
Reply With Quote
Sponsored Links
  #19  
Old 13th October 2007
idahopilot's Avatar
idahopilot idahopilot is offline
Biker
 
Join Date: Dec 2004
Posts: 70
Sportster/Buell Model: XB12X
Sportster/Buell Year: 2008
idahopilot has disabled reputation
Default

2007Low,
Thank you so much for your post in this thread. What you are talking about is EXACTLY what I am experiencing with my 2007 1200R -- poor gas mileage, major league "stumbling" when cold, sometimes when warm. The bike just runs like crap -- always has. It was even more pronounced when I completed the stage I (I have since put the bike back to stock and am trying to sell it). I'm curious, what was your approach with the dealership? Did you tell them to do the Tech Tip #328 or was it something they offered? Any resistance? Is this tech tip covered under warranty? Thanks again.

Last edited by idahopilot; 13th October 2007 at 17:05.. Reason: added question
Reply With Quote
  #20  
Old 14th October 2007
2007Low's Avatar
2007Low 2007Low is offline
Senior Chief Harley Engineer 2nd Class
 
Join Date: Oct 2007
Location: Southwestern Minnesota
Posts: 1,692
Sportster/Buell Model: XL1200 Low/TTS/Gronked
Sportster/Buell Year: 2007
Sportster/Buell Model #2: XLCH1000
Sportster/Buell Year #2: 1975
Reputation: 23358
2007Low is a name known to all2007Low is a name known to all2007Low is a name known to all2007Low is a name known to all2007Low is a name known to all2007Low is a name known to all2007Low is a name known to all2007Low is a name known to all2007Low is a name known to all2007Low is a name known to all2007Low is a name known to all
Default

I told them about the problem and they wanted to keep the bike over night in order to do a stone cold start. I couldn't leave it with them and a couple days later after I started the bike, driving out of the parking lot it almost died on me. You know that if you're not quick on the clutch you could dump the bike. This really upset me so that afternoon I got on the phone with the dealer and expressed my concern with having to worry about this happening at the wrong time. At the same time I asked if they would install this service kit called out in the Tech Tip and they agreed to do that. I still don't know for sure if the stumble is gone, it did it again on the next stone cold start and ride. But on the next cold start it did not do it. I noticed that it doesn't pop anymore either when I roll off the throttle which I'm glad. Anyway I will just have to see how it acts the next few times I ride. I don't know if there is any truth to what some say about the computer relearning after something like this or if you disconnect the battery for a certain length of time and then the computer has to relearn. Anyway, that's my experience for now, I'll keep adding to this thread when I learn more.
Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Sponsored Links
All times are GMT +1. The time now is 06:48.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
XL Forum® - Linson Media LLC