The Sportster and Buell Motorcycle Forum - The XLFORUM®
 

Go Back   The Sportster and Buell Motorcycle Forum - The XLFORUM® > SPORTSTER MOTORCYCLE ZONE > Sportster Motorcycle General Discussion and Problems
XLF Blogs XLF Arcade XLF Disclaimer/Privacy Statement/Terms Of Use

Sportster Motorcycle General Discussion and Problems For discussing problems about your Sportster motorcycle that don't fit anywhere else.

Active Threads
0 Ironheads
Last Post: Glamazon
Posted On: 1 Hour Ago
Replies: 3
Views: 214
0 Salutations y'all
Last Post: juzyHD
Posted On: 2 Hours Ago
Replies: 3
Views: 50
0 Why does my kickstand do this...
Last Post: Fridge
Posted On: 2 Hours Ago
Replies: 15
Views: 347
0 Anyone go racing last weekend?
Last Post: Vohnsen
Posted On: 3 Hours Ago
Replies: 2,397
Views: 215,388
0 Iree's late night cafe
Last Post: Graywolf
Posted On: 3 Hours Ago
Replies: 787
Views: 66,078
0 My Not So Stock 1980 XLS < Brakes >
Last Post: brianbbs67
Posted On: 3 Hours Ago
Replies: 41
Views: 1,897
0 67 Sportster build
Last Post: brianbbs67
Posted On: 4 Hours Ago
Replies: 1
Views: 111
0 This week on Craig's list
Last Post: brianbbs67
Posted On: 4 Hours Ago
Replies: 3,405
Views: 306,790
0 Hottie of the day, no nudity.
Last Post: trainman
Posted On: 5 Hours Ago
Replies: 5,826
Views: 372,634
0 There’s shade tree brakes; then there’s the dark side of shade tree
Last Post: sdsbassist
Posted On: 5 Hours Ago
Replies: 70
Views: 7,060
0 3/8 24 Banjo bolt on V rod 11/16 master cylinder
Last Post: Grumpy-Biker
Posted On: 5 Hours Ago
Replies: 10
Views: 169
0 no rear brake light
Last Post: IXL2Relax
Posted On: 6 Hours Ago
Replies: 8
Views: 301
0 Turn signal won't blink when motor's on
Last Post: IXL2Relax
Posted On: 6 Hours Ago
Replies: 10
Views: 297
0 Any on make a flat 2up seat?
Last Post: geoff
Posted On: 6 Hours Ago
Replies: 63
Views: 25,264
0 What did you do for your sporty Today?
Last Post: goblin_dust
Posted On: 7 Hours Ago
Replies: 4,981
Views: 511,277
More...
Members Birthdays
1Scooter (68), wallylach (67), cob (64), decman (62), djhannu (56), Vaughn, irishhog (49), dangjalopy (45), earthoverdrive (40), edman87k5 (39), 79iron (36), mr_anti_chrome
Sponsored Links
Reply
 
Share Thread Tools Display Modes
  #1  
Old 14th August 2011
garykohl2's Avatar
garykohl2 garykohl2 is offline
Biker
 
Join Date: Aug 2011
Posts: 28
Sportster/Buell Model: 883
Sportster/Buell Year: 2002
Reputation: 28
garykohl2 is an unknown quantity at this point
Default Strange turn signal problem

Hey guys! I just got my 02 883 and it has and issue with the left turn signal (its been this way since I got it)
If the bike is just on but not running the left turn signal works fine. Once you start the bike it still works if the bike is just idleing. Once you give it some throttle though it freezes in the "high" light. So if I'm riding at any speed and go to use my left turn signal it just comes on bright and stays that way....no flashing at all. Any ideas?
Thanks guys
Reply With Quote
  #2  
Old 14th August 2011
Cosmo Kramer's Avatar
Cosmo Kramer Cosmo Kramer is offline
Senior Master Custom Bike Builder
 
Join Date: Sep 2008
Location: Anytown USA
Posts: 5,209
Sportster/Buell Model: 1200N
Sportster/Buell Year: 2007
Reputation: 350594
Cosmo Kramer has a reputation beyond reputeCosmo Kramer has a reputation beyond reputeCosmo Kramer has a reputation beyond reputeCosmo Kramer has a reputation beyond reputeCosmo Kramer has a reputation beyond reputeCosmo Kramer has a reputation beyond reputeCosmo Kramer has a reputation beyond reputeCosmo Kramer has a reputation beyond reputeCosmo Kramer has a reputation beyond reputeCosmo Kramer has a reputation beyond reputeCosmo Kramer has a reputation beyond repute
Default

Quote:
Originally Posted by garykohl2 View Post
Hey guys! I just got my 02 883 and it has and issue with the left turn signal (its been this way since I got it)
If the bike is just on but not running the left turn signal works fine. Once you start the bike it still works if the bike is just idleing. Once you give it some throttle though it freezes in the "high" light. So if I'm riding at any speed and go to use my left turn signal it just comes on bright and stays that way....no flashing at all. Any ideas?
Which one stays on bright?...front or rear?...or do they both do the same thing? When there isn't enough amps drawn from the turn signal module (due to a bulb being burnt out or bad ground) then the turn signal module doesn't flash.

My first thought is bad ground. Remove your bulbs and make sure there isn't a lot of corrosion in the sockets.
__________________
Cosmo

If you don't stand behind our troops, please, feel free to stand in front of them!
Reply With Quote
  #3  
Old 14th August 2011
garykohl2's Avatar
garykohl2 garykohl2 is offline
Biker
 
Join Date: Aug 2011
Posts: 28
Sportster/Buell Model: 883
Sportster/Buell Year: 2002
Reputation: 28
garykohl2 is an unknown quantity at this point
Default

Quote:
Originally Posted by Cosmo Kramer View Post
Which one stays on bright?...front or rear?...or do they both do the same thing? When there isn't enough amps drawn from the turn signal module (due to a bulb being burnt out or bad ground) then the turn signal module doesn't flash.

My first thought is bad ground. Remove your bulbs and make sure there isn't a lot of corrosion in the sockets.
It is the front and rear....they both do it. I will pull the bulbs and check them tomorrow. Thanks
Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Sponsored Links
All times are GMT +1. The time now is 09:39.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
XL Forum® - Linson Media LLC