The Sportster and Buell Motorcycle Forum - The XLFORUM®
 

Go Back   The Sportster and Buell Motorcycle Forum - The XLFORUM® > SPORTSTER MOTORCYCLE ZONE > Sportster Motorcycle Era Specific and Model Specific > EFI Sportster Motorcycle Talk (2007 and up)
XLF Blogs XLF Arcade XLF Disclaimer/Privacy Statement/Terms Of Use

EFI Sportster Motorcycle Talk (2007 and up) For 2007 and above Sportsters

Active Threads
5 Is anyone with an early sportster running a 38 mm Mikuni?
Last Post: Moon Wolf
Posted On: 10 Minutes Ago
Replies: 23
Views: 967
0 Pictures of Sportster Scene 1960s
Last Post: kaveebee
Posted On: 18 Minutes Ago
Replies: 1,809
Views: 760,927
0 What did you do for your sporty Today?
Last Post: lo-rider
Posted On: 42 Minutes Ago
Replies: 5,025
Views: 524,485
0 project 74 sporty
Last Post: Ferrous Head
Posted On: 44 Minutes Ago
Replies: 3
Views: 27
0 This is gonna hurt.
Last Post: CaptEvo
Posted On: 50 Minutes Ago
Replies: 7,368
Views: 1,305,965
0 HFSM issues with installing DK Customs push button on
Last Post: cotton1
Posted On: 1 Hour Ago
Replies: 5
Views: 160
0 Mikuni HSR42 Initial setup..
Last Post: The Crusher
Posted On: 1 Hour Ago
Replies: 0
Views: 23
0 Engine dies when choke off
Last Post: rokytnji
Posted On: 1 Hour Ago
Replies: 16
Views: 376
0 Feeling in trouble.
Last Post: needspeed
Posted On: 1 Hour Ago
Replies: 11
Views: 192
0 HER 42 gas leaking from drain hose?
Last Post: mikeLI_77
Posted On: 2 Hours Ago
Replies: 9
Views: 107
0 Dynatek DC6-5 coil
Last Post: jordan1200
Posted On: 2 Hours Ago
Replies: 10
Views: 134
0 newby from Australia
Last Post: philipml
Posted On: 2 Hours Ago
Replies: 12
Views: 162
0 Sportster Camshaft Degreeing ?
Last Post: bustert
Posted On: 2 Hours Ago
Replies: 57
Views: 3,374
0 Cylinder Piston kits
Last Post: chevelle
Posted On: 2 Hours Ago
Replies: 64
Views: 2,334
0 2nd year in a row paid member
Last Post: rokytnji
Posted On: 2 Hours Ago
Replies: 3
Views: 18
0 Show your favorite pic of your bike. just one
Last Post: Don Biter
Posted On: 2 Hours Ago
Replies: 4,658
Views: 1,707,852
10 New rider - XL1200S in Aus.
Last Post: Beelzeboss
Posted On: 2 Hours Ago
Replies: 22
Views: 1,338
0 What Sort Of Sporty Have You Got?
Last Post: blindfredy
Posted On: 3 Hours Ago
Replies: 1,025
Views: 259,926
0 Future of the sporty?
Last Post: felis
Posted On: 4 Hours Ago
Replies: 42
Views: 1,953
0 fuel in the oil tank
Last Post: IronMick
Posted On: 4 Hours Ago
Replies: 3
Views: 86
5 Another "new guy" rumor or fact question....
Last Post: Sadsack
Posted On: 4 Hours Ago
Replies: 16
Views: 891
0 Oil not returning to tank, venting oil
Last Post: Ben221
Posted On: 4 Hours Ago
Replies: 9
Views: 283
5 Am I looking for Trouble ?
Last Post: bustert
Posted On: 4 Hours Ago
Replies: 1
Views: 73
8 spark plug blew out on the freeway
Last Post: Hippysmack
Posted On: 5 Hours Ago
Replies: 21
Views: 1,118
0 Nighster seat on Iron
Last Post: BSA Bob
Posted On: 5 Hours Ago
Replies: 7
Views: 215
0 EFI manifold / throttle body question
Last Post: Screw Loose Dan
Posted On: 6 Hours Ago
Replies: 28
Views: 2,905
0 Well, damn. Cracked bracket.
Last Post: sportsterpaul
Posted On: 6 Hours Ago
Replies: 8
Views: 274
5 Transmission HELP!
Last Post: Ferrous Head
Posted On: 6 Hours Ago
Replies: 33
Views: 1,769
0 Tourmaster Transition 5 jacket:
Last Post: sportsterpaul
Posted On: 7 Hours Ago
Replies: 0
Views: 72
0 Official XL Forum Random Image Thread (NO NUDITY!)
Last Post: maltesefalcon
Posted On: 7 Hours Ago
Replies: 40,084
Views: 6,154,301
More...
Members Birthdays
dtw757 (64), XLH75Rider (63), JRLang13 (56), Shaerona (54), christophe (51), collectovince (50), buckethead (40), Hang_Em_High (38)
Sponsored Links
Reply
 
Share Thread Tools Display Modes
  #1  
Old 14th June 2010
Gone Gone is offline
Flat Track Champion
 
Join Date: Nov 2004
Posts: 619
Reputation: 4470
Gone is an unknown quantity at this pointGone is an unknown quantity at this pointGone is an unknown quantity at this pointGone is an unknown quantity at this pointGone is an unknown quantity at this pointGone is an unknown quantity at this pointGone is an unknown quantity at this pointGone is an unknown quantity at this pointGone is an unknown quantity at this pointGone is an unknown quantity at this pointGone is an unknown quantity at this point
Exclamation Sportster battery keeps dying (what's up)

My 2009 XL1200C has been perfect since I got it. Now for the first time I rode it 3 days in a row to work in straight rain.

The 4th day I went out to ride to work (no rain), I went out to start the bike and dead battery (not even any lights or anything). Put on a trickle charge overnight and bike starts up and ride around for an hour. Bike will start up right away after bike is shut off so I'm thinking it's kept it's charge.

Next morning dead again. Any suggestions. I have an HD security system on it and instead of the usual pulsating key light, it's on a steady bright red after I turn off the bike. I also notice I now don't always get that sound of the Fuel Injector before start up. Weird...

I'm thinking something is running after I turn off the bike but can't put my finger on it. Did the ride in the rain cause this?

Please help.

Thanks,

Silver

PS - I didn't take out the key on ACC it was completely off.
Reply With Quote
  #2  
Old 14th June 2010
snowman's Avatar
snowman snowman is offline
Senior Master Custom Bike Builder
 
Join Date: Dec 2005
Location: Saline, MI
Posts: 10,007
Sportster/Buell Model: Gone...
Sportster/Buell Year: 2008
Other Motorcycle Model: The Beast (M109R)
Other Motorcycle Year: 2006
Reputation: 86254
snowman has much to be proud ofsnowman has much to be proud ofsnowman has much to be proud ofsnowman has much to be proud ofsnowman has much to be proud ofsnowman has much to be proud ofsnowman has much to be proud ofsnowman has much to be proud ofsnowman has much to be proud ofsnowman has much to be proud ofsnowman has much to be proud of
Default

Check the cable ground connections...
__________________
--Russ--
U.S. Army Veteran

***RIP***
--Mr. JIMI
--JOHNNY G
--BryanEOD
Reply With Quote
  #3  
Old 14th June 2010
joesporty's Avatar
joesporty joesporty is offline
Custom Bike Builder
 
Join Date: Apr 2006
Location: southwest lower michigan..
Posts: 2,390
Sportster/Buell Model: xl 883
Sportster/Buell Year: 2008
Other Motorcycle Model: kz750
Other Motorcycle Year: 1976
Reputation: 186715
joesporty has a brilliant futurejoesporty has a brilliant futurejoesporty has a brilliant futurejoesporty has a brilliant futurejoesporty has a brilliant futurejoesporty has a brilliant futurejoesporty has a brilliant futurejoesporty has a brilliant futurejoesporty has a brilliant futurejoesporty has a brilliant futurejoesporty has a brilliant future
Default

and all the fuses...
__________________
SMOKEY BURNOUT MASTER OF THE WORLD!!!!!
08 XL883;HAMMER 1250,Heavy breather,Rinehart 2-1, Power Vision,Ebc floating rotor,XR1200 Nissin caliper,1200R Mastery cylinder,RK shocks,1in tank lift,wire tuck,crossroads fork brace,low rise drag bars int.wired,Goodridge Ss line,Chrome valve stem covers, and a few top secret parts..:smoke
Reply With Quote
  #4  
Old 14th June 2010
Screw Loose Dan's Avatar
Screw Loose Dan Screw Loose Dan is offline
I think I like Sportsters
 
Join Date: Oct 2006
Location: Collegeville, PA
Posts: 6,899
Sportster/Buell Model: 883L (sorta) & a 1200R
Sportster/Buell Year: 2007
Sportster/Buell Model #2: 1200CX
Sportster/Buell Year #2: 2016
Other Motorcycle Model: XR1200X
Other Motorcycle Year: 2012
Reputation: 2488933
Screw Loose Dan has a reputation beyond reputeScrew Loose Dan has a reputation beyond reputeScrew Loose Dan has a reputation beyond reputeScrew Loose Dan has a reputation beyond reputeScrew Loose Dan has a reputation beyond reputeScrew Loose Dan has a reputation beyond reputeScrew Loose Dan has a reputation beyond reputeScrew Loose Dan has a reputation beyond reputeScrew Loose Dan has a reputation beyond reputeScrew Loose Dan has a reputation beyond reputeScrew Loose Dan has a reputation beyond repute
Default

Check the all the battery connections and fuses (as the others mentioned). Also, pull the relays and see if there is any corrosion. It's a well known issue with the EFI bikes that they goofed with the wiring harness and the relays often get corroded. There's a few different symptoms, one of them being battery dying because the corrosion allows the battery to drain.

Do you have a voltmeter (and know how to take volt readings)? It's pretty easy to check if the charging system is working.
__________________
Screw Loose Dan
Current fleet:
2007 - 1200R (Orange bike)
2012 - XR1200X (XR)
2016 - 1200CX Roadster (new one)
2007 - 883L/90" -current project - (Black bike)
Reply With Quote
  #5  
Old 14th June 2010
PaulDM PaulDM is offline
Senior Chief Know It All 1st Class
 
Join Date: May 2007
Posts: 1,159
Sportster/Buell Model: XL 883
Sportster/Buell Year: 2007
PaulDM has disabled reputation
Default

I had the same symptoms, dead battery after sitting overnight. In diagnosing the electrical drain I noticed that the efi pump was slowly running. I replaced the relay and it's been fine since. Last week the bike didn't want to start, it felt like a problem with the switch itself, I broke out my spare relay and installed it and that problem went away too.
__________________
2007 XL 883 - 1/4 Harley Fairing - ISO grips and pegs - Mustang Vintage wide - Adjure Reflector & PIAA bulb - 50 State Mufflers - ABS front fender - Tail pack for stuff - HyperPro progressive fork springs - Whittlebeast rear shocks = Rocky Mountain Sport Tourer :-)
Reply With Quote
  #6  
Old 15th June 2010
Bone's Avatar
Bone Bone is offline
Senior Master Custom Bike Builder
 
Join Date: Jun 2009
Location: Medford, NJ
Posts: 10,505
Sportster/Buell Model: 1200Lr
Sportster/Buell Year: 2007
Sportster/Buell Model #2: FLHP
Sportster/Buell Year #2: 2016
Other Motorcycle Model: 13 Guzzi V7 / 11 Duc 696
Other Motorcycle Year: 2013
Reputation: 2595771
Bone has a reputation beyond reputeBone has a reputation beyond reputeBone has a reputation beyond reputeBone has a reputation beyond reputeBone has a reputation beyond reputeBone has a reputation beyond reputeBone has a reputation beyond reputeBone has a reputation beyond reputeBone has a reputation beyond reputeBone has a reputation beyond reputeBone has a reputation beyond repute
Default

Yup to what Dan said - I seem to remember some threads about corroded relays allowing the IAC valve to constantly cycle with the key off which would slowly drain the battery.
Reply With Quote
  #7  
Old 15th June 2010
LuxBlue's Avatar
LuxBlue LuxBlue is offline
Senior Master Custom Bike Builder
 
Join Date: Nov 2004
Location: South of Lancaster, PA
Posts: 4,034
Sportster/Buell Model: XL 1200 Custom
Sportster/Buell Year: 2004
Reputation: 314267
LuxBlue has a reputation beyond reputeLuxBlue has a reputation beyond reputeLuxBlue has a reputation beyond reputeLuxBlue has a reputation beyond reputeLuxBlue has a reputation beyond reputeLuxBlue has a reputation beyond reputeLuxBlue has a reputation beyond reputeLuxBlue has a reputation beyond reputeLuxBlue has a reputation beyond reputeLuxBlue has a reputation beyond reputeLuxBlue has a reputation beyond repute
Default

+ 1 on everything said here. Your riding in the rain and / or washing has corroded your relay terminals resulting in your fuel pump probably running all the time. Easy fix to clean the corrosion and I would recommend spraying the back side of the board with a conformal coating of some sort.
__________________
Jester Mafia Member * TC88A Ignition With Rico's Jester III Map *
Reply With Quote
  #8  
Old 15th June 2010
Bone's Avatar
Bone Bone is offline
Senior Master Custom Bike Builder
 
Join Date: Jun 2009
Location: Medford, NJ
Posts: 10,505
Sportster/Buell Model: 1200Lr
Sportster/Buell Year: 2007
Sportster/Buell Model #2: FLHP
Sportster/Buell Year #2: 2016
Other Motorcycle Model: 13 Guzzi V7 / 11 Duc 696
Other Motorcycle Year: 2013
Reputation: 2595771
Bone has a reputation beyond reputeBone has a reputation beyond reputeBone has a reputation beyond reputeBone has a reputation beyond reputeBone has a reputation beyond reputeBone has a reputation beyond reputeBone has a reputation beyond reputeBone has a reputation beyond reputeBone has a reputation beyond reputeBone has a reputation beyond reputeBone has a reputation beyond repute
Default

FWIW Lux, I've never heard of/seen the fuel pump run because of the relays...because I'm pretty sure it takes the ECM to complete that circuit, but it's same idea, some components of the EFI system are cycling when the relay clicks shut... I guess in theory the fuel pump might cycle too then I dunno
Reply With Quote
  #9  
Old 15th June 2010
LuxBlue's Avatar
LuxBlue LuxBlue is offline
Senior Master Custom Bike Builder
 
Join Date: Nov 2004
Location: South of Lancaster, PA
Posts: 4,034
Sportster/Buell Model: XL 1200 Custom
Sportster/Buell Year: 2004
Reputation: 314267
LuxBlue has a reputation beyond reputeLuxBlue has a reputation beyond reputeLuxBlue has a reputation beyond reputeLuxBlue has a reputation beyond reputeLuxBlue has a reputation beyond reputeLuxBlue has a reputation beyond reputeLuxBlue has a reputation beyond reputeLuxBlue has a reputation beyond reputeLuxBlue has a reputation beyond reputeLuxBlue has a reputation beyond reputeLuxBlue has a reputation beyond repute
Default

Quote:
Originally Posted by Bone View Post
FWIW Lux, I've never heard of/seen the fuel pump run because of the relays...because I'm pretty sure it takes the ECM to complete that circuit, but it's same idea, some components of the EFI system are cycling when the relay clicks shut... I guess in theory the fuel pump might cycle too then I dunno

Could be? What I should have said is corrosion is causing some kind of sneak path on the relay board making some component run and drain the battery.
Reply With Quote
Sponsored Links
  #10  
Old 15th June 2010
crospo's Avatar
crospo crospo is offline
Harley Engineer
 
Join Date: Dec 2004
Location: Vancouver Island
Posts: 329
Sportster/Buell Model: 04 XL1200R
Other Motorcycle Model: Yamaha Seca400
Other Motorcycle Year: 1982
crospo has disabled reputation
Default

Pull the main 30Amp fuse overnight.If battery is still fully charged at least you know there's a drain somewhere.Then you can likely rule out the battery and charging system.
Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Sponsored Links
All times are GMT +1. The time now is 06:14.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
XL Forum® - Linson Media LLC