PDA

View Full Version : Clutch Grabbing Problem Solved


gilx
20th September 2005, 05:34
Fixed my clutch this past weekend, but not certain which of the two things I did contributed the most. Bought my bike new in June 2004. I had the local dealer do the 1k and the 5k. I did the 10k and just did the 15k this past weekend myself. Ever since I've had the bike, when I let out the clutch it felt like it grabbed...not a smooth release into first gear. It was particularly noticeable if I was riding two up. Last weekend I changed from Syn3 to Amsoil 20-50 for both motor and transmission. Also, I was very careful to make sure not to over fill the transmission. The first time I changed the transmission oil myself at the 10k, I refilled it to where I thought the manual said to...as far as I could see. However, since the 10k I have been having oil leak problems from the primary chain inspection port. This time, I filled the last little bit very slowly to let the oil settle to make sure I didn't go above the bottom of the clutch return plate. It must have worked because I no longer have the oil leak problem. More importantly I no longer feel any grabbing going into first gear. I can be riding two up, stopped up hill and still no grab on takeoff! Smooth as butter...or Amsoil! Actually, I suspect I must have been a little over for all of my oil changes until the 15k...but I also think the Amsoil is helping as the noise seems to be considerably less. Thought I would share the observations.

Moker
20th September 2005, 05:45
butter can't be good in the tranny....

my 2 cents

bobthebuilder
20th September 2005, 07:49
Getting rid of the SYN3 fixed your problem.

Great in the motor, no good in the primary/tranny, no matter what the moco says...

(IMHO anyway)

I had crap clutch feel and engagement issues (when warm) with the SYN3. I adjusted, dealer adjusted, I renewed the fluid, dealer renewed the fluid - same symptoms.

Changed back to Sporttrans - problem went away...

(I'd initially put the SYN3 in there to improve the shifting, which it definately seemed to do at the time, but since changing back, seems to continue to shift well too - I think I just learned to shift a Harley properly :-)

Bob