PDA

View Full Version : My Bike Runs Great Again !!!


Moved On
12th July 2006, 03:57
My bike has been running like crap since last November, but I finally nailed that sucker :D

Summary: It would cough and sputter after driving about 10 miles for about a mile. It would run great cold and great hot, just that 10 mile point it would run like crap for a little bit. Here's a few threads where I talked about the problem with folks...

Static Timing Check - Confusion (http://www.xlforum.net/vbportal/forums/showthread.php?t=28540)
2.5 Vacuum Questions (http://www.xlforum.net/vbportal/forums/showthread.php?t=28597)
Engine - Stutter Stutter KaBANG (http://www.xlforum.net/vbportal/forums/showthread.php?t=15996)

I finally broke down and bought a new ignition module for $150. It runs great again, no sputtering at ten miles or any oter point and it seems to be running smoother than I can remember it havin run in a long time overall.

Funny story with the ignition module... I was riding to work last Friday and the bike was running worse than ever. So I decided I need to get that ignition module and try that because I'm running out of ideas. Stopped at the dealer after work. I stood in line for a while, the first parts counter guy asked what I needed and I asked for the parts catalog because I wanted some deutsch connector pins too. A few minutes later the second guy asks if I've been helped, I was still looking for the connector pins but I asked how much the module was and rattled off the part number. He told me he had one in stock, and he went out back and got it for me. I looked at it and kept looking at the catalog then the parts manager came over and helped me get the pins. I mentioned the ignition module to him, he didn't realize I was holding one so he said "I have SE modules and they cost less $119", so I ask him to get it. He comes out with one and it's for a 1200. Neither him or I knew the difference so I said I'll take the 883 OEM stock module............ he says he doesn't have any they've all been on back order and he's been calling dealers all around the state to find one for a guy in the shop. So I said "I have one right here", he looked and said "where the heck did you get that?" I just pointed to the stock room. He said "well you do more buisness here than the guy out back so you can have it", and I said "damn right I have my hands on it and there's no way you're getting it back now" :D

Well I hope if the guy waiting for the 883 ignition module is reading this I'm not in too much rouble, but your new ignition module works great :shhhh

Thanks for all of the suggestions I got from everybody especialy Chris.

Gazza

chrishajer
12th July 2006, 03:59
Hey, rock on. Glad you fixed it. I have all these unresolved threads in the back of my gourd and I can check yours off now. Thanks for posting to resolution.

--Chris

renpia
12th July 2006, 04:07
Gazza, I had a similar problem. Replaced the ingition with an SE and solved all my hesitation, sputtering problems. Why didn't you go with the SE though? It has a higher rev limiter.

Moved On
12th July 2006, 04:08
None in stock for 883 and I hate waiting.

Gazza

renpia
12th July 2006, 04:10
I wonder if the SE for the 1200 would work on an 883.

Moved On
12th July 2006, 04:13
It might, but I didn't know the difference nor did the parts manager. He said the folks out back in service (it's a different building because their remodelling big time) would know but I wasn't about to leave my only 883 module in the state behind on the counter to go ask them :D

Gazza

Jojo_Dogboy
16th May 2007, 18:00
I wonder if the SE for the 1200 would work on an 883.
I read someware can't remember now where that the 1200 sport ignition module has a better advance curve. The is no difference on crane or daytona as to 1200 or 883 so I don't see why it wouldn't work. I ordered the Crane but the wiring harness dosent match up and need to make a deutch gender bender.

Hanoverfiste
16th May 2007, 18:20
Glad you nailed it!!, Im envious, I havent heard my bike run for over a year now!!

NoBoZoS
16th May 2007, 19:13
Hey

I have an 03 883 OEM ignition module take off if they're looking for one!