PDA

View Full Version : Oil Leak?


black1200r
2nd March 2005, 22:06
I just installed my cycle shack slip-on's and started her up after 4 months. I went inside to get my wife to listen to how great they sound. When I returned, there were oil spots on the bottom pipe. I couldn't locate where they were coming from but seemed only to be on the muffler. Should I be worried, or is this normal after a few months not running?

Wizwill
2nd March 2005, 22:19
When I first fired up my bike after the installation of SE II mufflers, there was a lot of smoke belching out of the pipes for a few minutes. I suspect it came from the manufacturing process because it has not continued. Perhaps this is the source of the oil on your mufflers.

mountbkr
2nd March 2005, 22:21
I don't know if it is normal but had a similar experience after not running for a while but hasn't happened lately. I read an article where sportsters sometimes drain there oil into the lower part of there moter because there is a checkvalve that sometime sticks open .The article was in AIM not sure what month it was in .Any body else?

black1200r
2nd March 2005, 22:22
I considered that, but the oil is on the TOP of the muffler, so I don't see how it could have gotten there? I even took off the air filter, but no oil there...

powereng
2nd March 2005, 23:59
black1200r, due to the freaking cold Michigan weather, oil seals have a tendance to shrink during extended periods of non-use. I would not worry. I would also suggest that we both move to Texas and get some damn sun!

black1200r
3rd March 2005, 03:04
thanks, I won't worry anymore unless it does it once (if?) riding season gets here! amen to texas, maybe I should have bought a snowmobile--harley should start building one!!!