PDA

View Full Version : Cam Help


kariglam1
28th January 2007, 08:30
Hello everyone need some advice, i went to install my new cams and when i took of the cover cam #2 came out with it i tried to keep it in but it just wouldn't stay, anyway i put it into 5th gear and lined up the pinion gear pointing to cam #2 bushing like it says in the manual and installed the cams now, i was wondering if that is ok and everything will be fine or am i going to have to do something else so that it is right thanks for any help.

TomSchneider
28th January 2007, 08:41
Hello everyone need some advice, i went to install my new cams and when i took of the cover cam #2 came out with it i tried to keep it in but it just wouldn't stay, anyway i put it into 5th gear and lined up the pinion gear pointing to cam #2 bushing like it says in the manual and installed the cams now, i was wondering if that is ok and everything will be fine or am i going to have to do something else so that it is right thanks for any help.

just make sure that when everything is lined up(the cam gears), the front cylinder is at top dead center.

aswracing
28th January 2007, 15:26
just make sure that when everything is lined up(the cam gears), the front cylinder is at top dead center.

It won't be.

engine
28th January 2007, 16:58
It won't be.

YEP!!!!
When I did my cams, I noticed that the front piston is just after BDC, on its way up; with the cams lined up.

Gone
28th January 2007, 21:58
When I changed my cams I rotated the engine over a few times and kept checking the timing marks just to make sure.

I've bent a few valve's on my GS dragbike just by being too aggressive. Checking it twice or even 3 times can't hurt.

kariglam1
15th February 2007, 03:56
Thanks guys for your help after checking time after time after time making sure it was right when i started it up today i was glad i checked over and over again runs good and sounds good now i just can't wait till the monsoon stops so i can take it for a good drive.