PDA

View Full Version : 2000 Buell Blast


asdf38
27th April 2007, 07:39
so I have a small problem, my transmission has been acting funny and now it does nothing... a little history first off I am new to bikes, I know nothing... I am good with fixing cars/trucks but this is different... if I am pointed in the right direction I can prob. figure it out...? I am ordering the service manual so I will get that soon
my friend was driving it home from work and he stopped at a light and after that it wouldn't go... prior to this there was a rattling/clicking sound coming from the transmission and it would do some funny things every once in awhile... ie: I guess kinda grind when you tried to put it into first but it wasn't too bad... I drove it 70 miles on the freeway just prior to this happening and it was fine, I haven't been able to look at it myself yet but has this happened/normal I've heard a lot of smack about the blast so yeah I'm clueless plus it has 7000 miles on it whats the average mileage before something like this happens....? owell sorry for the story any input will help

chrishajer
27th April 2007, 19:12
If you're good at fixing cars and trucks, you'll be fine fixing he Blast. It is NOT any different: parts is parts.

Based on the little information you've provided, I would start with the simple stuff. Adjust the clutch, clutch cable and primary chain. If that does not fix it, take a quick peek at the belt pulleys. Make sure the belt is in good shape and the pulleys are both attached and the teeth look good, the bolts are tight, etc.

If all the external stuff is OK, then you need to start looking in the primary. It's probably a shifter or clutch issue rather than a transmission issue, so start taking pictures once you're in the primary. Chances are something will stand out.

Also, have your VIN checked for recalls. There was a pulley recall a while back, I forget what years it applied to.

Relax and take things one at a time. With a service manual, you'll do just fine. It's just a machine. And there are a lot of people here who can help.

--Chris

oreocat
12th February 2009, 15:05
did you get your buell transmission problem repaired? i am trading for a buell with apparently the same problem ove the internet. what repair did you require with your buell blast?

Gojira
12th February 2009, 15:09
did you get your buell transmission problem repaired? i am trading for a buell with apparently the same problem ove the internet. what repair did you require with your buell blast?

this thread is from 07 and i believe its the clip on the shift drum causing the problem they seem to break all the time but i could be wrong