PDA

View Full Version : coil problems???


GSB_77_XL
10th July 2005, 23:20
Well me coil is in the process of breaking down (I think). It has been unreliable all day long today. I was heading out for a ride with a buddy who just got his new sporty yesterday, it died at a stop light, but I was able to get it started. I didnt think any thing of it, But was hard to get it to start back up, got it started and took off. It was running rough at high RPM'S and the tach was going nuts at cruising speed bouncing back and forth rapidly between 3000 and 9000 RPM and kept dying on me. I was able to limp home and get it in the garage.

It is a 77 with electronic ignition
What brand of coil is the most recomended?

any help would be great.

TX,
Greg

Y2K
10th July 2005, 23:28
I always had good luck with Accell products
http://www.accwhse.com/accell.htm

GSB_77_XL
11th July 2005, 00:48
Thanks Y2K!! I was looking through jireh cycles catalog, and looking closely at them and the crane coils.

rottenralph
11th July 2005, 01:17
I have a accel coil in my garage that I painted flat black(did not like the green at the time). I will send it to you for 20 bucks shipped. Let me know if you are interested. I have a harley stock coil also. Almost new same price. Can't use, I have single fire ignition. I can take a pic. if you would like. I am just trying to help out and this is the cheap way to trouble shoot.

Y2K
11th July 2005, 01:19
Thanks Y2K!! I was looking through jireh cycles catalog, and looking closely at them and the crane coils.

I don't think you can go wrong with either one :smoke

IronMick
11th July 2005, 04:16
Which brand of electronic ignition do you have? I would consider getting the same brand coil and wires.

GSB_77_XL
12th July 2005, 05:51
Rotten Ralph,
That sounds like a good deal, I am interested. My bike does not have electronic ignition like I was told when I got it. The :censor guy said it was converted to it, but I cant find anything but points and a condenser on the bike and I dont have much money right now to put it on there, so I will just change the coil and see where that gets me.

Fisherman
12th July 2005, 06:20
GSB 77, my bike doesn't leak either. But, like me, it occassionally needs to take a leak.

GSB_77_XL
12th July 2005, 06:22
LOL mine leaks more than I do. I am going to adress the oil leaks this winter in the living room when it is too cold to ride.

Fisherman
12th July 2005, 18:28
When I first got mine I went crazy trying to find & fix all the leaks. New hoses, hose clamps. Kept having one I couldn't find up high over rear motor mount. Finally found it. A vibration created stress crack in the oil tank.

IronMick
13th July 2005, 02:04
The leak on my bike came from the joint between the generator and the case. Dripped down, blown back by the wind [how fast did i ride?], gets on the chain, sprayed all over the back wheel. Under the bike was a mess, the sproket cover was a mess, the oil pump was a mess on the outside. I unnecessarily dismantled the o-pump before discovering it was ok after all.

GSB_77_XL
13th July 2005, 05:49
I am going to change the hoses under it, and plan to go over it with a fine tooth comb this winter. It has a few issues from sitting for so long.