The Sportster and Buell Motorcycle Forum DK Customs  

Go Back   The Sportster and Buell Motorcycle Forum > SPORTSTER MOTORCYCLE ZONE > Sportster Motorcycle Era Specific and Model Specific > EFI Sportster Motorcycle Talk (2007 and up)
XLF Gallery XLF Classifieds XLF Blogs XLF Shout XLF Arcade XLF Disclaimer/Privacy Statement/Terms Of Use

EFI Sportster Motorcycle Talk (2007 and up) For 2007 and above Sportsters

Members Birthdays
seajay, Hugh Betcha (68), jimhd89 (65), JayFL459 (65), Big Al (58), dakota_dj (57), 10walt (55), kiltbill (55), timsvalk (54), horsewriter (49), Benetampa (37)
Motor Stage
RYCA Motors
DK Customs
RYCA Motors

Biltwell
Reply
 
Share Thread Tools Display Modes
  #1  
Old 7th July 2012
blazingtorque's Avatar
blazingtorque blazingtorque is offline
Biker
 
Join Date: Feb 2011
Location: Hemyock
Posts: 7
Sportster/Buell Model: XL1200 CUSTOM
Sportster/Buell Year: 2008
Reputation: 10
blazingtorque is an unknown quantity at this point
Default Sportster won't start!

Hi, MY 2008 XL1200 has been in my garage for the last two months, just gone to start it and all the lights and battery seem fine but when I put the switch to run it makes a high pitch noise then I go to start it and all I get is a clicking and the motor won't fire up.

Any suggestions on what might be the problem?
Reply With Quote
  #2  
Old 7th July 2012
rymax101's Avatar
rymax101 rymax101 is offline
Biker
 
Join Date: Jan 2011
Location: Robins AFB
Posts: 46
Sportster/Buell Model: Iron 883
Sportster/Buell Year: 2009
Reputation: 975
rymax101 will become famous soon enoughrymax101 will become famous soon enoughrymax101 will become famous soon enoughrymax101 will become famous soon enoughrymax101 will become famous soon enoughrymax101 will become famous soon enoughrymax101 will become famous soon enoughrymax101 will become famous soon enough
Default

most of the time it is just the charge on the battery. even if the lights come on the battery might not have enough amps to crank the motor. i would either jump the bike off another battery and ride it to charge the battery or put the battery on a charger for a couple hours and then see if it will start.
If these dont help it may be that you battery is bad.
__________________
2009 Iron 883 w/1200 conversion, fuelpak, r6c 8" z bar, shortshots,
Reply With Quote
  #3  
Old 7th July 2012
vlmuke's Avatar
vlmuke vlmuke is offline
Land Speed Record
 
Join Date: Apr 2011
Posts: 784
Sportster/Buell Model: 883 iron
Sportster/Buell Year: 2010
Sportster/Buell Model #2: 1200 custom
Sportster/Buell Year #2: 2006
Reputation: 16806
vlmuke is a name known to allvlmuke is a name known to allvlmuke is a name known to allvlmuke is a name known to allvlmuke is a name known to allvlmuke is a name known to allvlmuke is a name known to allvlmuke is a name known to allvlmuke is a name known to allvlmuke is a name known to allvlmuke is a name known to all
Default

+1 on charging the battery
__________________
I don't know it all Nor do I claim to
Reply With Quote
  #4  
Old 8th July 2012
blazingtorque's Avatar
blazingtorque blazingtorque is offline
Biker
 
Join Date: Feb 2011
Location: Hemyock
Posts: 7
Sportster/Buell Model: XL1200 CUSTOM
Sportster/Buell Year: 2008
Reputation: 10
blazingtorque is an unknown quantity at this point
Default

Sorry, should of said the bike is on a Optimate charger most of the time anyway.
Could it be another problem ?
Reply With Quote
  #5  
Old 8th July 2012
Cosmo Kramer's Avatar
Cosmo Kramer Cosmo Kramer is offline
XL FORUM TEAM MEMBER
 
Join Date: Sep 2008
Location: Anytown USA
Posts: 5,137
Sportster/Buell Model: 1200N
Sportster/Buell Year: 2007
Reputation: 308812
Cosmo Kramer has a reputation beyond reputeCosmo Kramer has a reputation beyond reputeCosmo Kramer has a reputation beyond reputeCosmo Kramer has a reputation beyond reputeCosmo Kramer has a reputation beyond reputeCosmo Kramer has a reputation beyond reputeCosmo Kramer has a reputation beyond reputeCosmo Kramer has a reputation beyond reputeCosmo Kramer has a reputation beyond reputeCosmo Kramer has a reputation beyond reputeCosmo Kramer has a reputation beyond repute
Default

Have you done anything recently to the bike?...anything? Removed the battery?...changed grips....washed the bike..etc etc.

Have you removed all the fuses and relays and applied dielectric grease to the terminal ends? If there a large amount of corrosion on the relays you are better to just replace them. That should be step #3 on 07'-09' sportsters. #1 is making sure you have a fully charged battery and #2 is making sure that the battery cables are WRENCH tight on both ends! They are notorious for loosening up and simply tightening them up with a screwdriver is not good enough.

The clicking you are hearing could be a bad relay or arching between the battery cable and the battery or ground.

If you have got past that point the next step would be too take your two relays you currently have and swap them and see what happens.

Lastly, you need to check to see if you have any diagnostic trouble codes stored.
__________________
Cosmo

If you don't stand behind our troops, please, feel free to stand in front of them!
Reply With Quote
Know Thy Hog

  #6  
Old 8th July 2012
motorend's Avatar
motorend motorend is offline
Senior Master Bike Builder
 
Join Date: Jan 2011
Posts: 2,140
Sportster/Buell Model: XL1200N (Sold)
Sportster/Buell Year: 2009
Other Motorcycle Model: FXDL
Other Motorcycle Year: 2014
Reputation: 82531
motorend has much to be proud ofmotorend has much to be proud ofmotorend has much to be proud ofmotorend has much to be proud ofmotorend has much to be proud ofmotorend has much to be proud ofmotorend has much to be proud ofmotorend has much to be proud ofmotorend has much to be proud ofmotorend has much to be proud ofmotorend has much to be proud of
Default

Most of the time won't do it on an old battery. I left mine off the charger for 10 days and the same thing happened. Got the clicking. Placed it on the charger for 2-3 hours till the light was green and it fired right up.
Reply With Quote
  #7  
Old 9th July 2012
ShadowMan ShadowMan is offline
Biker
 
Join Date: Mar 2012
Posts: 13
Sportster/Buell Model: XL1200C
Sportster/Buell Year: 2007
Reputation: 10
ShadowMan is an unknown quantity at this point
Default

I just experienced a similar situation, lights came on and fuel pump primed. I hit the starter button and all I heard was a click and everything went dark.
It turned out my battery connections were loose, tightened those and it fired right off.
Reply With Quote
  #8  
Old 10th July 2012
Mozvader's Avatar
Mozvader Mozvader is offline
Master Mechanic
 
Join Date: Oct 2011
Posts: 249
Sportster/Buell Model: Sportster Xl 883 Custom
Sportster/Buell Year: 2008
Other Motorcycle Model: 2014 Street Glide Special
Reputation: 6415
Mozvader is just really niceMozvader is just really niceMozvader is just really niceMozvader is just really niceMozvader is just really niceMozvader is just really niceMozvader is just really niceMozvader is just really niceMozvader is just really niceMozvader is just really niceMozvader is just really nice
Default

I notice your bike is a custom and most likely has the HD anti theft system with the "smart" fob. Check the battery in the key fob before you start tearing the bike apart.
Sounds like your ignition kill is kicking in.
Reply With Quote
  #9  
Old 15th July 2012
blazingtorque's Avatar
blazingtorque blazingtorque is offline
Biker
 
Join Date: Feb 2011
Location: Hemyock
Posts: 7
Sportster/Buell Model: XL1200 CUSTOM
Sportster/Buell Year: 2008
Reputation: 10
blazingtorque is an unknown quantity at this point
Default

Thanks for the coments and suggestions, after 24 hours on a charger bike fired up, so will now invest in a new battery.
Does anyone know if you can fit a heavy duty battery with out making any mods?
If so where can I get one and what is the model of the battery?

Thanks again for all your comments
Reply With Quote
  #10  
Old 15th July 2012
jguynn jguynn is offline
Flat Track Champion
 
Join Date: Nov 2009
Posts: 687
Sportster/Buell Model: 1200C
Sportster/Buell Year: 2007
Reputation: 4903
jguynn is just really nicejguynn is just really nicejguynn is just really nicejguynn is just really nicejguynn is just really nicejguynn is just really nicejguynn is just really nicejguynn is just really nicejguynn is just really nicejguynn is just really nicejguynn is just really nice
Default

When the battery in my 07 took a dump I ordered the direct replacement AGM from O'Reilly(sp?) auto parts. Good price, perfect fit, and plenty of juice.
__________________
John
2007 XL 1200C
"When I'm riding my motorcycle, I'm glad to be alive. When I stop riding my motorcycle, I'm glad to be alive." - Neil Peart
Reply With Quote
Know Thy Hog

Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Custom Search

All times are GMT +1. The time now is 14:56.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
XL Forum - Linson Media LLC