The Sportster and Buell Motorcycle Forum Motor Stage  

Go Back   The Sportster and Buell Motorcycle Forum > SPORTSTER MOTORCYCLE ZONE > Sportster Motorcycle Electrical > Sportster Motorcycle Lighting
XLF Gallery XLF Classifieds XLF Blogs XLF Shout XLF Arcade XLF Disclaimer/Privacy Statement/Terms Of Use

Members Birthdays
DaddyJay, sixshooter (67), cartoad2001 (65), Dirty Ernie (59), bri1200c (51), pquirk (48), GOTWA (45), gremlinsteve (45), lbowles2 (43), Guess (35), rnaway22es, landon283 (26)
Sky Smith Insurance
Lickscycles
DK Customs
Motor Stage

Lowbrow Customs
Reply
 
Share Thread Tools Display Modes
  #1  
Old 11th April 2007
Gone Gone is offline
Senior Chief Harley Engineer
 
Join Date: Nov 2004
Posts: 1,041
Gone is an unknown quantity at this pointGone is an unknown quantity at this pointGone is an unknown quantity at this pointGone is an unknown quantity at this pointGone is an unknown quantity at this pointGone is an unknown quantity at this pointGone is an unknown quantity at this pointGone is an unknown quantity at this pointGone is an unknown quantity at this pointGone is an unknown quantity at this pointGone is an unknown quantity at this point
Default Turn Signals Don't Blink

I Have An 2001 Xl883 Sportster With Stock Turn Signals And When My Bike Is Not Running, Just The Key On The Turn Signals Blink, But When I Run The Engine They Just Stay Illuminated, They Don't Blink Right Or Left Side, I Had A Run Brake Turnsignal Module In It Recently, But The Right Rear Run And Turn Signal Quit Working, The Right Front Would Work, But Not The Back, So I Unplugged It And Took It Out, And A Day Later I Started Having The Other Problem I Described In The Beginning, Does Anybody Have A Clue Whats Wrong With This ?? I Was Thinking The Turn Signal Self Canceler Module Is Bad ?? Any Help Would Be Appreciated, Thank You.... Bob..
Reply With Quote
  #2  
Old 11th April 2007
Gold951's Avatar
Gold951 Gold951 is offline
Flat Track Champion
 
Join Date: May 2006
Location: Richmond, VA
Posts: 666
Sportster/Buell Model: XLH
Sportster/Buell Year: 2003
Sportster/Buell Model #2: XLH
Sportster/Buell Year #2: 1977
Other Motorcycle Model: Yamaha Virago XV 700
Other Motorcycle Year: 1987
Reputation: 928
Gold951 will become famous soon enoughGold951 will become famous soon enoughGold951 will become famous soon enoughGold951 will become famous soon enoughGold951 will become famous soon enoughGold951 will become famous soon enoughGold951 will become famous soon enoughGold951 will become famous soon enough
Default

Loose connection at the trun signal module.
__________________
Cliff Hipsher
'86 Porsche 951 Kalahari Metallic
'03 883 XLH
ICC USN (Ret.)
Reply With Quote
  #3  
Old 12th April 2007
Gone Gone is offline
Senior Chief Harley Engineer
 
Join Date: Nov 2004
Posts: 1,041
Gone is an unknown quantity at this pointGone is an unknown quantity at this pointGone is an unknown quantity at this pointGone is an unknown quantity at this pointGone is an unknown quantity at this pointGone is an unknown quantity at this pointGone is an unknown quantity at this pointGone is an unknown quantity at this pointGone is an unknown quantity at this pointGone is an unknown quantity at this pointGone is an unknown quantity at this point
Default

I Noticed The Rear Tire Rubbed The Right Rear Turn Signal Wires Under The Rear Fender, So I Fixed That Problem And Checked For Loose Connection And Any Other Messed Up Wires, And I Still Have The Same Problem !
Reply With Quote
  #4  
Old 12th April 2007
trosga1's Avatar
trosga1 trosga1 is offline
Chief Know It All
 
Join Date: Oct 2005
Location: Mill Creek, WA
Posts: 423
Sportster/Buell Model: XL883L
Sportster/Buell Year: '05
Other Motorcycle Model: Heritage Softail Classic
Other Motorcycle Year: '11
Reputation: 1085
trosga1 has a spectacular aura abouttrosga1 has a spectacular aura abouttrosga1 has a spectacular aura abouttrosga1 has a spectacular aura abouttrosga1 has a spectacular aura abouttrosga1 has a spectacular aura abouttrosga1 has a spectacular aura abouttrosga1 has a spectacular aura about
Default

I have the Kuryakn module on my bike and the module has a connection for the load equalizer, and a second connecter for a "blank" tail that basically just plugs in to seal off the connection ends. If the blank or the load equalizer are not seated all the way in the lights will either stay on solid, blink opposite to the turn, or flash without blinking.
__________________
2011 FLSTC with Vance and Hines True Duals, Arlen Ness A/C, Fuelpak, LED Turn Signals/Taillight.
Reply With Quote
  #5  
Old 12th April 2007
Gone Gone is offline
Senior Chief Harley Engineer
 
Join Date: Nov 2004
Posts: 1,041
Gone is an unknown quantity at this pointGone is an unknown quantity at this pointGone is an unknown quantity at this pointGone is an unknown quantity at this pointGone is an unknown quantity at this pointGone is an unknown quantity at this pointGone is an unknown quantity at this pointGone is an unknown quantity at this pointGone is an unknown quantity at this pointGone is an unknown quantity at this pointGone is an unknown quantity at this point
Default

I took my run stop turnsignal module out and just have it stock now, and my turn signals will not blink when i start my bike, they just stay illuminated, and dont blink, but they will blink when i have the engine off, and the key on, just for the heck of it i plugged my run turn stop module back in and the right rear light does not light up as a running light, and also doesnt blink, but my right front does blink, so i'm really stumped ?? i just want to put it back stock and have blinkers ...
Reply With Quote
Know Thy Hog

  #6  
Old 20th April 2007
Gone Gone is offline
Senior Chief Harley Engineer
 
Join Date: Nov 2004
Posts: 1,041
Gone is an unknown quantity at this pointGone is an unknown quantity at this pointGone is an unknown quantity at this pointGone is an unknown quantity at this pointGone is an unknown quantity at this pointGone is an unknown quantity at this pointGone is an unknown quantity at this pointGone is an unknown quantity at this pointGone is an unknown quantity at this pointGone is an unknown quantity at this pointGone is an unknown quantity at this point
Default

I went ahead and went to Harley and paid $132.00 for the turn signal module, got it today, put it in and it fixed my problem, now my blinkers blink when I hit them, even when the engines running, stoked they work again..
Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Custom Search

All times are GMT +1. The time now is 10:56.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
XL Forum - Linson Media LLC